Ticket #10617: 0003-Remove-130-compat_net_dev_ops.patch-for-openswan.patch

File 0003-Remove-130-compat_net_dev_ops.patch-for-openswan.patch, 1.3 KB (added by kevin@…, 5 years ago)

Remove 130-compat_net_dev_ops.patch for openswan

  • deleted file net/openswan/patches/130-compat_net_dev_ops.patch

    From d8e5edc54ba01da707424536f99305679e827846 Mon Sep 17 00:00:00 2001
    From: Kevin Locke <kevin@kevinlocke.name>
    Date: Mon, 12 Dec 2011 16:59:28 -0700
    Subject: [PATCH 3/5] Remove 130-compat_net_dev_ops.patch for openswan
    
    This patch was merged upstream in commit
    dd5c1a87f7032a00422135d14e1f1247b38a40c8 in Sept 2010.  It is already
    included in v2.6.30 and later.
    
    Signed-off-by: Kevin Locke <kevin@kevinlocke.name>
    ---
     net/openswan/patches/130-compat_net_dev_ops.patch |   19 -------------------
     1 files changed, 0 insertions(+), 19 deletions(-)
     delete mode 100644 net/openswan/patches/130-compat_net_dev_ops.patch
    
    diff --git a/net/openswan/patches/130-compat_net_dev_ops.patch b/net/openswan/patches/130-compat_net_dev_ops.patch
    deleted file mode 100644
    index 46786fa..0000000
    + -  
    1 --- 
    2  linux/include/openswan/ipsec_kversion.h |    6 ++++++ 
    3  1 file changed, 6 insertions(+) 
    4  
    5 --- a/linux/include/openswan/ipsec_kversion.h 
    6 +++ b/linux/include/openswan/ipsec_kversion.h 
    7 @@ -393,6 +393,12 @@ 
    8  # endif 
    9  #endif 
    10   
    11 +#if LINUX_VERSION_CODE == KERNEL_VERSION(2,6,30) 
    12 +# ifndef CONFIG_COMPAT_NET_DEV_OPS 
    13 +#  define USE_NETDEV_OPS 
    14 +# endif 
    15 +#endif 
    16 + 
    17  #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31) 
    18  # define USE_NETDEV_OPS 
    19  #else