source: branches/backfire/toolchain/gcc/Config.in @ 29301

Last change on this file since 29301 was 29301, checked in by nico, 4 years ago

[backfire] cleanup: remove refs to unsupported "gemini" target

  • Property svn:eol-style set to LF
File size: 2.4 KB
Line 
1# Choose gcc version.
2
3choice
4        prompt "GCC compiler Version" if TOOLCHAINOPTS
5        default GCC_VERSION_3_4_6 if LINUX_2_4
6        default GCC_VERSION_4_2_4 if avr32
7        default GCC_VERSION_4_3_3 if powerpc64
8        default GCC_VERSION_4_3_3 if TARGET_coldfire
9        default GCC_VERSION_4_4_1 if ubicom32
10        default GCC_VERSION_4_3_3_CS if (mips || mipsel) && !(TARGET_octeon || TARGET_sibyte)
11        default GCC_VERSION_4_3_3_CS if (arm || armeb)
12        default GCC_VERSION_4_4_3 if powerpc
13        default GCC_VERSION_4_4_3 if (TARGET_octeon || TARGET_sibyte)
14        default GCC_VERSION_4_1_2
15        help
16          Select the version of gcc you wish to use.
17
18        config GCC_VERSION_3_4_6
19                bool "gcc 3.4.6"
20
21if !LINUX_2_4
22        config GCC_VERSION_4_1_2
23                bool "gcc 4.1.2"
24
25        config GCC_VERSION_4_2_4
26                bool "gcc 4.2.4"
27
28        config GCC_VERSION_4_3_3
29                bool "gcc 4.3.3"
30
31        config GCC_VERSION_4_3_4
32                bool "gcc 4.3.4"
33
34        config GCC_VERSION_4_4_1
35                bool "gcc 4.4.1"
36
37        config GCC_VERSION_4_4_2
38                bool "gcc 4.4.2"
39
40        config GCC_VERSION_4_4_3
41                bool "gcc 4.4.3"
42
43        config GCC_VERSION_LLVM
44                bool "llvm-gcc 4.2"
45                depends BROKEN
46
47        config GCC_VERSION_4_3_3_CS
48                bool "gcc 4.3.3 with CodeSourcery enhancements"
49
50        config GCC_VERSION_4_4_1_CS
51                bool "gcc 4.4.1 with CodeSourcery enhancements"
52                depends BROKEN
53
54        config GCC_VERSION_4_4_3_CS
55                bool "gcc 4.4.3 with CodeSourcery enhancements"
56                depends BROKEN
57
58endif
59
60endchoice
61
62config GCC_USE_GRAPHITE
63        bool
64        prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
65        depends GCC_VERSION_4_4_1 || GCC_VERSION_4_4_2 || GCC_VERSION_4_4_3
66
67config EXTRA_GCC_CONFIG_OPTIONS
68        string
69        prompt "Additional gcc configure options" if TOOLCHAINOPTS
70        default ""
71        help
72            Any additional gcc options you may want to include....
73
74config SSP_SUPPORT
75        bool
76        depends !GCC_VERSION_3_4_6
77        prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
78        default n
79        help
80            Enable Stack-Smashing Protection support
81
82config TLS_SUPPORT
83        bool
84        depends !GCC_VERSION_3_4_6 && UCLIBC_VERSION_NPTL
85        prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
86        default n
87        help
88            Enable Thread-local storage support
89
90config INSTALL_LIBSTDCPP
91        bool
92        prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
93        default y
94        help
95            Build/install c++ compiler and libstdc++?
96
97config INSTALL_LIBGCJ
98        bool
99        prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
100        default n
101        help
102            Build/install java compiler and GNU classpath ?
Note: See TracBrowser for help on using the repository browser.