source: trunk/openwrt/package/lua/patches/lua-5.0.2-config.patch @ 1066

Last change on this file since 1066 was 1066, checked in by nico, 12 years ago

Add lua package

  • Property svn:eol-style set to native
  • Property svn:keywords set to Author Date Id Revision
File size: 1.1 KB
  • lua-5.0.

    diff -ruN lua-5.0.2-orig/config lua-5.0.2-1/config
    old new  
    2525# interface (e.g., Linux, Solaris, IRIX, BSD, AIX, HPUX, and probably others), 
    2626# uncomment the next two lines. 
    2727# 
    28 #LOADLIB= -DUSE_DLOPEN=1 
    29 #DLLIB= -ldl 
     28LOADLIB= -DUSE_DLOPEN=1 
     29DLLIB= -ldl 
    3030# 
    3131# In Linux with gcc, you should also uncomment the next definition for 
    3232# MYLDFLAGS, which passes -E (= -export-dynamic) to the linker. This option 
    3333# allows dynamic libraries to link back to the `lua' program, so that they do 
    3434# not need the Lua libraries. (Other systems may have an equivalent facility.) 
    3535# 
    36 #MYLDFLAGS= -Wl,-E 
     36MYLDFLAGS= -Wl,-E 
    3737# 
    3838# On Windows systems. support for dynamic loading is enabled by default. 
    3939# To disable this support, uncomment the next line. 
     
    142142 
    143143# This should work in all Unix systems, but you may want to add options. 
    144144# 
    145 STRIP= strip 
     145STRIP= /bin/true 
    146146 
    147147# ------------------------------------------------------------------ install 
    148148 
Note: See TracBrowser for help on using the repository browser.