source: trunk/package/madwifi/patches/476-3.0_detection_fix.patch @ 27188

Last change on this file since 27188 was 27188, checked in by hauke, 5 years ago

madwifi: Fix linux 3.0 detection

Allows madwifi to be built against linux 3.0.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@…>

File size: 714 bytes
  • Makefile

    a b unload: 
    155155configcheck: 
    156156        @echo -n "Checking kernel configuration... " 
    157157         
    158         @# check version of kernel 
    159         @echo $(KERNELRELEASE) | grep -q -i '^[2-9]\.[4-9]\.' || { \ 
    160             echo "FAILED"; \ 
    161             echo "Only kernel versions 2.4.x and above are supported."; \ 
    162             echo "You have $(KERNELRELEASE)."; \ 
    163             exit 1; \ 
    164         } 
     158        @# check kernel version 
     159        @case $(KERNELRELEASE) in \ 
     160            2.[456].*) ;; \ 
     161            [3-9].*) ;; \ 
     162            *) echo "FAILED"; \ 
     163               echo "Only kernel versions 2.4.x and above are supported."; \ 
     164               echo "You have $(KERNELRELEASE)."; \ 
     165               exit 1 ;; \ 
     166        esac 
    165167         
    166168        @# check kernel configuration 
    167169        @if [ -z "$(CONFIG_SYSCTL)" ]; then \ 
Note: See TracBrowser for help on using the repository browser.