source: trunk/package/ppp/patches/405-no_multilink_option.patch @ 28497

Last change on this file since 28497 was 28497, checked in by nbd, 5 years ago

pppd: add a patch for overriding the path to /etc/ppp/ipv6-{up,down}

File size: 724 bytes
  • pppd/options.c

    a b option_t general_options[] = { 
    318318      "Enable multilink operation", OPT_PRIOSUB | OPT_ALIAS | 1 }, 
    319319    { "nomultilink", o_bool, &multilink, 
    320320      "Disable multilink operation", OPT_PRIOSUB | 0 }, 
    321     { "nomp", o_bool, &multilink, 
    322       "Disable multilink operation", OPT_PRIOSUB | OPT_ALIAS | 0 }, 
    323321 
    324322    { "bundle", o_string, &bundle_name, 
    325323      "Bundle name for multilink", OPT_PRIO }, 
    326324#endif /* HAVE_MULTILINK */ 
    327325 
     326    { "nomp", o_bool, &multilink, 
     327      "Disable multilink operation", OPT_PRIOSUB | OPT_ALIAS | 0 }, 
     328 
    328329#ifdef PLUGIN 
    329330    { "plugin", o_special, (void *)loadplugin, 
    330331      "Load a plug-in module into pppd", OPT_PRIV | OPT_A2LIST }, 
Note: See TracBrowser for help on using the repository browser.