source: trunk/toolchain/gcc/Config.in @ 27337

Last change on this file since 27337 was 27337, checked in by kaloz, 5 years ago

[toolchain/gcc]: bump the 4.4 flavour to 4.4.6

  • Property svn:eol-style set to LF
File size: 2.4 KB
Line 
1# Choose gcc version.
2
3choice
4        prompt "GCC compiler Version" if TOOLCHAINOPTS
5        default GCC_VERSION_4_3_3_CS if GCC_DEFAULT_VERSION_4_3_3_CS
6        default GCC_VERSION_4_3_5 if GCC_DEFAULT_VERSION_4_3_5
7        default GCC_VERSION_4_4_6 if GCC_DEFAULT_VERSION_4_4_6
8        default GCC_VERSION_LINARO
9        help
10          Select the version of gcc you wish to use.
11
12        config GCC_VERSION_4_3_5
13                bool "gcc 4.3.5"
14
15        config GCC_VERSION_4_4_6
16                bool "gcc 4.4.6"
17
18        config GCC_VERSION_4_6_1
19                bool "gcc 4.6.1"
20
21        config GCC_VERSION_LINARO
22                bool "gcc 4.5.x with Linaro enhancements"
23
24        config GCC_VERSION_LLVM
25                bool "llvm-gcc 4.2"
26                depends BROKEN
27
28        config GCC_VERSION_4_3_3_CS
29                bool "gcc 4.3.3 with CodeSourcery enhancements"
30
31        config GCC_VERSION_4_4_1_CS
32                bool "gcc 4.4.1 with CodeSourcery enhancements"
33
34endchoice
35
36config GCC_USE_GRAPHITE
37        bool
38        prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
39        depends GCC_VERSION_4_4 || GCC_VERSION_4_5 || GCC_VERSION_4_6
40
41config GCC_USE_SYSTEM_PPL_CLOOG
42        bool
43        prompt "Use the system versions of PPL and CLooG"
44        depends GCC_USE_GRAPHITE
45        default n
46
47config EXTRA_GCC_CONFIG_OPTIONS
48        string
49        prompt "Additional gcc configure options" if TOOLCHAINOPTS
50        default ""
51        help
52            Any additional gcc options you may want to include....
53
54config SSP_SUPPORT
55        bool
56        prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
57        default n
58        help
59            Enable Stack-Smashing Protection support
60
61config TLS_SUPPORT
62        bool
63        depends UCLIBC_VERSION_NPTL
64        prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
65        default n
66        help
67            Enable Thread-local storage support
68
69config SJLJ_EXCEPTIONS
70        bool
71        prompt "Use setjump()/longjump() exceptions" if TOOLCHAINOPTS
72        default n
73        help
74            Use old setjump()/longjump() exceptions instead of the newer
75            frame unwinding exceptions handling routines.  Warning: increases
76            code size and runtime memory usage.
77
78config INSTALL_LIBSTDCPP
79        bool
80        prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
81        default y
82        help
83            Build/install c++ compiler and libstdc++?
84
85config INSTALL_LIBGCJ
86        bool
87        depends on !GCC_VERSION_LLVM
88        prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
89        default n
90        help
91            Build/install java compiler and GNU classpath ?
92
93
94config INSTALL_GFORTRAN
95        bool
96        prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
97        default n
98        help
99            Build/install GNU fortran compiler ?
Note: See TracBrowser for help on using the repository browser.