Ignore:
Timestamp:
2008-06-11T18:34:38+02:00 (8 years ago)
Author:
florian
Message:

this patch cleans up lcd4linux deps. (#3521)

Signed-off-by: Michael Vogt <michu at neophob.com>

File:
1 edited

Legend:

Unmodified
Added
Removed
  • packages/utils/lcd4linux/Makefile

    r11322 r11438  
    1212PKG_REV:=877 
    1313PKG_VERSION:=r$(PKG_REV) 
    14 PKG_RELEASE:=1 
     14PKG_RELEASE:=2 
    1515 
    1616PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 
     
    2727  SECTION:=utils 
    2828  CATEGORY:=Utilities 
    29   DEPENDS:=+libncurses +libusb +libiconv +libgd 
     29  DEPENDS:=+libusb 
    3030  TITLE:=LCD display utility 
    3131  URL:=http://lcd4linux.bulix.org/ 
     
    131131endif 
    132132 
     133ifneq ($(CONFIG_LCD4LINUX_DRV_G15),) 
     134PKG_BUILD_DEPENDS += libgd 
     135endif 
     136 
     137ifneq ($(CONFIG_LCD4LINUX_DRV_LPH7508),) 
     138PKG_BUILD_DEPENDS += libgd 
     139endif 
     140 
     141ifneq ($(CONFIG_LCD4LINUX_DRV_LUIse),) 
     142PKG_BUILD_DEPENDS += libgd 
     143endif 
     144 
     145ifneq ($(CONFIG_LCD4LINUX_DRV_Noritake),) 
     146PKG_BUILD_DEPENDS += libgd 
     147endif 
     148 
     149ifneq ($(CONFIG_LCD4LINUX_DRV_serdisplib),) 
     150PKG_BUILD_DEPENDS += libgd, serdisplib 
     151endif 
     152 
    133153ifneq ($(CONFIG_LCD4LINUX_DRV_st2205),) 
    134 PKG_BUILD_DEPENDS += st2205tool 
     154PKG_BUILD_DEPENDS += libgd, st2205tool 
     155endif 
     156 
     157ifneq ($(CONFIG_LCD4LINUX_DRV_T6963),) 
     158PKG_BUILD_DEPENDS += libgd 
     159endif 
     160 
     161ifneq ($(CONFIG_LCD4LINUX_DRV_Curses),) 
     162PKG_BUILD_DEPENDS += libncurses 
     163endif 
     164 
     165ifneq ($(CONFIG_LCD4LINUX_DRV_X11),) 
     166PKG_BUILD_DEPENDS += libgd, libX11 
    135167endif 
    136168 
     
    138170PKG_BUILD_DEPENDS += libnmeap 
    139171endif 
     172 
     173ifneq ($(CONFIG_LCD4LINUX_PLUGIN_iconv),) 
     174PKG_BUILD_DEPENDS += libiconv 
     175endif 
     176 
     177ifneq ($(CONFIG_LCD4LINUX_PLUGIN_mysql),) 
     178PKG_BUILD_DEPENDS += libmysqlclient 
     179endif 
     180 
     181 
     182## TODO PYTHON PLUGIN, DEPENDS on ver >= '2.1.0' 
     183 
    140184 
    141185EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/lib/libiconv/include 
Note: See TracChangeset for help on using the changeset viewer.