Changeset 15880


Ignore:
Timestamp:
2009-05-17T02:25:41+02:00 (7 years ago)
Author:
nico
Message:

[package] openssl: fix annoying build errors when changing upstream versions

Files:
2 edited

Legend:

Unmodified
Added
Removed
  • branches/8.09/package/openssl/Makefile

    r15872 r15880  
    9393 
    9494define Build/Compile 
    95         rm -rf $(PKG_INSTALL_DIR) 
    96         mkdir -p $(PKG_INSTALL_DIR) 
     95        # XXX: OpenSSL "make depend" will look for installed headers before its own, 
     96        # so remove installed stuff first 
     97        -$(SUBMAKE) -j1 clean-staging 
    9798        $(MAKE) -C $(PKG_BUILD_DIR) \ 
    9899                MAKEDEPPROG="$(TARGET_CROSS)gcc" \ 
  • trunk/package/openssl/Makefile

    r15410 r15880  
    9494 
    9595define Build/Compile 
    96         rm -rf $(PKG_INSTALL_DIR) 
    97         mkdir -p $(PKG_INSTALL_DIR) 
     96        # XXX: OpenSSL "make depend" will look for installed headers before its own, 
     97        # so remove installed stuff first 
     98        -$(SUBMAKE) -j1 clean-staging 
    9899        $(MAKE) -C $(PKG_BUILD_DIR) \ 
    99100                MAKEDEPPROG="$(TARGET_CROSS)gcc" \ 
Note: See TracChangeset for help on using the changeset viewer.