Changeset 26398


Ignore:
Timestamp:
2011-04-02T04:24:38+02:00 (6 years ago)
Author:
nbd
Message:

ppp: fix fallout from the size reduction patch (thx, frogonwheels)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package/ppp/patches/400-simplify_kernel_checks.patch

    r25919 r26398  
    9191     if (sfd < 0) 
    9292        return 0; 
     93--- a/pppd/plugins/pppoatm/pppoatm.c 
     94+++ b/pppd/plugins/pppoatm/pppoatm.c 
     95@@ -210,14 +210,6 @@ static void recv_config_pppoa(int mru, 
     96  
     97 void plugin_init(void) 
     98 { 
     99-#ifdef linux 
     100-       extern int new_style_driver;    /* From sys-linux.c */ 
     101-       if (!ppp_available() && !new_style_driver) 
     102-               fatal("Kernel doesn't support ppp_generic - " 
     103-                   "needed for PPPoATM"); 
     104-#else 
     105-       fatal("No PPPoATM support on this OS"); 
     106-#endif 
     107        add_options(pppoa_options); 
     108 } 
     109  
     110--- a/pppd/plugins/rp-pppoe/plugin.c 
     111+++ b/pppd/plugins/rp-pppoe/plugin.c 
     112@@ -55,9 +55,6 @@ static char const RCSID[] = 
     113  
     114 char pppd_version[] = VERSION; 
     115  
     116-/* From sys-linux.c in pppd -- MUST FIX THIS! */ 
     117-extern int new_style_driver; 
     118- 
     119 char *pppd_pppoe_service = NULL; 
     120 static char *acName = NULL; 
     121 static char *existingSession = NULL; 
     122@@ -312,10 +309,6 @@ PPPoEDevnameHook(char *cmd, char **argv, 
     123 void 
     124 plugin_init(void) 
     125 { 
     126-    if (!ppp_available() && !new_style_driver) { 
     127-       fatal("Linux kernel does not support PPPoE -- are you running 2.4.x?"); 
     128-    } 
     129- 
     130     add_options(Options); 
     131 } 
     132  
Note: See TracChangeset for help on using the changeset viewer.