Ignore:
Timestamp:
2011-07-02T09:43:26+02:00 (5 years ago)
Author:
kaloz
Message:

[toolchain]: nuke support for older gcc versions, except for 4.4.6 (needed for avr32 and ubicom32)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/toolchain/gcc/Config.version

    r27350 r27351  
    11config GCC_DEFAULT_VERSION 
    2         bool 
    3  
    4 config GCC_DEFAULT_VERSION_4_3_3_CS 
    5         select GCC_DEFAULT_VERSION 
    6         bool 
    7  
    8 config GCC_DEFAULT_VERSION_4_3_5 
    9         select GCC_DEFAULT_VERSION 
    102        bool 
    113 
     
    2214config GCC_VERSION 
    2315        string 
    24         default "4.3.3+cs"  if GCC_VERSION_4_3_3_CS 
    25         default "4.3.5"     if GCC_VERSION_4_3_5 
    26         default "4.4.1+cs"  if GCC_VERSION_4_4_1_CS 
    2716        default "4.4.6"     if GCC_VERSION_4_4_6 
    2817        default "4.6.1"     if GCC_VERSION_4_6_1 
     
    3120        default "linaro" 
    3221 
    33 config GCC_VERSION_4_3 
    34         bool 
    35         default y       if GCC_VERSION_4_3_3_CS 
    36         default y       if GCC_VERSION_4_3_5 
    37  
    3822config GCC_VERSION_4_4 
    3923        bool 
    40         default y       if GCC_VERSION_4_4_1_CS 
    4124        default y       if GCC_VERSION_4_4_6 
    4225 
     
    5134if !TOOLCHAINOPTS 
    5235 
    53         config GCC_VERSION_4_3_3_CS 
    54                 default y if GCC_DEFAULT_VERSION_4_3_3_CS 
    55                 bool 
    56  
    57         config GCC_VERSION_4_3_5 
    58                 default y if GCC_DEFAULT_VERSION_4_3_5 
    59                 bool 
    60  
    6136        config GCC_VERSION_4_4_6 
    6237                default y if GCC_DEFAULT_VERSION_4_4_6 
     
    6742                bool 
    6843 
    69  
    7044endif 
Note: See TracChangeset for help on using the changeset viewer.