Ignore:
Timestamp:
2011-10-11T20:15:12+02:00 (5 years ago)
Author:
jow
Message:

include: autotools.mk: do not fail in patch-libtool fixup if patch is already applied

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/include/autotools.mk

    r27855 r28419  
    5757                        case "$$$$lt_version" in \ 
    5858                                1.5|2.2|2.4) echo "autotools.mk: Found libtool v$$$$lt_version - applying patch to $$$$lt"; \ 
    59                                         (cd $$$$(dirname $$$$lt) && $$(PATCH) -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch) ;; \ 
     59                                        (cd $$$$(dirname $$$$lt) && $$(PATCH) -N -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch || true) ;; \ 
    6060                                *) echo "autotools.mk: error: Unsupported libtool version v$$$$lt_version - cannot patch $$$$lt"; exit 1 ;; \ 
    6161                        esac; \ 
Note: See TracChangeset for help on using the changeset viewer.