Changeset 8404


Ignore:
Timestamp:
2007-08-12T13:53:23+02:00 (9 years ago)
Author:
florian
Message:

Add a requireheader for squid, should fix it (#2205)

Files:
2 edited

Legend:

Unmodified
Added
Removed
  • packages/net/squid/Makefile

    r8403 r8404  
    3232  $(call Package/squid/Default) 
    3333  MENU:=1 
    34   DEPENDS:=+libopenssl +libpthread @BROKEN 
     34  DEPENDS:=+libopenssl +libpthread 
    3535  TITLE:=full-featured Web proxy cache 
    3636  DESCRIPTION:=\ 
     
    182182$(eval $(call BuildPlugin,squid-mod-ntlm-auth-fakeauth,fakeauth_auth)) 
    183183$(eval $(call BuildPlugin,squid-mod-ntlm-auth-smb-auth,ntlm_auth)) 
     184 
     185$(eval $(call RequireHeader,/usr/include/openssl/ssl.h, \ 
     186        $(PKG_NAME) requires the openssl development (named like libssl-dev, \ 
     187        depending of your package manager) package be installed on the host-system. \ 
     188)) 
  • trunk/include/prereq.mk

    r8242 r8404  
    4848endef 
    4949 
     50define RequireHeader 
     51  define Require/$(1) 
     52    [ -e "$(1)" ] 
     53  endef 
     54   
     55  $$(eval $$(call Require,$(1),$(2))) 
     56endef 
     57 
    5058.NOTPARALLEL: 
Note: See TracChangeset for help on using the changeset viewer.