Ignore:
Timestamp:
2007-11-08T00:16:37+01:00 (9 years ago)
Author:
nbd
Message:

fix acx-mac80211 compile with older kernels

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package/acx-mac80211/Makefile

    r9388 r9512  
    4343        $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_NAME)" "$(PKG_FW_MD5SUM)" $(PKG_FW_URL) 
    4444 
     45ifneq ($(findstring 2.6.23,$(LINUX_VERSION)),) 
    4546  PKG_EXTRA_KCONFIG:= \ 
    4647        CONFIG_ACX_MAC80211=m \ 
     
    5152        $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=y,%,$(filter %=y,$(PKG_EXTRA_KCONFIG)))) \ 
    5253 
    53   define Build/Compile/it 
     54  define Build/Compile 
    5455        $(MAKE) -C "$(LINUX_DIR)" \ 
    5556                ARCH="$(LINUX_KARCH)" \ 
     
    6364                modules 
    6465  endef 
     66else 
     67  override CONFIG_PACKAGE_kmod-acx-mac80211= 
     68endif 
    6569 
    6670define Build/Configure 
    67 endef 
    68  
    69 define Build/Compile 
    70 $(call Build/Compile/it) 
    7171endef 
    7272 
Note: See TracChangeset for help on using the changeset viewer.