Changeset 9578


Ignore:
Timestamp:
2007-11-17T16:54:53+01:00 (9 years ago)
Author:
nbd
Message:

prevent mac80211 from accidentally starting to build on older kernel versions because of dependencies (#2718)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package/mac80211/Makefile

    r9554 r9578  
    5858endef 
    5959 
    60 define Build/InstallDev 
     60ifeq ($(CONFIG_LINUX_2_6_23),y) 
     61  define Build/InstallDev 
    6162        mkdir -p $(1)/usr/include/mac80211 
    6263        $(CP) $(PKG_BUILD_DIR)/net/mac80211/*.h $(PKG_BUILD_DIR)/include/* $(1)/usr/include/mac80211/ 
    63 endef 
     64  endef 
    6465 
    65 define Build/UninstallDev 
     66  define Build/UninstallDev 
    6667        rm -rf  $(1)/usr/include/mac80211 
    67 endef 
     68  endef 
    6869 
    69 define KernelPackage/mac80211/install 
     70  define KernelPackage/mac80211/install 
    7071        $(INSTALL_DIR) $(1)/lib/wifi 
    7172        $(INSTALL_DATA) ./files/lib/wifi/mac80211.sh $(1)/lib/wifi 
    72 endef 
     73  endef 
     74endif 
    7375 
    7476$(eval $(call KernelPackage,mac80211)) 
Note: See TracChangeset for help on using the changeset viewer.