source: trunk/package/uci/Makefile

Revision Log Mode:


Legend:

Added
Modified
Copied or renamed
Diff Rev Age Author Log Message
(edit) @26470   5 years jow [package] uci: mark uci as unsafe for parallel building
(edit) @26315   5 years nbd uci: fix linking against libdl (#9123)
(edit) @26310   5 years nbd uci: update to fix lua plugin linker issue (#9121)
(edit) @26309   5 years nbd uci: install libucimap to the staging dir
(edit) @26308   5 years nbd remove ucitrigger, it is unused and will be replaced by something …
(edit) @26307   5 years nbd uci: update to latest version, uses cmake now
(edit) @25144   5 years kaloz [toolchain]: get rid of gcc 4.1.2 and 4.2.4 support
(edit) @25048   5 years jow [package] uci: use latest git, fixes reorder operation and incorperates …
(edit) @23757   6 years jow [package] uci: use a delete-safe iterator in the Lua :foreach() function …
(edit) @23430   6 years nbd uci: update to 2010-09-28
(edit) @22629   6 years jow [package] base-files, uci: properly revert list state on config_load This …
(edit) @22536   6 years lars [package] uci: Install ucimap.h into the staging dir
(edit) @21529   6 years jow [package] uci: bump pkg release after r21489-r21494 (#7312)
(edit) @21516   6 years jow [package] uci: revert pkg rev to 5 until updated sources are available …
(edit) @21494   6 years jow [package] uci: bump package revision
(edit) @20378   6 years thepeople [uci] bump to the lastest git commit
(edit) @18092   7 years nbd uci: only use $(FPIC) on library parts, saves a few hundred bytes
(edit) @16768   7 years nbd ucitrigger depends on lua
(edit) @16375   7 years nbd add ucitrigger: a uci plugin, command line tool and lua interface for …
(edit) @15356   7 years nbd uci: upgrade to 0.7.5 - fixes a runtime error with 2.6.29 if flock() does …
(edit) @15242   7 years nbd get rid of $Id$ - it has never helped us and it has broken too many …
(edit) @15021   7 years nbd upgrade to uci 0.7.4 - fixes a file locking bug, thx Cyrus
(edit) @14651   7 years nico [package] replace some -I & -L flags with $(TARGET_CPPFLAGS) & …
(edit) @14115   7 years nbd upgrade to uci 0.7.3 - fixes a small input validation bug
(edit) @14111   7 years nbd bump uci to 0.7.2 - adds uci.rename() and fixes uci.set() with a list …
(edit) @13751   8 years nbd uci: upgrade to 0.7.1, fixes uci rename for unnamed sections
(edit) @13739   8 years nbd uci: work around a gcc bug which causes a bogus compiler warning
(edit) @13732   8 years nbd upgrade uci to 0.7.0 - adds ucimap and fixes #4236
(edit) @13203   8 years nbd uci: upgrade to 0.6.4 - adds extended syntax to the cli and fixes a lua …
(edit) @12535   8 years nbd upgrade to uci 0.6.2 (bugfixes)
(edit) @12413   8 years nbd upgrade to uci 0.6.1 - lots of cli and lua binding fixes
(edit) @12373   8 years nbd upgrade uci to 0.6.0 - many bugfixes and an API cleanup
(edit) @12353   8 years nbd upgrade to uci 0.5.0, adds list handling support
(edit) @12225   8 years nbd use $(FPIC) in a few places where it matters
(edit) @12045   8 years nbd another one …
(edit) @12044   8 years nbd upgrade to uci 0.4.7 - fixes a stupid regression introduced in 0.4.5
(edit) @12028   8 years nbd upgrade to uci 0.4.6 - fixes a parser glitch
(edit) @12023   8 years nbd upgrade to uci 0.4.5 - adds extra input validation
(edit) @12022   8 years nbd clean up the directory layout of the uci shell api
(edit) @12021   8 years nbd nuke uci-sh, it is obsolete and no longer works
(edit) @11548   8 years nbd upgrade to uci 0.4.4 (fixes a stupid bug, thx Frédéric Moulins)
(edit) @11517   8 years agb [uci] Create $(1)/etc/uci-defaults directory during installation. Thanks …
(edit) @11361   8 years nbd upgrade uci to 0.4.2 - fixes some escaping and library issues
(edit) @11354   8 years nbd upgrade uci to 0.4.1 improves uci.foreach and uci.get_all in the lua …
(edit) @11353   8 years nbd move the uci lua plugin to /usr/lib/lua instead of /usr/lib/lua/5.1
(edit) @11348   8 years nbd update uci to v0.4.0 - improves lua binding
(edit) @11030   8 years nbd upgrade to uci 0.3.4 - extends lua bindings and fixes a bug that rejected …
(edit) @10818   8 years nbd upgrade uci to 0.3.3, build lua plugin
(edit) @10772   8 years nbd upgrade uci to 0.3.1 - fixes a parser problem
(edit) @10732   8 years agb Install libuci and headers in staging_dir
(edit) @10447   8 years nbd upgrade uci to 0.3.0 - fix for adding changes to empty config files - …
(edit) @10431   8 years nbd bump uci to 0.2.5 - adds support for adding unnamed sections
(edit) @10400   8 years nbd update uci - fixes a bug in parse_uci_tuple
(edit) @10391   8 years nbd fix another crash
(edit) @10390   8 years nbd upgrade to uci 0.2.2 - fixes uci invocations from hotplug
(edit) @10388   8 years nbd import uci v0.2.1 - fixes a merge-import bug
(edit) @10386   8 years nbd add uci v0.2 - implements batch mode and a command for listing changes to …
(edit) @10382   8 years nbd upgrade uci 0.1.2, which accepts more characters in the section type …
(edit) @10381   8 years nbd update uci to 0.1.1 - accepts options without value or with an empty value …
(edit) @10368   8 years nbd fix copy&paste bug
(add) @10367   8 years nbd Here comes the new UCI. Enjoy :)
Note: See TracRevisionLog for help on using the revision log.