Modify

Opened 4 years ago

Closed 4 years ago

Last modified 22 months ago

#10450 closed defect (duplicate)

OperationalError: database is locked

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

How to Reproduce

While doing a GET operation on /wiki/platforms, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'page': u'platforms'}

User Agent was: Opera/9.80 (Android; Opera Mini/6.5.27049/26.1153; U; en) Presto/2.8.119 Version/10.5454

System Information

Trac 0.11.7
Python 2.6.2 (release26-maint, Apr 19 2009, 01:58:18)
[GCC 4.3.3]
setuptools 0.6c9
SQLite 3.6.10
pysqlite 2.5.0
Genshi 0.5.1
Pygments 0.10
Subversion 1.6.1 (r37116)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 176, in dispatch
    chosen_handler)
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 296, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/lib/python2.6/dist-packages/trac/versioncontrol/api.py", line 86, in pre_process_request
    self.get_repository(req.authname).sync()
  File "/usr/lib/python2.6/dist-packages/trac/versioncontrol/cache.py", line 92, in sync
    ','.join(["'%s'" % key for key in CACHE_METADATA_KEYS]))
  File "/usr/lib/python2.6/dist-packages/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql)
  File "/usr/lib/python2.6/dist-packages/trac/db/sqlite_b

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10451

comment:2 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.