Opened 5 years ago

Closed 4 years ago

Last modified 2 years ago

#10501 closed defect (no_response)

PPPoE support broken

Reported by: anonymous Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:



After installing today's OpenWrt snapshot (r28310), I found that PPPoE support is broken. "ifup wan" fails to start pppd; it doesn't give an error message. I was able to fix it by changing

	start_pppd "$config" \
		"nic-$iface" \
		plugin \
		${ac:+rp_pppoe_ac "$ac"} \
		${service:+rp_pppoe_service "$service"} \
		mtu $mtu mru $mtu


	start_pppd "$config" \
		plugin \
		${ac:+rp_pppoe_ac "$ac"} \
		${service:+rp_pppoe_service "$service"} \
		mtu $mtu mru $mtu \

in /lib/network/, i. e. placing "nic-$iface" at the end of the argument list.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by jow

That fix makes no sense. a) it will break the ac and service options, b) start_pppd() takes care of moving the nic argument. Are you sure your pppd package is actually up to date?

comment:2 Changed 4 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:3 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.