Modify

Opened 4 years ago

Closed 4 years ago

Last modified 22 months ago

#10526 closed defect (invalid)

The ntpd package needs some scripts, but the package has not set the dependency.

Reported by: mike@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: ntpd package Cc:

Description

The ntpd package has an /etc/init.d/ntpd script that calls the following scripts: user_exists, user_add, group_exists and group_add. However, these scripts may not be present. The ntpd package should set, as a dependency, whatever package does contain those scripts. (I'm not sure which one.)

root@OpenWrt:~# /etc/init.d/ntpd restart
/etc/rc.common: line 82: service_stop: not found
/etc/rc.common: line 82: user_exists: not found
/etc/rc.common: line 82: user_add: not found
/etc/rc.common: line 82: group_exists: not found
/etc/rc.common: line 82: group_add: not found
chown: unknown user/group ntp:ntp
/etc/rc.common: line 82: service_start: not found

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

Those procedures are provided by recent base-files, your running firmware is just too old.

comment:2 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.