Modify

Opened 4 years ago

Closed 4 months ago

Last modified 3 weeks ago

#10852 closed enhancement (not_a_bug)

Support for ASUS RT-N66U

Reported by: Geraner Owned by: hauke
Priority: low Milestone: Features Paradise
Component: kernel Version: Trunk
Keywords: ASUS, RT-N66U Cc:

Description

Hi,
Please add OpenWRT support for the ASUS RT-N66U!
Toastman firmware is already running on that router.

More information about this router to be found on:
http://forums.smallnetbuilder.com/showthread.php?t=6446

Attachments (1)

20130716154234.rt-n66u.3.10.first.boot (17.5 KB) - added by sash-kan <alex@…> 3 years ago.

Download all attachments as: .zip

Change History (49)

comment:1 Changed 4 years ago by jow

  • Component changed from base system to kernel
  • Milestone changed from Backfire 10.03.2 to Features Paradise
  • Owner changed from developers to hauke
  • Priority changed from high to low
  • Status changed from new to assigned

This needs reverse engineered ethernet drivers which have not yet been developed, don't hold your breath.

comment:2 Changed 4 years ago by hauke

There are some other parts in addition to the Ethernet driver missing.
There are some smaller parts in the general system initialization and support for the 128MB high memory missing and probably more.
But non of the OpenWrt core developers have such a device so adding support for this device will be hard.

comment:3 Changed 4 years ago by anonymous

Can we help by donating a device?

comment:4 Changed 4 years ago by hauke

Yes donating a device will help to get (better) support for this device.

comment:5 Changed 4 years ago by Andrew <gamehacker0@…>

Has a device been donated/delivered to anyone? Is a device still needed? I am looking for an alternative to DD-WRT, as support/progress is beginning to stall, and working with dd-wrt is becoming a major hassle with this router.

comment:6 Changed 3 years ago by hauke

Ethernet is now working for me with this device.

comment:7 Changed 3 years ago by Andrew

hauke, this is good to hear. Will hopefully switch over to OpenWRT if everything comes together here. Is there anything you need to add 64K CFE support to the build as well?

comment:8 Changed 3 years ago by wh1p

just got a one of these just wandering what sort of time we are looking at to get a version of openwrt that works :?

comment:9 Changed 3 years ago by hauke

It depends on what you mean by "works".

The base system is working in trunk (booting, flash is detected correctly, and so on).
Ethernet and USB are working.

OpenWrt just supports the lower 128MB ram, someone has to add support for the other 128MB.

Wifi currently does not work, there is some dma problem in b43. If b43 would work it would just work with 80211g rates and not with 80211n rates or on 5GHz.
brcmsmac and broadcom-wl does not support the HT-PHY.

Adding support for the upper 128MB Ram and fixing the dma problem should not be that hard, but addimg support for 80211n rates and 5GHz is a big task. I am still hoping that Broadcom will add support for the HT-PHY into brcmsmac.

comment:10 Changed 3 years ago by wh1p

Asus have released a beta firmware update for the Asus RT-N66U that adds a new/updated Broadcom driver and i don't know if that means that there is now an available driver or a way of pulling the driver from the firmware update?

comment:11 Changed 3 years ago by Martin Lucina <martin@…>

Hi, I own this device, how can I add myself into Cc: for this ticket?

comment:12 Changed 3 years ago by sash-kan <alex@…>

i tried "Target Profile (Broadcom SoC, all Ethernet, BCM43xx WiFi (wl, proprietary))"

in dmesg:

[   13.776000] wl: module license 'unspecified' taints kernel.
[   13.780000] Disabling lock debugging due to kernel taint
[   13.844000] SSB/BCMA glue driver successfully attached
[   13.848000] bcma: PCI: Fixing up device 0000:00:01.0
[   13.892000] wl0: 5.10.56.27 driver failed with code 11
[   13.900000] Memory leak of bytes 4064
[   13.904000] bcma: PCI: Fixing up device 0000:01:01.0
[   13.952000] wl0: 5.10.56.27 driver failed with code 11
[   13.956000] Memory leak of bytes 20

as i understand it, wl can't initialize any of the two adapters (2.4ghz and 5ghz).

any ideas?

comment:13 Changed 3 years ago by sash-kan <alex@…>

it seems, from the commit 216525 (svn r36987), the lan network is broken.
the same for asus.rt-n16

comment:14 follow-up: Changed 3 years ago by hauke

broadcom-wl does not support the wifi core (BCM4331) in the Asus-RT-N66U, the driver is too old.

The network problem should be fixed by now.

comment:15 Changed 3 years ago by sash-kan <alex@…>

The network problem should be fixed by now.

thank you!

but b43 "dma error" still present...

i tried to pass option "pio=1" to b43 module.
"dma error" dissapered, but wifi-client can't connect (without any messages in jtag console).
unfortunately, i can not see the logs on the client side (android).

comment:16 in reply to: ↑ 14 ; follow-ups: Changed 3 years ago by logistiker

Replying to hauke:

broadcom-wl does not support the wifi core (BCM4331) in the Asus-RT-N66U, the driver is too old.

The network problem should be fixed by now.

Apparently there is support, otherwise dd-wrt wouldn't be able to do it. I have this firmware loaded on my RT-N66U and wireless works (uses kernel 3.9.4):

ftp://ftp.dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2013/05-27-2013-r21676/

comment:17 in reply to: ↑ 16 Changed 3 years ago by sash-kan <alex@…>

Replying to logistiker:

Replying to hauke:

broadcom-wl does not support the wifi core (BCM4331) in the Asus-RT-N66U, the driver is too old.

The network problem should be fixed by now.

Apparently there is support, otherwise dd-wrt wouldn't be able to do it. I have this firmware loaded on my RT-N66U and wireless works (uses kernel 3.9.4):

ftp://ftp.dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2013/05-27-2013-r21676/

which file you used?

Changed 3 years ago by sash-kan <alex@…>

comment:18 follow-up: Changed 3 years ago by sash-kan <alex@…>

i tried linux-3.10

  1. network is not working: "b53_common: Failed to enable switch!" (full log is attached).
  2. router is booted only once. for the second time cfe reported: "Boot program checksum is invalid".

comment:19 in reply to: ↑ 18 Changed 3 years ago by anonymous

Replying to sash-kan <alex@…>:

i tried linux-3.10

  1. network is not working: "b53_common: Failed to enable switch!" (full log is attached).
  2. router is booted only once. for the second time cfe reported: "Boot program checksum is invalid".

I just upgraded it to the latest dd-wrt which also works:

ftp://ftp.dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2013/07-24-2013-r22118/broadcom_K3X/dd-wrt.v24-22118_NEWD-2_K3.x-big-RT-N66U.trx

comment:20 in reply to: ↑ 16 Changed 3 years ago by hauke

Replying to sash-kan:

but b43 "dma error" still present...

i tried to pass option "pio=1" to b43 module.
"dma error" dissapered, but wifi-client can't connect (without any messages in jtag console).
unfortunately, i can not see the logs on the client side (android).

I also see this problem here, but I do not know whats wrong here, my current assumption is that the PCIe driver is wrong. It would be nice if someone would look into that.

Replying to logistiker:

Apparently there is support, otherwise dd-wrt wouldn't be able to do it. I have this firmware loaded on my RT-N66U and wireless works (uses kernel 3.9.4):

ftp://ftp.dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2013/05-27-2013-r21676/

DD-Wrt uses a more recent version of the proprietary closed source Broadcom wireless driver, this version depends on a heavily patches kernel. Sadly we do not have access to the source code of the proprietary Broadcom wireless driver and do not have a written permission from Broadcom to create a kernel version independent version for OpenWrt based on a more recent version of the driver. If you could provide me with both I will look into it, but just taking the binary from DD-Wrt does not work.

Linking to the firmware blob does not help at all, then you have to link to the source code.

Replying to sash-kan:

i tried linux-3.10

  1. network is not working: "b53_common: Failed to enable switch!" (full log is attached).
  2. router is booted only once. for the second time cfe reported: "Boot program checksum is invalid".
  1. This is fixed in r37645
  2. This is fixed in r37625

Thanks for reporting both.

comment:21 follow-up: Changed 3 years ago by hauke

b43 is now working for me on this device, just with 1 MBit/s, but it works. ;-) This was fixed in r37709.

comment:22 in reply to: ↑ 21 Changed 3 years ago by sash-kan <alex@…>

Replying to hauke:

b43 is now working for me on this device, just with 1 MBit/s, but it works. ;-) This was fixed in r37709.

great news!

comment:23 Changed 3 years ago by sash-kan <alex@…>

@hauke
i try last commits.
router gets _very_ hot.
i can't even touch heatsink cover.

comment:24 Changed 2 years ago by ChrisGo

I would love to see a canned package or a WIKI for this router, at least the basics and full speed wireless. The USB and other BS I can love without.

comment:25 Changed 2 years ago by rbeede

comment:27 Changed 2 years ago by anonymous

I'm probably very naive on this driver requirement but is this not the driver source for the BCM4331:

http://www.broadcom.com/support/802.11/linux_sta.php

Not sure if the license is inappropriate or this still requires binary blobs or just too invasive?

comment:28 Changed 2 years ago by anonymous

Пожалуйста, сделайте поддержку OpenWrt для нашего роутера!

comment:29 Changed 2 years ago by victorhooi

I also have a Asus RT-N66U, and would love to see support =).

Is there anything at all that we can do to help?

Do the developers need a donated device, or do they have one?

Anything that we could help to test on our devices?

comment:30 Changed 2 years ago by anonymous

I too would love to get OpenWrt running on my Asus RT-N66U. any news? it looks like this bug is stagnant.

comment:31 Changed 23 months ago by arkokan@…

Same here, I would like to see and if any help is need.

comment:32 Changed 21 months ago by anonymous

Any news? Want to test some builds

comment:35 Changed 19 months ago by hauke

The driver found at ​http://www.broadcom.com/support/802.11/linux_sta.php contains a binary core for x86 and AMD64. This will not work on MIPS or ARM.

The BCM4331 wifi is the tricky part of this device. Broadcom has an Wifi driver but it is closed source and they do not allow us to ship it in OpenWrt. I have a device and I do not think that is the big problem, currently the problem are developers wanting to work on the wifi part.

comment:36 Changed 19 months ago by anonymous

comment:38 Changed 18 months ago by anonymous

Hi, is there anything we can do to get this going? I know a lot of people have this router, that would love openwrt.
Thanks

comment:39 Changed 18 months ago by anonymous

Doesn't Ubuntu just cut out the proprietary part with b43-fwcutter ?

comment:40 Changed 17 months ago by Elektronik

Maybe this could help ?
http://dlcdnet.asus.com/pub/ASUS/wireless/RT-N66U_B1/GPL_RT_N66U_30043763657.tgz

Should be the GPL sources for the latest international firmware.

comment:41 Changed 17 months ago by anonymous

Please add support for Asus RT-N66U. I would like to upgrade from a tired installation of TomatoUSB.

Thank you

comment:42 Changed 14 months ago by l3iggs

+1 for getting this router working! How can I help?

comment:43 Changed 14 months ago by anonymous

+1, please let the community know what's blocking it and how we may help.

comment:46 Changed 14 months ago by anonymous

lPease let the community know what's still causing an issue so we can help. DD-Wrt and Tomato both work on this router, not understanding why OpenWRT can't.

comment:47 Changed 14 months ago by anonymous

Please stop adding these unhelpful comments. Other people are receiving notifications, only to see your "+1".

If the developers had anything for you to do, they would probably say so.

comment:49 Changed 12 months ago by benben159

hello,

i've tested Chaos Calmer r45879 on this device. most functionality works well, except for the wireless.

  1. the 5GHz part of the wifi controller is disabled. I'm sure it requires non-free binary blobs that is unavailable for OpenWrt (CMIIW)
  1. the 2.4GHz signal is very weak. i've tried to connect my laptop on the access point, but the connection keeps dropped. my laptop is very near with the access point.

comment:50 Changed 5 months ago by anonymous

Are there any news?

comment:51 Changed 4 months ago by jakub@…

Just installed: OpenWrt Chaos Calmer 15.05 / LuCI Master (git-15.233.47308-791ca8b)
and same issue as above 5ghz radio is not visible and 2.4 is good only for like two meters, 2,5 max.

There is also 128MB of RAM missing as device is only finding 128MB total (vs 256MB that device has)

comment:52 Changed 4 months ago by anonymous

have you tried the trunk snapshot? (on your own risk). Given linux can compile latesta STA driver, I still am not quite sure why that doesn't work with openwrt?

comment:53 Changed 4 months ago by jow

  • Resolution set to not_a_bug
  • Status changed from assigned to closed

Current support status is likely the best you'll get with OpenWrt, wireless will probably never work fully. We cannot use the broadcom-sta driver as it is x86 only and not supporting ap mode. We cannot use the drivers from Tomato or DD-Wrt either as they're closed source and not compatible to our used kernel version.

Furthermore I'm going to close this ticket as it is

a) a feature request and not a bug and
b) baseline support is available now in trunk

For remaining issues apart from wireless support ones open separate tickets. Do not reopen this one.

comment:54 Changed 3 weeks ago by anonymous

Tested with 15.05.1 today and it appears as though the same issues exist as before (same with 15.05):

  1. RAM reporting only 128MB Instead of 256MN
  2. 5GHZ Radio disabled
  3. 2.4GHZ Radio is VERY weak to say the least. You need to put your device pretty much within 5 feet to get signal.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.