Modify

Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#11553 closed defect (fixed)

ar71xx build r31978-31988 wifi can't start during bootup

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

After r31978, I've got these message during bootup,
then wifi won't start after bootup


user.info sysinit: Configuration file: /var/run/hostapd-phy0.conf
user.info sysinit: nl80211: Failed to add interface wlan0 into bridge lo: Operation not supported
user.info sysinit: nl80211 driver initialization failed.
user.info sysinit: Failed to start hostapd for phy0


However, simply issue "wifi" manually wifi startup again.

Attachments (2)

network (385 bytes) - added by anonymous 5 years ago.
wireless (818 bytes) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 5 years ago by hnyman <hannu.nyman@…>

Works for me. I have just built and flashed 31988 for my ar71xx WNDR3700. Wifi came up automatically after the flash quite normally. (sysupgrade preserving settings)

I suggest you make sure that your build environment is clean (make clean) and that your .config does not have old dependencies from pre-netifd times. There have been quite a lot of changes in base-files related to netifd.

comment:2 Changed 5 years ago by anonymous

TRENDnet TEW-632BRP

There are also a line of "no-dhcp-interface=br-lan" in /tmp/etc/dnsmasq.conf.
So dhcp not work for br-lan.

Also after import my uci config and reboot, it never get up. I don't have a ttl line, so I don't know what happened .

comment:3 Changed 5 years ago by anonymous

It has a non-functioning "ifb0 ifb1" and it just try to blind the wifi on it during startup.

comment:4 follow-up: Changed 5 years ago by nbd

  • Priority changed from normal to response-needed

please post your /etc/config/wireless and /etc/config/network

comment:5 in reply to: ↑ 4 Changed 5 years ago by anonymous

Replying to nbd:

please post your /etc/config/wireless and /etc/config/network

just very simple/.


/etc/network
config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'MyWAN'

option type 'bridge'
option ifname 'eth0'
option proto 'dhcp'
option stp '1'

config interface 'lan'

option type 'bridge'
option proto 'none'


/etc/wireless
config wifi-device 'radio0'

option type 'mac80211'
option macaddr 'xx:xx:xx:xx:xx:xx'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option hwmode '11ng'
option txpower '20'
option htmode 'HT40+'
option country 'JP'
option noscan '1'
option channel '6'

config wifi-iface

option device 'radio0'
option mode 'ap'
option encryption 'none'
option wds '1'
option network 'MyWAN'
option ssid 'wifi1'

config wifi-iface

option device 'radio0'
option mode 'ap'
option encryption 'none'
option network 'MyWAN'
option wds '1'
option ssid 'WDS'


Now I switch back to r31956, everything works fine.
But after this build, wifi won't start automatically, need to run "wifi" to start it after bootup.
I don't know where is that nl80211 come from.

Changed 5 years ago by anonymous

Changed 5 years ago by anonymous

comment:6 Changed 5 years ago by anonymous

I have tried delete the whole openwrt and start all over again, only the default packages are selected, the problem remain the same.

comment:7 follow-up: Changed 5 years ago by nbd

please try r32011 or newer, should be fixed now

comment:8 in reply to: ↑ 7 Changed 5 years ago by anonymous

Replying to nbd:

please try r32011 or newer, should be fixed now

Just finished built r32012
It is working now !!
Thk you so much for you guys effort.

comment:9 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:10 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.