Modify

Opened 4 years ago

Closed 4 years ago

Last modified 2 years ago

#11580 closed defect (invalid)

qos - download and upload speed reversed

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

In /etc/conf/qos the effects of upload and download options are reversed. I tested speed with flash tool on http://www.dslreports.com/speedtest?flash=1.


test cases and results

option uploadoption downloadactual uploadactual download
12812891104
12825621997
128512454100
25612888208
51212889394
102412884792
2048128841413

Attachments (1)

qos (1.4 KB) - added by anonymous 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by anonymous

comment:1 follow-up: Changed 4 years ago by anonymous

Sounds strange, as it works quite normally for me both with current Backfire and current trunk.

Qos has changed quite much during last year, so please report your exact version. Which openwrt version you are using? Backfire 10.03.1 rxxxx? trunk rXXXXX?

comment:2 Changed 4 years ago by anonymous

Trunk ar71xx r32012

comment:3 in reply to: ↑ 1 Changed 4 years ago by anonymous

Replying to anonymous:

Sounds strange, as it works quite normally for me both with current Backfire and current trunk.

Qos has changed quite much during last year, so please report your exact version. Which openwrt version you are using? Backfire 10.03.1 rxxxx? trunk rXXXXX?


I have a pseudo bridge setup with my wzr-hp-ag300h. I'm using the 5ghz radio1(sta mode) to connect to router downstairs and 2ghz radio0 as access point which I have qos turned on for wlan interface.

comment:4 follow-up: Changed 4 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

If you've configured QoS on the AP interface, then it makes sense for the directions in the speed test to be reversed.
From an interface perspective, upload on the AP interface means traffic from the internet to the client.

=> not a bug

comment:5 in reply to: ↑ 4 Changed 4 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to nbd:

If you've configured QoS on the AP interface, then it makes sense for the directions in the speed test to be reversed.
From an interface perspective, upload on the AP interface means traffic from the internet to the client.

=> not a bug


Your reasoning doesn't make sense. The AP is no different from the default br-lan that was initially provided. Upload/Download should always be in the perspective of the AP working as a gateway for the client. For instance when I say I'm downloading something it means from internet --> AP --> client. When something is uploaded it means client --> AP --> internet.

comment:6 Changed 4 years ago by nbd

  • Resolution set to invalid
  • Status changed from reopened to closed

No, upload/download *always* refers to the upload/download of the specific interface that you configure it on. If you activate it on an AP mode interface, then the upload on that AP interface is traffic that goes *to* a station.

Upload/download only refers to the 'internet upload/download' if you configure it on the *wan* interface, not lan.

It does not make sense to twist it in a way to make it always refer to the internet download/upload, because that would simply not fit for many scenarios where you'd want to deploy qos, aside from the fact that it would be an ugly-as-hell hack in the code.

comment:7 Changed 4 years ago by anonymous

Wow.. this should've been clearly written on OpenWRT wiki (QoS wiki).
I thought mine was reversed too. I'm using Trunk Attitude-Adjusment beta 2 (r33883).
I set-up 3 wireless networks with 3 separate network interface. I limit the bandwidth of one of those wifi with qos-scripts.
After several testing, I found out that the upload/download setting seems "reversed".
Thanks for the explanation.

comment:8 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.