Modify

Opened 4 years ago

Last modified 9 months ago

#11896 reopened defect

TP-LINK TL-WDR4300 Wrong Tx-Power

Reported by: florian Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

When I set the Transmit Power to 17dBm (50mW) openwrt displays in the status the following information:

Mode: Master | SSID: xxx
BSSID: 90:F6:xx:xx:xx | Encryption: WPA2 PSK (CCMP)
Channel: 44 (5.220 GHz) | Tx-Power: 14 dBm
Signal: -61 dBm | Noise: -87 dBm
Bit Rate: 45.0 MBit/s | Country: DE

Even when I set it to 17dBm in the command line it only uses 14 dBm...

Attachments (0)

Change History (37)

comment:1 Changed 4 years ago by nbd

Did you change the antenna settings?

comment:2 Changed 4 years ago by florian

I changed everything LuCI allowed me to change. Also I tried to set the 17dba setting per CLI:

root@OpenWrt:~# iwconfig wlan1 txpower 17dBm
root@OpenWrt:~#
root@OpenWrt:~# iwconfig wlan1 | grep Tx-Power
wlan1 IEEE 802.11an Mode:Master Tx-Power=14 dBm

comment:3 Changed 4 years ago by Udo Beckmann <udo.beckmann@…>

Same problem here.

Even with "option txpower '17'" set in /etc/config/wireless I only get 14dBm Tx-Power for wlan1. Therefore the signal strength is horribly low.

In my case wlan0 is also affected:

# iwconfig wlan0 txpower 20dBm
# iwconfig wlan0
wlan0 IEEE 802.11bgn Mode:Master Tx-Power=19 dBm

RTS thr:off Fragment thr:off
Power Management:on

comment:4 Changed 4 years ago by hodosiszabolcs@…

Same issue here.
I set 17 dBm TX Power from command line:
#iwconfig wlan1 txpower 17dBm
and only 14 was set.
From 4 meter distance the wireless strength is only 58% (client is a Lenovo T400 with Intel WiMax WiFi, as I remember Intel 5300)

comment:5 Changed 4 years ago by hotzenplotz

I have the same problem. Is there any solution?

comment:6 Changed 4 years ago by anonymous

The problem still exists on OpenWrt Attitude Adjustment 12.09-beta / LuCI Trunk (trunk+svn9220).

comment:7 Changed 4 years ago by anonymous

Still present in 12-09-beta2

comment:8 Changed 4 years ago by anonymous

has somebody already tested the rc1?

comment:9 Changed 3 years ago by anonymous

bug still exists in rc1

comment:10 Changed 3 years ago by ryannathans@…

possibly a crda problem? Would love to see some decent tx-power soon..

comment:11 Changed 3 years ago by anonymous

Any news? Bug is still marked as "new"...

comment:12 Changed 3 years ago by anonymous

still in rc2

comment:13 Changed 3 years ago by nbd

please try the current version

comment:14 Changed 3 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:15 Changed 3 years ago by anonymous

  • Resolution no_response deleted
  • Status changed from closed to reopened

problem does still exist in trunk. wireless on wdr4300 with openwrt is somehow not usable.

comment:16 Changed 3 years ago by nbd

please show your wireless config

comment:17 Changed 3 years ago by bobschi

i saw you have checked in some ath9k fixes. so i will flash new version and give you more informations then.

comment:18 Changed 2 years ago by anonymous

this problem is still here in trunk r39432.

comment:19 follow-up: Changed 2 years ago by nbd

with what configuration and what tx power values?

comment:20 in reply to: ↑ 19 Changed 2 years ago by anonymous

Replying to nbd:

with what configuration and what tx power values?

I've had this issue since I got two of these devices for a WDS setup. Sometimes I've seen them report 17 dBm when _not_ in WDS mode (long time ago, I think some commit changed this), however it did not have any impact on coverage, so I assumed it was just a display error.

I've also seen them display 5dBm but signal strengths seemed to be the same as with 14dBm, this too was fixed some time ago I believe, atleast I haven't seen it happen for a long time.

Setting "CONFIG_ATH_USER_REGD=y" or using reghack doesn't make any difference (14dBm is the highest TX power it will use). Strangely, while using either of these methods 15dBm is the highest allowed "setting" in luci -- and when _not_ using these modifications it allows me to set 17dBm. But it will never indicate a used TX power of anything higher then 14dBm.

Changing channels, channel width (20/40MHz), regulatory domain etc. usually makes no difference. Either with or without reghack/ath_user_regd. I say usually because I've seen it report 15 and 17 dBm on occasion, and then return to 14dBm after a reboot or simply by magic. Either way signal strength/coverage never appears to change. I bet you're scratching your head now.. I sure have been since I got these devices, almost beginning to suspect it's hardware/eeprom related.

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11na'
        option path 'pci0000:00/0000:00:00.0'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '15' ### with hack or ATH_USER_REGD=y 15dBm is max, without any modification it allows 17dBm, but signal strength/coverage remains the same no matter what I set above 14dBm
        option channel '36'
        option htmode 'HT40+'
        option noscan '1'
        option country 'GR'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'xxx'
        option encryption 'psk2+ccmp'
        option key 'xxx'
        option wds '1'

comment:21 Changed 2 years ago by anonymous

seems fine for me

root@WDR4300:/# cat /etc/openwrt_release
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="Bleeding Edge"
DISTRIB_REVISION="r39789"
DISTRIB_CODENAME="barrier_breaker"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Barrier Breaker r39789"
DISTRIB_TAINTS=""
root@WDR4300:/# iwconfig wlan0
wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=20 dBm
          RTS thr=2347 B   Fragment thr=2346 B
          Power Management:off

root@WDR4300:/# iwconfig wlan1
wlan1     IEEE 802.11an  Mode:Master  Tx-Power=17 dBm
          RTS thr=2347 B   Fragment thr=2346 B
          Power Management:off

root@WDR4300:/# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr '64:70:02:xx:xx:xx'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option country 'CA'
        option frag '2346'
        option rts '2347'
        option hwmode '11ng'
        option channel '1'
        option txpower '20'
        option htmode 'HT20'

config wifi-device 'radio1'
        option type 'mac80211'
        option macaddr '64:70:02:xx:xx:xx'
        option hwmode '11na'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '17'
        option country 'CA'
        option frag '2346'
        option rts '2347'
        option htmode 'HT20'
        option channel '40'

comment:22 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:23 Changed 2 years ago by Amandeep Sidhu

  • Resolution fixed deleted
  • Status changed from closed to reopened

still exists

comment:24 Changed 2 years ago by nbd

please provide some details

comment:25 Changed 2 years ago by anonymous

What exactly do you need?

comment:26 Changed 2 years ago by anonymous

root@SMG:~# cat /etc/openwrt_release
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="Attitude Adjustment"
DISTRIB_REVISION="r40835"
DISTRIB_CODENAME="attitude_adjustment"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Attitude Adjustment 12.09.1"

root@SMG:~# iwconfig wlan0
wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=22 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

root@SMG:~# iwconfig wlan1
wlan1     IEEE 802.11an  Mode:Master  Tx-Power=14 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

root@SMG:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option noscan '1'
        option channel '13'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11na'
        option path 'pci0000:00/0000:00:00.0'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option noscan '1'
        option channel '48'
        option htmode 'HT40-'

comment:27 Changed 2 years ago by darrenliew96@…

Same Problem here, affecting WDR3600, WDR4300

root@WDR3600:~# cat /etc/openwrt_release
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="12.09"
DISTRIB_REVISION="r36088"
DISTRIB_CODENAME="attitude_adjustment"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Attitude Adjustment 12.09"
root@WDR3600:~# iwconfig
ifb0      no wireless extensions.

wlan1-1   IEEE 802.11an  Mode:Master  Tx-Power=19 dBm
          RTS thr:off   Fragment thr:off
          Power Management:on

eth0.1    no wireless extensions.

lo        no wireless extensions.

usb0      no wireless extensions.

wlan1     IEEE 802.11an  Mode:Master  Tx-Power=19 dBm
          RTS thr:off   Fragment thr:off
          Power Management:on

wlan0-1   IEEE 802.11bgn  Mode:Master  Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Power Management:on

wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Power Management:on

eth0      no wireless extensions.

br-guest  no wireless extensions.

ifb1      no wireless extensions.

br-lan    no wireless extensions.

Set to TX-power 30db for the 5GHZ network. But still fall back to 19db.

And changing country seems like not working at all..

comment:28 Changed 2 years ago by locojohn

Set to TX-power 30db for the 5GHZ network. But still fall back to 19db.

Same on wdr3500 (Barrier Breaker r41508 from trunk) and kernel setting "CONFIG_ATH_USER_REGD=y":

OpenWRT-r41508 ~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option short_preamble '1'
        option country 'LV'
        option channel '11'
        option htmode 'HT20'
        option txpower '20'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11na'
        option path 'pci0000:00/0000:00:00.0'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option short_preamble '1'
        option country 'LV'
        option channel '40'
        option htmode 'HT40+'
        option txpower '19'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option encryption 'psk2+tkip+aes'
	option key '0101010101'
	option network 'lan'
	option ssid 'eigus'
	option wmm '1'

config wifi-iface
	option device 'radio1'
	option mode 'ap'
	option ssid 'eigus'
	option encryption 'psk2+tkip+aes'
	option key '0101010101'
	option network 'lan'
	option wmm '1'


OpenWRT-r41508 ~# iw phy0 info
Wiphy phy0
	max # scan SSIDs: 4
	max scan IEs length: 2257 bytes
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Device supports AP-side u-APSD.
	Device supports T-DLS.
	Available Antennas: TX 0x3 RX 0x3
	Configured Antennas: TX 0x3 RX 0x3
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * WDS
		 * monitor
		 * mesh point
		 * P2P-client
		 * P2P-GO
	Band 1:
		Capabilities: 0x11ef
			RX LDPC
			HT20/HT40
			SM Power Save disabled
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 1-stream
			Max AMSDU length: 3839 bytes
			DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 8 usec (0x06)
		HT TX/RX MCS rate indexes supported: 0-15
		Frequencies:
			* 2412 MHz [1] (20.0 dBm)
			* 2417 MHz [2] (20.0 dBm)
			* 2422 MHz [3] (20.0 dBm)
			* 2427 MHz [4] (20.0 dBm)
			* 2432 MHz [5] (20.0 dBm)
			* 2437 MHz [6] (20.0 dBm)
			* 2442 MHz [7] (20.0 dBm)
			* 2447 MHz [8] (20.0 dBm)
			* 2452 MHz [9] (20.0 dBm)
			* 2457 MHz [10] (20.0 dBm)
			* 2462 MHz [11] (20.0 dBm)
			* 2467 MHz [12] (20.0 dBm)
			* 2472 MHz [13] (20.0 dBm)
			* 2484 MHz [14] (disabled)
	valid interface combinations:
		 * #{ managed, WDS } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
		   total <= 2048, #channels <= 1, STA/AP BI must match
	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing

OpenWRT-r41508 ~# iw phy1 info
Wiphy phy1
	max # scan SSIDs: 4
	max scan IEs length: 2261 bytes
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Device supports AP-side u-APSD.
	Device supports T-DLS.
	Available Antennas: TX 0x3 RX 0x3
	Configured Antennas: TX 0x3 RX 0x3
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * WDS
		 * monitor
		 * mesh point
		 * P2P-client
		 * P2P-GO
	Band 2:
		Capabilities: 0x11ef
			RX LDPC
			HT20/HT40
			SM Power Save disabled
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 1-stream
			Max AMSDU length: 3839 bytes
			DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 8 usec (0x06)
		HT TX/RX MCS rate indexes supported: 0-15
		Frequencies:
			* 5180 MHz [36] (15.0 dBm)
			* 5200 MHz [40] (19.0 dBm)
			* 5220 MHz [44] (15.0 dBm)
			* 5240 MHz [48] (15.0 dBm)
			* 5260 MHz [52] (15.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5280 MHz [56] (15.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5300 MHz [60] (15.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5320 MHz [64] (15.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5500 MHz [100] (15.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5520 MHz [104] (19.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5540 MHz [108] (19.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5560 MHz [112] (19.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5580 MHz [116] (19.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5600 MHz [120] (15.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5620 MHz [124] (15.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5640 MHz [128] (15.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5660 MHz [132] (15.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5680 MHz [136] (15.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5700 MHz [140] (15.0 dBm) (radar detection)
			  DFS state: usable (for 2551804 sec)
			  DFS CAC time: 60000 ms
			* 5745 MHz [149] (disabled)
			* 5765 MHz [153] (disabled)
			* 5785 MHz [157] (disabled)
			* 5805 MHz [161] (disabled)
			* 5825 MHz [165] (disabled)
	valid interface combinations:
		 * #{ managed, WDS } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
		   total <= 2048, #channels <= 1, STA/AP BI must match
	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing

comment:29 Changed 2 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

19dBm is the hardware capability. 30dBm is the _theoretical_ regulatory limit.

comment:30 Changed 2 years ago by mail@…

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

That is not right!!!

The Hardware Capability is higher than 19dBm... i tested it with several Softwares on my WDR4300.

It is definitely a bug...

...in some special constellation i got the 20dBm on 2,4 GHz WiFi, but i don't know how it is done :-(

comment:31 Changed 2 years ago by nbd

The limit also depends on the channel that you use. On channels closer to the edge, it will reduce the tx power to stay within regulatory limits for side-channel emissions.

comment:32 Changed 2 years ago by anonymous

There is no way a home user router outputs any higher than 250mw unless you buy some special 500mw - 1000mw rated devices (they will specifically say that)

Highest I have seen TP-Link home routers is the TP-Link WR1043ND

24dbm = 250mw (can see conversions here: http://www.moonblink.com/store/dbm_to_watt_conversion.cfm)

The OpenWRT Wiki will also show the max output power of the chipset

Usually the firmware will report some false or higher level which means
the chipset is at its max rated output - NOT @ 30dbm

comment:33 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:34 Changed 2 years ago by qasdfdsaq@…

jow@29 and anonymous@32 are both correct.

From the wiki:

SiGe SE2574L WFEs for 2.4 Ghz (20 dBm output) and SiGe SE5005L WFEs for 5 Ghz (18 dBm output)

These are the maximums of the hardware. Actual per-channel values will vary slightly according to caldata, although there are some fairly weird aberrations in mine:

  • 2452 MHz [9] (22.0 dBm)
  • 2457 MHz [10] (22.0 dBm)
  • 2462 MHz [11] (18.0 dBm)
  • 2467 MHz [12] (22.0 dBm)
  • 2472 MHz [13] (22.0 dBm)
  • 5180 MHz [36] (15.0 dBm)
  • 5200 MHz [40] (21.0 dBm)
  • 5220 MHz [44] (15.0 dBm)
  • 5240 MHz [48] (15.0 dBm)
  • 5260 MHz [52] (15.0 dBm)
  • 5280 MHz [56] (15.0 dBm)
  • 5300 MHz [60] (15.0 dBm)
  • 5320 MHz [64] (15.0 dBm)
  • 5500 MHz [100] (17.0 dBm)
  • 5520 MHz [104] (21.0 dBm)
  • 5540 MHz [108] (21.0 dBm)
  • 5560 MHz [112] (21.0 dBm)

The actual hardware maximum actually varies between 14dBm and 22dBm depending on modulation and what voltage it's driven at. But you can't just imaginarily make it do 30dBm just because you want to.

comment:35 Changed 23 months ago by anonymous

mine WDR-4300 v1.7 shows max 15dBm for 5Ghz for 36-48 channels.

comment:36 Changed 11 months ago by anonymous

+1
WDR-4300 v1.7 shows max 15dBm for 5Ghz for 36-48 channels.
Even setting channel 40, does not give option for >15dBm

comment:37 Changed 9 months ago by anonymous

Setting 5 GHz Channel 40 and adding to rc.local:

ifconfig iface2 txpower 1
sleep 1
ifconfig iface2 txpower 17

let me set up txpower to 17 on all my WDR4300. The trick was to set it to 1 before.

This method did not improve anything on 2,4 GHz channels, only on 5 GHz.

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.