Modify

Opened 4 years ago

Closed 4 years ago

Last modified 19 months ago

#11934 closed defect (worksforme)

radvd does not build in r32903

Reported by: risa2000 Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: radvd Cc:

Description

When building r32903 for ar71xx target (TL-WR1043ND) radvd package build fails with error:

make[3]: Entering directory `/home/risa/openwrt/openwrt/feeds/packages/ipv6/radvd'
(cd /home/risa/openwrt/openwrt/build_dir/target-mips_r2_uClibc-0.9.33.2/radvd-1.9.1/./; if [ -x ./configure ]; then /usr/bin/find /home/risa/openwrt/openwrt/build_dir/target-mips_r2_uClibc-0.9.33.2/radvd-1.9.1/ -name config.guess | xargs -r chmod u+w; /usr/bin/find /home/risa/openwrt/openwrt/build_dir/target-mips_r2_uClibc-0.9.33.2/radvd-1.9.1/ -name config.guess | xargs -r -n1 cp /home/risa/openwrt/openwrt/scripts/config.guess; /usr/bin/find /home/risa/openwrt/openwrt/build_dir/target-mips_r2_uClibc-0.9.33.2/radvd-1.9.1/ -name config.sub | xargs -r chmod u+w; /usr/bin/find /home/risa/openwrt/openwrt/build_dir/target-mips_r2_uClibc-0.9.33.2/radvd-1.9.1/ -name config.sub | xargs -r -n1 cp /home/risa/openwrt/openwrt/scripts/config.sub; AR=mips-openwrt-linux-uclibc-ar AS="ccache_cc -c -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float" LD=mips-openwrt-linux-uclibc-ld NM=mips-openwrt-linux-uclibc-nm CC="ccache_cc" GCC="ccache_cc" CXX="ccache_cxx" RANLIB=mips-openwrt-linux-uclibc-ranlib STRIP=mips-openwrt-linux-uclibc-strip OBJCOPY=mips-openwrt-linux-uclibc-objcopy OBJDUMP=mips-openwrt-linux-uclibc-objdump SIZE=mips-openwrt-linux-uclibc-size CFLAGS="-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float " CXXFLAGS="-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float " CPPFLAGS="-I/home/risa/openwrt/openwrt/staging_dir/target-mips_r2_uClibc-0.9.33.2/usr/include -I/home/risa/openwrt/openwrt/staging_dir/target-mips_r2_uClibc-0.9.33.2/include -I/home/risa/openwrt/openwrt/staging_dir/toolchain-mips_r2_gcc-4.7-linaro_uClibc-0.9.33.2/usr/include -I/home/risa/openwrt/openwrt/staging_dir/toolchain-mips_r2_gcc-4.7-linaro_uClibc-0.9.33.2/include " LDFLAGS="-L/home/risa/openwrt/openwrt/staging_dir/target-mips_r2_uClibc-0.9.33.2/usr/lib -L/home/risa/openwrt/openwrt/staging_dir/target-mips_r2_uClibc-0.9.33.2/lib -L/home/risa/openwrt/openwrt/staging_dir/toolchain-mips_r2_gcc-4.7-linaro_uClibc-0.9.33.2/usr/lib -L/home/risa/openwrt/openwrt/staging_dir/toolchain-mips_r2_gcc-4.7-linaro_uClibc-0.9.33.2/lib "   ./configure --target=mips-openwrt-linux --host=mips-openwrt-linux --build=x86_64-pc-linux-gnu --program-prefix="" --program-suffix="" --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --libexecdir=/usr/lib --sysconfdir=/etc --datadir=/usr/share --localstatedir=/var --mandir=/usr/man --infodir=/usr/info --disable-nls   --with-configfile=/etc/radvd.conf --with-logfile=/var/log/radvd.log --with-pidfile=/var/run/radvd.pid ; fi; )
configure: WARNING: unrecognized options: --disable-nls
configure: loading site script /home/risa/openwrt/openwrt/include/site/mips-openwrt-linux-uclibc
checking build system type... x86_64-pc-linux-gnu
checking host system type... mips-openwrt-linux-gnu
checking target system type... mips-openwrt-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for mips-openwrt-linux-strip... mips-openwrt-linux-uclibc-strip
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking architecture... linux
checking for mips-openwrt-linux-gcc... ccache_cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... yes
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether ccache_cc accepts -g... yes
checking for ccache_cc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of ccache_cc... gcc3
checking netlink... yes
checking for rm... /bin/rm
checking for sed... /home/risa/openwrt/openwrt/staging_dir/host/bin/sed
checking for ln... /bin/ln
checking for bison... bison -y
checking for flex... flex
checking lex output file root... lex.yy
checking lex library... none needed
checking whether yytext is a pointer... no
checking for tar... /bin/tar
checking for gzip... /bin/gzip
checking where to put logfile... /var/log/radvd.log
checking where to put pidfile... /var/run/radvd.pid
checking where to find configfile... /etc/radvd.conf
checking which syslog facility to use... LOG_DAEMON
checking for inet_ntop in -lc... yes
checking pkg-config is at least version 0.9.0... yes
checking for DAEMON... no
configure: error: Package requirements (libdaemon) were not met:

No package 'libdaemon' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DAEMON_CFLAGS
and DAEMON_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
make[3]: *** [/home/risa/openwrt/openwrt/build_dir/target-mips_r2_uClibc-0.9.33.2/radvd-1.9.1/.configured_] Error 1
make[3]: Leaving directory `/home/risa/openwrt/openwrt/feeds/packages/ipv6/radvd'
make[2]: *** [package/feeds/packages/radvd/compile] Error 2
make[2]: Leaving directory `/home/risa/openwrt/openwrt'
make[1]: *** [/home/risa/openwrt/openwrt/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/risa/openwrt/openwrt'
make: *** [world] Error 2

Attachments (0)

Change History (7)

comment:1 Changed 4 years ago by blogic

  • Resolution set to worksforme
  • Status changed from new to closed

i assume you used DEVELOPER=1 when building this, thus causing openwrt to not build libdaemon ... or you manually linked the module to the package/ folder causing the dependencies to not be installed.

comment:2 Changed 4 years ago by risa2000

As far as I know, I do not have DEVELOPER=1. What I do is

svn up
scripts/feeds update
scripts/feeds install radvd
make

I could throw make dirclean above that (in that case I am installing more packages, but I guess it is not important here), but it does not make any difference. It does not make any difference also if I do make oldconfig before final make. I am building ImageBuilder this way, using TP-WR1043ND "flavour".

From where should libdaemon come?

comment:3 follow-up: Changed 4 years ago by heffer

scripts/feeds install libdaemon

comment:4 in reply to: ↑ 3 Changed 4 years ago by risa2000

I should have figured this one out myself, but I was probably just hoping it will be imported by radvd package.

I hope that the build correctly builds libdaemon first and then radvd, even when the install dependency is not forced.

comment:5 Changed 4 years ago by Kenyon Ralph <kenyon@…>

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I don't have DEVELOPER=1 either, and am seeing this issue on r33329. The build system is not selecting libdaemon for the build automatically. I don't see why. The radvd Makefile syntax seems OK.

comment:6 Changed 4 years ago by jow

  • Resolution set to worksforme
  • Status changed from reopened to closed

You probably didn't update your feed or you didn't install libdaemon from it or you reused an old .config without running "make defconfig". We're unable to reproduce it in local tests, on the buildbots or during the release builds.

comment:7 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.