Modify

Opened 4 years ago

Closed 3 years ago

Last modified 22 months ago

#11943 closed defect (duplicate)

28-Jul-2012 /snapshots/trunk/x86/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64 make error

Reported by: devinlasalle@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: other Version: Trunk
Keywords: x86, imagebuilder Cc:

Description

$ make image
{{{make[1]: Entering directory `/opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64'
echo 'Building images for x86 - Generic'
Building images for x86 - Generic
echo 'Packages: base-files busybox dnsmasq dropbear firewall hotplug2 iptables kernel kmod-3c59x kmod-8139too kmod-e100 kmod-e1000 kmod-ipt-nathelper kmod-natsemi kmod-ne2k-pci kmod-pcnet32 kmod-r8169 kmod-sis900 kmod-tg3 kmod-via-rhine kmod-via-velocity libc libgcc mtd netifd opkg ppp ppp-mod-pppoe uci'
Packages: base-files busybox dnsmasq dropbear firewall hotplug2 iptables kernel kmod-3c59x kmod-8139too kmod-e100 kmod-e1000 kmod-ipt-nathelper kmod-natsemi kmod-ne2k-pci kmod-pcnet32 kmod-r8169 kmod-sis900 kmod-tg3 kmod-via-rhine kmod-via-velocity libc libgcc mtd netifd opkg ppp ppp-mod-pppoe uci
echo

rm -rf /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/build_dir/target-i386_uClibc-0.9.33.2/root-x86
mkdir -p /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/build_dir/target-i386_uClibc-0.9.33.2/root-x86 /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/bin/x86 /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/tmp

if [ ! -f "/opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/packages/Packages" ]
[ ! -f "/opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/packages/Packages.gz" ] [ "find /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/packages -cnewer /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/packages/Packages.gz" ]; then \

echo "Package list missing or not up-to-date, generating it.";\
make package_index; \

else \

mkdir -p /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/build_dir/target-i386_uClibc-0.9.33.2/root-x86/tmp; \
IPKG_TMP="/opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/tmp/ipkgtmp" IPKG_INSTROOT="/opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/build_dir/target-i386_uClibc-0.9.33.2/root-x86" IPKG_CONF_DIR="/opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/tmp" IPKG_OFFLINE_ROOT="/opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/build_dir/target-i386_uClibc-0.9.33.2/root-x86" /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/staging_dir/host/bin/opkg -f /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/repositories.conf --force-depends --force-overwrite --force-postinstall --cache /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/dl --offline-root /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/build_dir/target-i386_uClibc-0.9.33.2/root-x86 --add-dest root:/ --add-arch all:100 --add-arch x86:200 update; \

fi
Package list missing or not up-to-date, generating it.
make[2]: Entering directory `/opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64'

Building package index...
(cd /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/packages; /opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64/scripts/ipkg-make-index.sh . > Packages && \

gzip -9c Packages > Packages.gz \

) >/dev/null 2>/dev/null
make[2]: * [package_index] Error 126
make[2]: Leaving directory `/opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64'
make[1]:
* [_call_image] Error 2
make[1]: Leaving directory `/opt/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64'
make: * [image] Error 2}}}

Attachments (1)

Makefile (4.7 KB) - added by devinlasalle 4 years ago.
unedited Makefile

Download all attachments as: .zip

Change History (17)

Changed 4 years ago by devinlasalle

unedited Makefile

comment:1 Changed 4 years ago by anonymous

Bug appears to persist in 01-Aug-2012 /snapshots/trunk/x86/OpenWrt-ImageBuilder-x86_generic-for-Linux-x86_64

comment:2 follow-up: Changed 4 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

This is due to a too old (e)glibc version on your host system. The buildbots use a very recent release therefore the host utils depend on recent libc symbols. The easiest solution is to use the IB on a recent distro e.g. an Arch Linux vm.

comment:3 in reply to: ↑ 2 Changed 4 years ago by devinlasalle

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Replying to jow:

This is due to a too old (e)glibc version on your host system. The buildbots use a very recent release therefore the host utils depend on recent libc symbols. The easiest solution is to use the IB on a recent distro e.g. an Arch Linux vm.

The host system is a full Arch Linux installation with glibc 2.16.0-2, which according to http://www.gnu.org/software/libc/ is the latest stable version. The rest of the Arch Linux on this host is up to date also. What else could causes the problem?

comment:4 Changed 4 years ago by barbudor

Hi
I have the exact same problem trying to build image for WR703N or MR3020 using Aug 20th trunk snapshot.
My host is a fully up to date Xubuntu distro.
I have no problem building an image for 10.03.1 'Backfire'.

comment:5 Changed 4 years ago by anonymous

i have the same issue in ubuntu 12.04 using OpenWrt-ImageBuilder-ar71xx_generic-for-Linux-x86_64

comment:6 Changed 4 years ago by anonymous

same issue here for OpenWrt-ImageBuilder-atheros-for-linux-x86_64 on OpenSuse 12.1

comment:7 Changed 4 years ago by anonymous

I have same issue:
OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64.tar.bz2
OS:Ubuntu 10 LTS

No problem with:
OpenWrt-ImageBuilder-ar71xx-for-Linux-i686.tar.bz2
OS:Ubuntu 10 LTS

comment:8 Changed 4 years ago by anonymous

Same issue here using trunk, using Fedora 17 x86_64

comment:9 Changed 4 years ago by jow

At the people having "the same issue", please attach the output of "./staging_dir/host/bin/sed"

comment:10 Changed 4 years ago by anonymous

$ ./staging_dir/host/bin/sed
./staging_dir/host/bin/bundled/sed: relocation error: /lib/libc.so.6: symbol _dl_starting_up, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference

comment:11 Changed 4 years ago by jow

cp ./staging_dir/host/bin/bundled/lib/*/lib*.so* ./staging_dir/host/bin/bundled/lib/

Already fixed with r33353

comment:12 Changed 4 years ago by anonymous

Works, thanks!!

comment:13 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:14 Changed 3 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

the same issue for latest trunk (ar71xx, 19 Mar 2013) using 32x Ubuntu 12.04.2 with latest updates

user@u12lts:~/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64$ env LANG=en make image PROFILE=TLMR3020
make[1]: Entering directory `/home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64'
echo 'Building images for ar71xx - TP-LINK TL-MR3020'
Building images for ar71xx - TP-LINK TL-MR3020
echo 'Packages: base-files busybox dnsmasq dropbear firewall3 hotplug2 iptables kernel kmod-ath9k kmod-gpio-button-hotplug kmod-ipt-nathelper kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-netdev kmod-ledtrig-timer kmod-ledtrig-usbdev kmod-usb-core kmod-usb2 kmod-wdt-ath79 libc libgcc mtd netifd opkg ppp ppp-mod-pppoe swconfig uboot-envtools uci wpad-mini'
Packages: base-files busybox dnsmasq dropbear firewall3 hotplug2 iptables kernel kmod-ath9k kmod-gpio-button-hotplug kmod-ipt-nathelper kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-netdev kmod-ledtrig-timer kmod-ledtrig-usbdev kmod-usb-core kmod-usb2 kmod-wdt-ath79 libc libgcc mtd netifd opkg ppp ppp-mod-pppoe swconfig uboot-envtools uci wpad-mini
echo

rm -rf /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/build_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx
mkdir -p /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/build_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/bin/ar71xx /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/tmp
if [ ! -f "/home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/packages/Packages" ] || [ ! -f "/home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/packages/Packages.gz" ] || [ "`find /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/packages -cnewer /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/packages/Packages.gz`" ]; then \
                echo "Package list missing or not up-to-date, generating it.";\
                make package_index; \
        else \
                mkdir -p /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/build_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx/tmp; \
                IPKG_TMP="/home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/tmp/ipkgtmp" IPKG_INSTROOT="/home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/build_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx" IPKG_CONF_DIR="/home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/tmp" IPKG_OFFLINE_ROOT="/home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/build_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx" /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/staging_dir/host/bin/opkg -f /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/repositories.conf --force-depends --force-overwrite --force-postinstall --cache /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/dl --offline-root /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/build_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx --add-dest root:/ --add-arch all:100 --add-arch ar71xx:200 update; \
        fi
Package list missing or not up-to-date, generating it.
make[2]: Entering directory `/home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64'

Building package index...
(cd /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/packages; /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/scripts/ipkg-make-index.sh . > Packages && \
                gzip -9c Packages > Packages.gz \
        ) >/dev/null 2>/dev/null
make[2]: *** [package_index] Error 126
make[2]: Leaving directory `/home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64'
make[1]: *** [_call_image] Error 2
make[1]: Leaving directory `/home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64'
make: *** [image] Error 2
user@u12lts:~/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64$ env LANG=en ./staging_dir/host/bin/sed
./staging_dir/host/bin/sed: line 4: /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/staging_dir/host/bin/bundled/lib/ld-linux-x86-64.so.2: cannot execute binary file
./staging_dir/host/bin/sed: line 4: /home/user/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64/staging_dir/host/bin/bundled/lib/ld-linux-x86-64.so.2: Success
user@u12lts:~/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64$ ls ./staging_dir/host/bin/sed
./staging_dir/host/bin/sed
user@u12lts:~/openwrt/OpenWrt-ImageBuilder-ar71xx_generic-for-linux-x86_64$ ls -la ./staging_dir/host/bin/sed
lrwxrwxrwx 1 user user 29 марта 19 04:42 ./staging_dir/host/bin/sed -> ./bundled/run-linux-x86-64.sh

make image stops at the same point

images from BuildRoot ( as described at http://wiki.openwrt.org/doc/howto/buildroot.exigence) succesfully compiled (r36006)
old OpenWrt-ImageBuilder-ar71xx-for-Linux-i686.tar.bz2 (r29592 Wed Dec 21 01:17:15 2011)
works perfectly, but it did not contain WR3020 as target

comment:15 Changed 3 years ago by jow

  • Resolution set to duplicate
  • Status changed from reopened to closed

Dupe of #13063, I still wait for relevant info, attach it there.

comment:16 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.