Modify

Opened 4 years ago

Closed 4 years ago

Last modified 21 months ago

#11955 closed defect (worksforme)

Compiling libtool in trunk fails, wrong Perl API version

Reported by: Jonas Heinrich <onny@…> Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description (last modified by florian)

Compiling openwrt from trunk (or backfire stale) fails with the recent (stable) perl version 5.16:

make -j1 -C /home/onny/openwrt_trunk/build_dir/host/libtool-2.4 
make[4]: Entering directory `/home/onny/openwrt_trunk/build_dir/host/libtool-2.4'
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/bash /home/onny/openwrt_trunk/build_dir/host/libtool-2.4/libltdl/config/missing --run autoconf
Perl API version v5.14.0 of IO does not match v5.16.0 at /usr/share/perl5/core_perl/XSLoader.pm line 92.

I'm not sure how to fix this, but downgrading packages on Arch is usually a very bad option :/

Best regards,
Jonas

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by florian

  • Description modified (diff)

comment:2 Changed 4 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

seems to be an issue of perl modules on your system and not a bug in openwrt

comment:3 Changed 21 months ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.