Modify

Opened 4 years ago

Closed 2 years ago

Last modified 3 weeks ago

#11989 closed defect (worksforme)

USB Storage does not work on TP-Link 1043ND

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: 1043ND usb 2.0 storage Cc:

Description

My TP-Link 1043ND v1.8 is unable to use any USB storage device.

On OpenWrt Trunk r32xxx (something, probably 326xx), putting in an USB device at least brought an 1-1 device to /dev.
Now on r33014, even that doesn't shows up.

Basically, I see no /dev/sda.
Dmesg says
[ 321.810000] usb 1-1: new high-speed USB device number 4 using ehci-platform
but then does nothing to start any usb storage mounting.

fdisk -l only shows the partitions on the device flash.

Devices I've tried:

  • usb 2.0 sd card reader behind an usb 4x hub fat32
  • sata harddisk 1tb in exernal enclosure no.1 ntfs
  • sata harddisk 2tb in exernal enclosure no.2 ntfs

None of these work. The hub is detected, by the way.
I know that linux doesn't like fat32/ntfs, but that should not be part of the issue here.

This could be connected to Ticket https://dev.openwrt.org/ticket/6779, but I see no signs of
usb 1-1: device descriptor read/8, error -71
and my device doesn't even show the
Initializing USB Mass Storage driver... or comparable.
That ticket shows only the usage of the OHCI USB 1.1 driver by the way, while my devices are USB 2.0 only -> ehci.

My ehci driver seems to be installed correctly by default:
Package kmod-usb2 (3.3.8-1) installed in root is up to date.

As advised by http://wiki.openwrt.org/doc/howto/usb.essentials,
I've testet if the modules are loaded, and they seem to be:
insmod: can't insert 'usbcore': File exists
insmod: can't insert 'ehci-hcd': File exists

Now usb.essentials troubleshooting says something about scsi, which seems deprecated and was apparently removed during the last 2 years.
(That part should be updated btw, such things are not helpful at all for beginners)

The issue is identical if the usb device is plugged in at startup.

More details:
if I plug in an usb hub connected to an card reader:
[ 2663.350000] usb 1-1: new high-speed USB device number 5 using ehci-platform
[ 2663.500000] hub 1-1:1.0: USB hub found
[ 2663.500000] hub 1-1:1.0: 4 ports detected
[ 2663.800000] usb 1-1.4: new high-speed USB device number 6 using ehci-platform

then the /dev/bus/usb/001/, which always contains 001, becomes populated with 005 and 006, apparently the new devices 5 and 6.

cat 005 | hexdump and cat 006 | hexdump show about 22 to 25 bytes of data each.

Some further dmesg output:

[ 8.760000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 8.770000] ehci-platform ehci-platform: Generic Platform EHCI Controller
[ 8.780000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[ 8.810000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[ 8.830000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
..
9.080000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver

Attachments (0)

Change History (17)

comment:1 Changed 4 years ago by anonymous

Update from thread creator:
I successfully connected an Arduino uno after a sysupgrade to the newest openwrt trunk and kmod-usb-acm installed via opkg.

Therefore, the usb system seems to be working quite well, no obvious electrical or mechanical problems, core drivers seem to work.

Am I just missing some sort of storage media driver?
I guessed this would be file system independent, as the drives itself are not properly recognized, regardless of their partition types.

If further storage drivers are needed, the openWRT usb page probably needs to be updated.

comment:2 Changed 4 years ago by anonymous

I have the same issue as OP on the TP-Link MR3020. I connected a Corsair Flash Voyager (256MB) with two partitions, first one formatted as ext2, second one as swap. dmesg shows that something has been connected, but does not recognise the device as some kind of USB Storage. Here is the output of dmesg after disconnecting and reconnecting the usb storage :

[ 1353.410000] usb 1-1: USB disconnect, device number 8
[ 1353.410000] usb 1-1.1: USB disconnect, device number 9
[ 1357.770000] usb 1-1: new high-speed USB device number 10 using ehci-platform
[ 1357.930000] hub 1-1:1.0: USB hub found
[ 1357.930000] hub 1-1:1.0: 1 port detected
[ 1358.230000] usb 1-1.1: new high-speed USB device number 11 using ehci-platform

I tried connecting the device in two conditions : with uhci and ehci drivers loaded and with only ehci, but that did'nt make any difference.

comment:3 Changed 4 years ago by anonymous

Regarding the MR3020... I am ashamed to say that I did not install kmod-usb-storage. It works fine once this package is installed

comment:4 Changed 4 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 Changed 3 years ago by anonymous

maintainers does not giving a damn about usb 2.0 support. That is a really bad support.

comment:6 Changed 3 years ago by jow

You can get your money back on the way out...

comment:7 Changed 3 years ago by sparomba@…

I just upgraded from Backfire to Attitude Adjustment 12.09 (stable) and the USB issue doesn't seem to be solved. When i connect the USB device i get in dmesg:

usb 1-1: new high-speed USB device number 4 using ehci-platform

But /dev/sdax doesn't show up, so it's not possible to mount the drive.

Please dear good developers, please fix this. Thank you!

comment:8 Changed 3 years ago by nbd

Do you have usb-storage installed?

comment:9 Changed 3 years ago by hirner@…

same here, some debug info:
installed packages
Remove kmod-ledtrig-usbdev 3.3.8-1
Remove kmod-usb-core 3.3.8-1
Remove kmod-usb-ohci 3.3.8-1
Remove kmod-usb2 3.3.8-1

root@OpenWrt:~# ls /dev
bus mtd1 mtd5 null ttyS0 ttyS2 urandom
console mtd1ro mtd5ro port ttyS1 ttyS3 watchdog
full mtd2 mtdblock0 ppp ttyS10 ttyS4 zero
kmsg mtd2ro mtdblock1 ptmx ttyS11 ttyS5
log mtd3 mtdblock2 pts ttyS12 ttyS6
mem mtd3ro mtdblock3 random ttyS13 ttyS7
mtd0 mtd4 mtdblock4 shm ttyS14 ttyS8
mtd0ro mtd4ro mtdblock5 tty ttyS15 ttyS9

root@OpenWrt:~# dmesg | grep usb
[ 3.270000] Registered led device: tp-link:green:usb
[ 9.310000] usbcore: registered new interface driver usbfs
[ 9.320000] usbcore: registered new interface driver hub
[ 9.330000] usbcore: registered new device driver usb
[ 10.970000] usb 1-1: new high-speed USB device number 2 using ehci-platform

... no devices :(

comment:10 Changed 3 years ago by hirner@…

ok, make the sysupgrade and follow the wiki. then it works.

comment:11 Changed 2 years ago by danielsokolowski

Run opkg install kmod-usb-storage and continue with the wiki: http://wiki.openwrt.org/doc/howto/usb.storage#required.packages.for.usb.storage

comment:12 Changed 2 years ago by anonymous

I have upgraded yesterday from backfire to attitude adjustment (12.09, r36088), and also see no
/dev/sdXX on my system. I have all needed packages (I have read all messages in this bug report, and
also checked the wiki page on USB storage).

This is on an Asus WL500gp, v1.

comment:13 Changed 2 years ago by rafael.cassaniga@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have a tl-mr3420 and I face the same problem you reported that the external drive is detected at the USB bus.

[ 6675.220000] usb 1-1: new high-speed USB device number 11 using ehci-platform
[ 6675.370000] hub 1-1:1.0: USB hub found
[ 6675.370000] hub 1-1:1.0: 4 ports detected
[ 6678.440000] usb 1-1.2: new high-speed USB device number 12 using ehci-platform

What I could discover is that if I hook up a different external driver from another manufacturer, then openwrt sucessfully recognize it.

[ 8212.660000] usb 1-1.4: new high-speed USB device number 15 using ehci-platform
[ 8212.810000] scsi1 : usb-storage 1-1.4:1.0
[ 8213.810000] scsi 1:0:0:0: Direct-Access Seagate FreeAgent Go 100F PQ: 0 ANSI: 4
[ 8213.820000] sd 1:0:0:0: [sda] 156301488 512-byte logical blocks: (80.0 GB/74.5 GiB)
[ 8213.830000] sd 1:0:0:0: [sda] Write Protect is off

The problems seems to be linked to the manufacturer. The point is that both are correctly recognized by Windows 8.1.

comment:14 Changed 2 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

about the tl-mr3420: that device has a different usb controller than tl-wr1043nd. please try your device with current trunk, and if it doesn't work, open a new ticket.

comment:15 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:16 Changed 3 weeks ago by a33

TP-Link TL-WR1043N/ND v1.2
Fresh install of Chaos Calmer 15.05.1, r48532
NONAME 23in1 Card Reader + old 8Mb Nikon CF Card.

Plug-n-play:

[ 3535.040000] usb 1-1: new low-speed USB device number 2 using ehci-platform
[ 3535.260000] usb 1-1: device descriptor read/64, error -71
[ 3535.580000] usb 1-1: device descriptor read/64, error -71
[ 3535.810000] usb 1-1: new low-speed USB device number 3 using ehci-platform
[ 3536.030000] usb 1-1: device descriptor read/64, error -71
[ 3536.350000] usb 1-1: device descriptor read/64, error -71
[ 3536.580000] usb 1-1: new low-speed USB device number 4 using ehci-platform
[ 3537.060000] usb 1-1: device not accepting address 4, error -71
[ 3537.180000] usb 1-1: new low-speed USB device number 5 using ehci-platform
[ 3537.660000] usb 1-1: device not accepting address 5, error -71
[ 3537.660000] usb usb1-port1: unable to enumerate USB device
[ 3561.910000] usb 1-1: new high-speed USB device number 6 using ehci-platform

After reboot:

root@WR1043ND:~# dmesg | grep -i usb
[    4.150000] usbcore: registered new interface driver usbfs
[    4.160000] usbcore: registered new interface driver hub
[    4.160000] usbcore: registered new device driver usb
[    4.170000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.190000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[    4.230000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[    4.230000] hub 1-0:1.0: USB hub found
[    4.560000] usb 1-1: new high-speed USB device number 2 using ehci-platform

Additional info:

root@WR1043ND:~# cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 3.18
S:  Manufacturer=Linux 3.18.23 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=ehci-platform
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  6 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=058f ProdID=6362 Rev= 1.26
S:  Manufacturer=Generic
S:  Product=Mass Storage Device
S:  SerialNumber=058F312D81B
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

Needed packages:

root@WR1043ND:~# opkg list | grep -i kmod-scsi
kmod-scsi-cdrom - 3.18.23-1 - Kernel support for CD / DVD drives
kmod-scsi-core - 3.18.23-1 - SCSI device support
kmod-scsi-generic - 3.18.23-1 - Kernel support for SCSI generic
root@WR1043ND:~# opkg list | grep kmod-usb-storage
kmod-usb-storage - 3.18.23-1 - Kernel support for USB Mass Storage devices
kmod-usb-storage-extras - 3.18.23-1 - Say Y here if you want to have some more drivers, such as for SmartMedia card readers
root@WR1043ND:~# opkg list | grep kmod-fs
kmod-fs-autofs4 - 3.18.23-1 - Kernel module for AutoFS4 support
kmod-fs-btrfs - 3.18.23-1 - Kernel module for BTRFS support
kmod-fs-cifs - 3.18.23-1 - Kernel module for CIFS support
kmod-fs-configfs - 3.18.23-1 - Kernel module for configfs support
kmod-fs-cramfs - 3.18.23-1 - Kernel module for cramfs support
kmod-fs-exfat - 3.18.21+git-20150301-1 - Kernel module for ExFAT Filesytems
kmod-fs-exportfs - 3.18.23-1 - Kernel module for exportfs. Needed for some other modules.
kmod-fs-ext4 - 3.18.23-1 - Kernel module for EXT4 filesystem support
kmod-fs-f2fs - 3.18.23-1 - Kernel module for F2FS filesystem support
kmod-fs-fscache - 3.18.23-1 - General filesystem local cache manager
kmod-fs-hfs - 3.18.23-1 - Kernel module for HFS filesystem support
kmod-fs-hfsplus - 3.18.23-1 - Kernel module for HFS+ filesystem support
kmod-fs-isofs - 3.18.23-1 - Kernel module for ISO9660 filesystem support
kmod-fs-jfs - 3.18.23-1 - Kernel module for JFS support
kmod-fs-minix - 3.18.23-1 - Kernel module for Minix filesystem support
kmod-fs-msdos - 3.18.23-1 - Kernel module for MSDOS filesystem support
kmod-fs-nfs - 3.18.23-1 - Kernel module for NFS support
kmod-fs-nfs-common - 3.18.23-1 - Common NFS filesystem modules
kmod-fs-nfsd - 3.18.23-1 - Kernel module for NFS kernel server support
kmod-fs-ntfs - 3.18.23-1 - Kernel module for NTFS filesystem support
kmod-fs-reiserfs - 3.18.23-1 - Kernel module for ReiserFS support
kmod-fs-udf - 3.18.23-1 - Kernel module for UDF filesystem support
kmod-fs-vfat - 3.18.23-1 - Kernel module for VFAT filesystem support
kmod-fs-xfs - 3.18.23-1 - Kernel module for XFS support
root@WR1043ND:~# opkg list | grep block-mount
block-mount - 2016-01-10-96415afecef35766332067f4205ef3b2c7561d21 - Block device mounting and checking

No /dev/sdX stuff.
This Card Reader works like a charm with my Ubuntu 14.04 Dell laptop.

comment:17 Changed 3 weeks ago by anonymous

Today i have tested:

  1. The same NONAME 23in1 Card Reader but with another old 16Mb Canon SD Card with the same bad result.
  2. NONAME MicroSD USBFlash-shaped card reader with 8Gb MicroSD card.
    [56310.330000] usb 1-1: new full-speed USB device number 8 using ehci-platform
    
    root@WR1043ND:~# cat /sys/kernel/debug/usb/devices
    
    T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
    B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
    D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
    P:  Vendor=1d6b ProdID=0002 Rev= 3.18
    S:  Manufacturer=Linux 3.18.23 ehci_hcd
    S:  Product=EHCI Host Controller
    S:  SerialNumber=ehci-platform
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
    E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms
    
    T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  8 Spd=12   MxCh= 0
    D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=5136 ProdID=4678 Rev=10.00
    S:  Manufacturer=Generic 
    S:  Product=USB2.0 Device   
    S:  SerialNumber=8120420080429000
    C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
    I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
    E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
    E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
    
    
  1. Silicon Power 16Gb USB pen drive
    [56613.190000] usb 1-1: new high-speed USB device number 9 using ehci-platform
    
    root@WR1043ND:~# cat /sys/kernel/debug/usb/devices
    
    T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
    B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
    D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
    P:  Vendor=1d6b ProdID=0002 Rev= 3.18
    S:  Manufacturer=Linux 3.18.23 ehci_hcd
    S:  Product=EHCI Host Controller
    S:  SerialNumber=ehci-platform
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
    E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms
    
    T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  9 Spd=480  MxCh= 0
    D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=090c ProdID=1000 Rev=11.00
    S:  Manufacturer=UFD 2.0
    S:  Product=Silicon-Power16G
    S:  SerialNumber=1112049600009818
    C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
    I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
    E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
    E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=31875us
    

Still no luck.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.