Modify

Opened 5 years ago

Closed 4 years ago

Last modified 3 years ago

#12063 closed defect (no_response)

Relayd not working in current snapshots (r33212)

Reported by: sz.zycinski@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: relayd bridge pseudobridge relay Cc:

Description

Tested on tl-wr703n and tl-wa901nd. Even that it starts it don't work as Routed Client with relayd (Pseudobridge).

root@OpenWrt:~# ps | grep "relayd"
 1247 root       888 S    /usr/sbin/relayd -I br-lan -I wlan0 -B -D
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device  radio0
        option type     mac80211
        option channel  1
        option macaddr  14:e6:e4:ea:ba:10
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-20
        list ht_capab   SHORT-GI-40
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 0

config wifi-iface
        option device   radio0
        option network  wwan
        option mode     sta
        option ssid     NETWORK_NAME
        option encryption psk2
        option key      PRESHAREDKEY

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

config interface 'wwan'
        option proto 'dhcp'

config interface 'stabridge'
        option proto 'relay'
        option network 'lan wwan'

Attachments (2)

1.PNG (61.6 KB) - added by Crazy <crazy4@…> 5 years ago.
Working relayd on wa701nd
interfaces.PNG (45.0 KB) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (31)

comment:1 Changed 5 years ago by anonymous

Works on my 703n with r33201!

comment:2 Changed 5 years ago by sz.zycinski@…

Could you post config? I'm following wiki on openwrt.

comment:3 Changed 5 years ago by sz.zycinski@…

Works on backfire wr1043nd and on firmware from eko.one.pl (Obsy) without netifd.

comment:4 Changed 5 years ago by sz.zycinski@…

r33270 still no go .... can anyone check if it is my config fault or this i real bug?

comment:5 Changed 5 years ago by Crazy

Working on my 1043ND with r33212

This is my configuration:

1) DHCP

config dnsmasq
	option domainneeded	1
	option boguspriv	1
	option filterwin2k	0  # enable for dial on demand
	option localise_queries	1
	option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
	option rebind_localhost 1  # enable for RBL checking and similar services
	#list rebind_domain example.lan  # whitelist RFC1918 responses for domains
	option local	'/lan/'
	option domain	'lan'
	option expandhosts	1
	option nonegcache	0
	option authoritative	1
	option readethers	1
	option leasefile	'/tmp/dhcp.leases'
	option resolvfile	'/tmp/resolv.conf.auto'
	#list server		'/mycompany.local/1.2.3.4'
	#option nonwildcard	1
	#list interface		br-lan
	#list notinterface	lo
	#list bogusnxdomain     '64.94.110.11'

config dhcp lan
	option interface	lan
	option start 	100
	option limit	150
	option leasetime	12h
	option ignore	1

config dhcp wan
	option interface	wan
	option ignore	1

2) Network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0.1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.2.1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config switch
	option name 'rtl8366rb'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'rtl8366rb'
	option vlan '1'
	option ports '1 2 3 4 5t'

config switch_vlan
	option device 'rtl8366rb'
	option vlan '2'
	option ports '0 5t'

config 'interface' 'wwan'
	option 'proto' 'dhcp'

config 'interface' 'stabridge'
	option 'proto' 'relay'
	option 'network' 'lan wwan'

3) Wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option macaddr 'f8:d1:11:91:01:c6'
	option hwmode '11ng'
	option htmode 'HT20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'DSSS_CCK-40'
	option txpower '27'
	option country 'US'

config wifi-iface
	option device 'radio0'
	option mode 'sta'
	option ssid 'My Wireless Network'
	option key 'My Password'
	option encryption 'psk2+ccmp'
	option network 'wwan'

4) Firewall

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	option network	'lan wwan'
	option input		ACCEPT
	option output		ACCEPT
	option forward	ACCEPT

config zone
	option name		wan
	option network		'wan'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

comment:6 Changed 5 years ago by Craxi <crazy4@…>

No problems also on dir-825 and r33280

comment:7 Changed 5 years ago by sz.zycinski@…

I'm stuck. Config is identical! Only difference is that my routers don't have WAN port so all sections reffering to WAN don't exist, also switch config for eth0.x don't appear in my config becouse there is no switch in any of this devices.

comment:8 Changed 5 years ago by sz.zycinski@…

Strange thing is:

root@OpenWrt:~# wifi down
root@OpenWrt:~# wifi
command failed: Device or resource busy (-16)
Successfully initialized wpa_supplicant
root@OpenWrt:~#

logread:

Aug 27 20:42:33 OpenWrt kern.info kernel: [ 1069.140000] wlan0: deauthenticating from b0:48:7a:db:26:e6 by local choice (reason=3)
Aug 27 20:42:33 OpenWrt daemon.notice netifd: wwan (2492): udhcpc (v1.19.4) started
Aug 27 20:42:33 OpenWrt daemon.notice netifd: wwan (2492): Sending discover...
Aug 27 20:42:33 OpenWrt daemon.notice netifd: wwan (2492): Sending discover...
Aug 27 20:42:33 OpenWrt daemon.notice netifd: wwan (2492): Sending select for 192.168.1.172...
Aug 27 20:42:33 OpenWrt daemon.notice netifd: wwan (2492): Lease of 192.168.1.172 obtained, lease time 43200
Aug 27 20:42:33 OpenWrt daemon.notice netifd: wwan (2492): udhcpc: SIOCGIFINDEX: No such device
Aug 27 20:42:33 OpenWrt daemon.notice netifd: wwan (2492): Received SIGTERM
Aug 27 20:42:33 OpenWrt daemon.notice netifd: Interface 'wwan' is now down
Aug 27 20:42:34 OpenWrt user.info firewall: removing wwan (wlan0) from zone lan
Aug 27 20:42:37 OpenWrt kern.err kernel: [ 1073.030000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00006400
Aug 27 20:42:37 OpenWrt kern.err kernel: [ 1073.040000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
Aug 27 20:42:37 OpenWrt kern.err kernel: [ 1073.120000] ath: phy0: '''Failed to stop TX DMA, queues=0x001!'''
Aug 27 20:42:38 OpenWrt kern.info kernel: [ 1073.730000] wlan0: authenticate with b0:48:7a:db:26:e6
Aug 27 20:42:38 OpenWrt kern.info kernel: [ 1073.740000] wlan0: send auth to b0:48:7a:db:26:e6 (try 1/3)
Aug 27 20:42:38 OpenWrt kern.info kernel: [ 1073.750000] wlan0: authenticated
Aug 27 20:42:38 OpenWrt kern.info kernel: [ 1073.770000] wlan0: associate with b0:48:7a:db:26:e6 (try 1/3)
Aug 27 20:42:38 OpenWrt kern.info kernel: [ 1073.780000] wlan0: RX AssocResp from b0:48:7a:db:26:e6 (capab=0x411 status=0 aid=1)
Aug 27 20:42:38 OpenWrt kern.info kernel: [ 1073.780000] wlan0: associated
Aug 27 20:42:41 OpenWrt daemon.notice netifd: Interface 'wwan' is now up
Aug 27 20:42:41 OpenWrt user.notice ifup: Allowing Router Advertisements on wwan (wlan0)

Dunno if it has something in common. Lack of switch in device could be a problem?

comment:9 Changed 5 years ago by Crazy <crazy4@…>

Also firewall setting is the same?

config zone
	option name		lan
	option network	'lan wwan'
	option input		ACCEPT
	option output		ACCEPT
	option forward	'ACCEPT'

Note: option forward 'ACCEPT'

comment:10 Changed 5 years ago by anonymous

Of course ...

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan wwan'


root@OpenWrt:~#

Other config is in the first post. DHCP is also set to ignore.

comment:11 Changed 5 years ago by Crazy

Tomorrow I try with 701nd and let you know...

comment:12 Changed 5 years ago by Crazy <crazy4@…>

OK, another test with wa701nd and also in this device is working fast and well.
Probably you are doing something wrong with the wireless configuration.

1) DHCP

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

2)Firewall

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option network 'lan wwan'
	option forward 'ACCEPT'

3) Network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.2.1'

config interface 'wwan'
	option proto 'dhcp'

config interface 'stabridge'
	option proto 'relay'
	list network 'lan'
	list network 'wwan'

4) Wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel 'MyChannel'
	option macaddr 'd8:5d:4c:9e:b5:bc'
	option hwmode '11ng'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option disabled '0'
	option txpower '17'
	option htmode 'HT40-'
	option country 'US'

config wifi-iface
	option device 'radio0'
	option mode 'sta'
	option bssid '90:F6:52:86:xx:xx'
	option key 'MyPassword'
	option ssid 'MySSID'
	option encryption 'psk2+ccmp'
	option network 'wwan'

Please note that in this guide there are 2 errors:
http://trac.gateworks.com/wiki/relayd

I attach some images, hope you serve...

Changed 5 years ago by Crazy <crazy4@…>

Working relayd on wa701nd

comment:13 Changed 5 years ago by sz.zycinski@…

Is the signal really repeated via wifi (at onece client and AP)? In my case the router assosiciated in client mode but did not repeat signal. Works only as client, no station is associating to repeater. I followed: http://wiki.openwrt.org/doc/recipes/relayclient

comment:14 Changed 5 years ago by anonymous

Is the wireless client signal, if you don't see probably are doing something wrong with the wireless configuration (security, bssid, channel, etc etc).

Changed 5 years ago by anonymous

comment:15 Changed 5 years ago by sz.zycinski@…

Make an experiment. Turn off repeater and check if other devices near it find weaker signal. In ma case interfaces are up (but wwan is ONLY client and not repeating!). All other devices in this room don't see difference in signal quality if repeater is up and running or not. It means that it don't work correctly - insted of original Tp Link firmware where everything is ok.

comment:16 Changed 5 years ago by sz.zycinski@…

No stations assosiate with repeater...
All stations are connected to main router even if they stand next to repeater.
img207.imageshack.us/ img207/ 5943/ relyed.jpg

comment:17 Changed 5 years ago by Crazy <crazy4@…>

So you want make a repeater?
Relayd is working, repeater configuration is another thing... please someone close this ticket!
Please next time write in the forum and not here.

comment:18 Changed 5 years ago by anonymous

Read firs post .... i try to make "Routed Client with relayd (Pseudobridge)." That is repeater called in OpenWRT http://wiki.openwrt.org/doc/recipes/relayclient

Forum is not a solution, there is something wrong with NetIfD. Before Netidf was incorporated into OpenWRT everything was OK! You seem to don't understand what is going on in this problem. Ticket have to be open until someone make a patch.

comment:19 Changed 5 years ago by cave

made it a few times with different devices, and also did it yesterday on WR703n freshly new from my buildroot.

HowTo - Recipe for dummies like me
http://cavebeat.blogspot.co.at/2012/08/openwrt-bridge-with-relayd-pseudobridge.html
and
howto with config files
https://forum.openwrt.org/viewtopic.php?pid=173467#p173467

Please correct wording, Bridge and Repeater are different things!

comment:20 Changed 5 years ago by sz.zycinski@…

I must be really, really dumb but the network is not repeating using this (btw: outdated) screen shot storry how to make o repeater. When i add second wifi network (what is not covered in any of links over but seems to be needed)all i get is the same ssid but with second NAT and different subnet when i connect with static IP. I see that when analyze networks around with android phone and wifi analyzer.

Forum topic is covering only simple bridge between eth0 and radio0. No repeating at all.

I know what is bridge and repeater. It was not my idea to call it like that, the pseudobridge is coming from official openwrt site (http://wiki.openwrt.org/doc/recipes/relayclient - this os what i want to achive).

comment:21 Changed 5 years ago by sz.zycinski@…

If you made a repeater using those links you put here earlier paste here your /etc/config/wireless, /etc/config/network, /etc/config/firewall, /etc/config/dhcp
of course xxx your ssid, mac, passwords etc. I will set it up with my device and make it suitable to my situation.

Did you made two wifi-ifaces?

comment:22 Changed 5 years ago by hgrueber

I am seeing this issue also with trying to create a bridged repeater (pseudobridge).

The bridge comes up fine and works well.

The repeater doesn't work though as clients never receive DHCP addresses from upstream devices. I confirmed with a packet capture on the DHCP server that requests are being received and responses sent back to the client. The client never receives them the DHCP responses via the repeater AP.

Running r33482 on TP-link 1043nd.

https://forum.openwrt.org/viewtopic.php?pid=179279#p179279

comment:23 Changed 4 years ago by nbd

please try current trunk or 12.09

comment:24 Changed 4 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:25 Changed 3 years ago by anonymous

Seeing the same problem with AA r44550 on an AR9331 AP121

comment:26 Changed 3 years ago by cprevotaux

some users are complaining here too, https://forum.openwrt.org/viewtopic.php?id=49078

comment:27 Changed 3 years ago by cprevotaux

Last edited 3 years ago by cprevotaux (previous) (diff)

comment:28 Changed 3 years ago by cprevotaux

I think this ticket should not be closed

Last edited 3 years ago by cprevotaux (previous) (diff)

comment:29 Changed 3 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.