Modify

Opened 4 years ago

Closed 4 years ago

Last modified 2 years ago

#12102 closed defect (wontfix)

wlan led file not consistently generated

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Trunk r32996 for ath71xx for TP-Link WR741ND (and possibly WR740N too)

Installed same firmware built from trunk on six routers. Four of them don't have the file: /sys/devices/platform/leds-gpio/leds/tp-link\:green\:wlan

The other LED files are created but not this one. Note that this firmware has no wlan drivers. Something seems to be intermittent in the file creation.

Is there a way I can create this file manually after the fact as some of these routers are in the field in far away places?

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by juhosg

  • Priority changed from normal to response-needed

The hardware versions of your routers are different by any chance? Only the 4.x versions have the 'tp-link:green:wlan' LED, on the older models, it does not exists.

comment:2 follow-up: Changed 4 years ago by anonymous

Yes, this was the problem. The 741ND routers of version 4.3 worked, the 740N of version 4.21 also worked but the 741ND routers of version 2.4 did not.

The problem I have is that I cannot control the version I am shipped by my supplier. I presently have approx 10 additional units on hand of version 2.4 ready to install.

Also the 741ND version 2.4 report V1 on the luci status page even though I remember installing V2 of the firmware.

What is the possibility of getting the V2 firmware to work same as V4?

comment:3 in reply to: ↑ 2 Changed 4 years ago by juhosg

  • Resolution set to wontfix
  • Status changed from new to closed

Replying to anonymous:

Yes, this was the problem. The 741ND routers of version 4.3 worked, the 740N of version 4.21 also worked but the 741ND routers of version 2.4 did not.

The problem I have is that I cannot control the version I am shipped by my supplier. I presently have approx 10 additional units on hand of version 2.4 ready to install.

Also the 741ND version 2.4 report V1 on the luci status page even though I remember installing V2 of the firmware.

Both the v1 and the v2 uses the same hardware id in the firmware (includind the original tp-link firmwares), so it is not possible to distinguish them.

What is the possibility of getting the V2 firmware to work same as V4?

Those will never work the same way. The v4.x boards are based on a different SoC, and the wlan LED is controlled by a GPIO line of the SoC on those. On the older boards, the wlan LED is connected directly to the wifi chip.

comment:4 Changed 4 years ago by anonymous

Thanks for the info

comment:5 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.