Modify

Opened 4 years ago

Closed 6 months ago

Last modified 6 months ago

#12114 closed defect (worksforme)

NAK on DHCP renew

Reported by: imago <piotr@…> Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: udhcpc DHCP NAK Cc:

Description

Every time my DHCP lease expires, or every time I send USR1 to udhcpc process to trigger DHCP renew, DHCP request get sent, but as a response DHCP NAK is received.

Aug 26 21:33:50 OpenWrt daemon.notice netifd: wan (5630): Sending renew...
Aug 26 21:33:50 OpenWrt daemon.notice netifd: wan (5630): Received DHCP NAK
Aug 26 21:33:50 OpenWrt daemon.notice netifd: Interface 'wan' has lost the connection
Aug 26 21:33:50 OpenWrt kern.info kernel: [158999.510000] eth0: link down
Aug 26 21:33:50 OpenWrt user.info firewall: removing wan (eth0) from zone wan
Aug 26 21:33:53 OpenWrt daemon.notice netifd: wan (5630): Sending discover...
Aug 26 21:33:53 OpenWrt daemon.notice netifd: wan (5630): udhcpc: sendto: Network is down
Aug 26 21:33:53 OpenWrt daemon.notice netifd: wan (5630): Read error: Network is down, reopening socket
Aug 26 21:33:56 OpenWrt daemon.notice netifd: wan (5630): Sending discover...
Aug 26 21:33:56 OpenWrt daemon.notice netifd: wan (5630): udhcpc: sendto: Network is down
Aug 26 21:33:56 OpenWrt daemon.notice netifd: wan (5630): Read error: Network is down, reopening socket
Aug 26 21:33:59 OpenWrt daemon.notice netifd: wan (5630): udhcpc: sendto: Network is down

After initial analysis I have noticed that transaction id used in DHCP request for renewal is the same as transaction id used in initial DHCP request (after DHCP discovery) - this may be the root cause of the DHCP NAK received.

Attachments (0)

Change History (32)

comment:1 Changed 4 years ago by roni

i have dhe same problem on my wndr3800 ar71xx platform

comment:2 Changed 4 years ago by roni

here is the log

Sep 2 16:35:24 OpenWrt daemon.notice netifd: wan (3212): Sending renew...
Sep 2 16:36:20 OpenWrt daemon.notice netifd: wan (3212): Sending renew...
Sep 2 16:36:48 OpenWrt daemon.notice netifd: wan (3212): Sending renew...
Sep 2 16:37:02 OpenWrt daemon.notice netifd: wan (3212): Sending renew...
Sep 2 16:37:09 OpenWrt daemon.notice netifd: wan (3212): Sending renew...
Sep 2 16:37:12 OpenWrt daemon.notice netifd: wan (3212): Sending renew...
Sep 2 16:37:13 OpenWrt daemon.notice netifd: wan (3212): Sending renew...
Sep 2 16:37:13 OpenWrt daemon.notice netifd: wan (3212): Lease lost, entering init state
Sep 2 16:37:13 OpenWrt daemon.notice netifd: Interface 'wan' has lost the connection
Sep 2 16:37:13 OpenWrt daemon.notice netifd: wan (3212): Sending discover...
Sep 2 16:37:13 OpenWrt daemon.notice netifd: wan (3212): udhcpc: sendto: Network is down
Sep 2 16:37:13 OpenWrt daemon.notice netifd: wan (3212): Read error: Network is down, reopening socket
Sep 2 16:37:13 OpenWrt kern.info kernel: [ 3864.250000] eth1: link down
Sep 2 16:37:14 OpenWrt user.info firewall: removing wan (eth1) from zone wan
Sep 2 16:37:16 OpenWrt daemon.notice netifd: wan (3212): udhcpc: sendto: Network is down
Sep 2 16:37:16 OpenWrt daemon.notice netifd: wan (3212): Read error: Network is down, reopening socket
Sep 2 16:37:19 OpenWrt daemon.notice netifd: wan (3212): udhcpc: sendto: Network is down
Sep 2 16:37:19 OpenWrt daemon.notice netifd: wan (3212): Read error: Network is down, reopening socket
Sep 2 16:37:22 OpenWrt daemon.notice netifd: wan (3212): udhcpc: sendto: Network is down
Sep 2 16:37:22 OpenWrt daemon.notice netifd: wan (3212): Read error: Network is down, reopening socket
Sep 2 16:37:25 OpenWrt daemon.notice netifd: wan (3212): udhcpc: sendto: Network is down

comment:3 Changed 4 years ago by hnyman <hannu.nyman@…>

possible related to #12112
Duplicate?

comment:4 follow-up: Changed 4 years ago by anonymous

Is it your DHCP server problem ?
Mine is working fine.

Sep  3 13:42:28 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 13:42:28 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 14:12:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 14:12:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 14:42:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 14:42:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 15:12:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 15:12:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 15:42:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 15:42:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 16:12:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 16:12:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 16:42:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 16:42:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 17:12:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 17:12:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 17:42:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 17:42:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 18:12:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 18:12:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 18:42:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 18:42:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 19:12:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 19:12:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 19:42:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 19:42:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 20:12:31 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 20:12:31 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600

comment:5 in reply to: ↑ 4 Changed 4 years ago by anonymous

It is using r33311

Replying to anonymous:

Is it your DHCP server problem ?
Mine is working fine.

Sep  3 13:42:28 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 13:42:28 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 14:12:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 14:12:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 14:42:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 14:42:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 15:12:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 15:12:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 15:42:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 15:42:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 16:12:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 16:12:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 16:42:29 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 16:42:29 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 17:12:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 17:12:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 17:42:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 17:42:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 18:12:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 18:12:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 18:42:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 18:42:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 19:12:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 19:12:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 19:42:30 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 19:42:30 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600
Sep  3 20:12:31 MR3020 daemon.notice netifd: LAN (849): Sending renew...
Sep  3 20:12:31 MR3020 daemon.notice netifd: LAN (849): Lease of 192.168.x.x obtained, lease time 3600

comment:6 Changed 4 years ago by imago <piotr@…>

It may be, but handling of DHCP NAK - disabling the interface and then trying to use it (while disabled) for DHCP discover - doesn't look good.

comment:7 in reply to: ↑ description Changed 4 years ago by imago <piotr@…>

Even if this is DHCP server problem, handling of DHCP NAK - disabling the interface and then trying to use it (while disabled) for DHCP discover - need to be fixed.

comment:8 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r33325

comment:9 Changed 4 years ago by roni

any one can tell me if this is normal

Sep 16 15:04:01 OpenWrt daemon.notice netifd: wan (683): Sending renew...
Sep 16 15:07:46 OpenWrt daemon.notice netifd: wan (683): Sending renew...
Sep 16 15:09:38 OpenWrt daemon.notice netifd: wan (683): Sending renew...
Sep 16 15:10:34 OpenWrt daemon.notice netifd: wan (683): Sending renew...
Sep 16 15:11:02 OpenWrt daemon.notice netifd: wan (683): Sending renew...
Sep 16 15:11:16 OpenWrt daemon.notice netifd: wan (683): Sending renew...
Sep 16 15:11:23 OpenWrt daemon.notice netifd: wan (683): Sending renew...
Sep 16 15:11:26 OpenWrt daemon.notice netifd: wan (683): Sending renew...
Sep 16 15:11:27 OpenWrt daemon.notice netifd: wan (683): Sending renew...
Sep 16 15:11:27 OpenWrt daemon.notice netifd: wan (683): Lease lost, entering init state
Sep 16 15:11:27 OpenWrt daemon.notice netifd: Interface 'wan' has lost the connection
Sep 16 15:11:27 OpenWrt daemon.notice netifd: wan (683): Sending select for 10.189.176.130...
Sep 16 15:11:27 OpenWrt user.info firewall: removing wan (eth1) from zone wan
Sep 16 15:11:27 OpenWrt daemon.notice netifd: wan (683): Lease of 10.189.176.130 obtained, lease time 1800
Sep 16 15:11:27 OpenWrt daemon.notice netifd: Interface 'wan' is now up
Sep 16 15:11:28 OpenWrt user.notice ifup: Allowing Router Advertisements on wan (eth1)
Sep 16 15:11:28 OpenWrt user.info firewall: adding wan (eth1) to zone wan
Sep 16 15:11:44 OpenWrt daemon.info dnsmasq[1791]: reading /tmp/resolv.conf.auto
Sep 16 15:11:44 OpenWrt daemon.info dnsmasq[1791]: using nameserver 62.101.93.101#53
Sep 16 15:11:44 OpenWrt daemon.info dnsmasq[1791]: using nameserver 83.103.25.250#53
Sep 16 15:11:44 OpenWrt daemon.info dnsmasq[1791]: using local addresses only for domain lan

comment:10 Changed 4 years ago by nbd

Looks like a temporary connection loss that it recovers from

comment:11 Changed 4 years ago by anonymous

this happens every 30 min when the lease expires (internet connecion lost).if I put static adress on wan all works fine

comment:12 Changed 4 years ago by hansdampf

  • Resolution fixed deleted
  • Status changed from closed to reopened

If I understand this correctly this fix should be in 12.09 beta2? I flashed my TP-LINK TL-WR1043ND with the following image http://downloads.openwrt.org/attitude_adjustment/12.09-beta2/ar71xx/generic/openwrt-ar71xx-generic-tl-wr1043nd-v1-squashfs-factory.bin and seem to have the exact same issue.

With the previous OpenWRT version my internet/WAN connections used to last for weeks. With 12.09 beta 2 I get a disconnect every 60 minutes or so. Looking at the cable modem itself it reports a connection uptime of several hours, so I doubt there's something wrong with the cable connection itself.

Logs:

Dec 3 23:53:07 OpenWrt daemon.notice netifd: wan (31680): Sending renew...
Dec 3 23:53:07 OpenWrt daemon.notice netifd: wan (31680): Received DHCP NAK
Dec 3 23:53:07 OpenWrt daemon.notice netifd: Interface 'wan' has lost the connection
Dec 3 23:53:08 OpenWrt user.info firewall: removing wan (eth0.2) from zone wan
Dec 3 23:53:10 OpenWrt daemon.notice netifd: wan (31680): Sending select for x.x.x.x...
Dec 3 23:53:10 OpenWrt daemon.notice netifd: wan (31680): Lease of x.x.x.x obtained, lease time 3597
Dec 3 23:53:10 OpenWrt daemon.notice netifd: Interface 'wan' is now up

comment:13 Changed 4 years ago by imago <piotr@…>

In OpenWrt Attitude Adjustment 12.09-rc1 everything is working fine. Log after USR1 sent to udhcpc:

Dec  4 00:47:45 OpenWrt daemon.notice netifd: wan (819): Performing a DHCP renew
Dec  4 00:47:45 OpenWrt daemon.notice netifd: wan (819): Sending renew...
Dec  4 00:47:45 OpenWrt daemon.notice netifd: wan (819): Sending renew...
Dec  4 00:47:45 OpenWrt daemon.notice netifd: wan (819): Received DHCP NAK
Dec  4 00:47:46 OpenWrt daemon.notice netifd: Interface 'wan' has lost the connection
Dec  4 00:47:47 OpenWrt user.info firewall: removing wan (eth0) from zone wan
Dec  4 00:47:49 OpenWrt daemon.notice netifd: wan (819): Sending discover...
Dec  4 00:47:49 OpenWrt daemon.notice netifd: wan (819): Sending select for XXX.XXX.XXX.XXX...
Dec  4 00:47:49 OpenWrt daemon.notice netifd: wan (819): Lease of XXX.XXX.XXX.XXX obtained, lease time 143035
Dec  4 00:47:49 OpenWrt daemon.notice netifd: Interface 'wan' is now up
Dec  4 00:47:49 OpenWrt user.notice ifup: Allowing Router Advertisements on wan (eth0)
Dec  4 00:47:50 OpenWrt user.info firewall: adding wan (eth0) to zone wan
Dec  4 00:47:51 OpenWrt daemon.info dnsmasq[2361]: reading /tmp/resolv.conf.auto
Dec  4 00:47:51 OpenWrt daemon.info dnsmasq[2361]: using nameserver XXX.XXX.XXX.XXX#53
Dec  4 00:47:51 OpenWrt daemon.info dnsmasq[2361]: using nameserver XXX.XXX.XXX.XXX#53
Dec  4 00:47:51 OpenWrt daemon.info dnsmasq[2361]: using local addresses only for domain lan

comment:14 Changed 4 years ago by hansdampf

I might get you wrong but what do you mean by 'working fine'? To me this looks like the WAN interface was shutdown and enabled again which I would consider an issue as this breaks active connections etc...

I should mention that I flashed back to OpenWrt Backfire 10.03.1 for now and everything's working fine again.

comment:15 Changed 4 years ago by hansdampf

I might get you wrong but what do you mean by 'working fine'? To me this looks like the WAN interface was shutdown and enabled again which I would consider an issue as this breaks active connections etc...

I should mention that I flashed back to OpenWrt Backfire 10.03.1 for now and everything's working fine again.

comment:16 follow-up: Changed 4 years ago by imago <piotr@…>

Please take into account that DHCP NAK is received. So, starting DHCP discover is perfectly fine in that circumstances.

comment:17 in reply to: ↑ 16 Changed 4 years ago by hansdampf

Replying to imago <piotr@…>:

Please take into account that DHCP NAK is received. So, starting DHCP discover is perfectly fine in that circumstances.

Ok... I'm no DHCP expert but shouldn't it try another renew instead of resetting the interface?

Maybe the root cause is somewhere else... In 12.09 I noticed that it performs a renew every 10 minutes or so...

Dec 3 23:24:06 OpenWrt daemon.notice netifd: wan (31680): Sending renew...
Dec 3 23:39:06 OpenWrt daemon.notice netifd: wan (31680): Sending renew...
Dec 3 23:46:35 OpenWrt daemon.notice netifd: wan (31680): Sending renew...
Dec 3 23:50:19 OpenWrt daemon.notice netifd: wan (31680): Sending renew...
Dec 3 23:52:11 OpenWrt daemon.notice netifd: wan (31680): Sending renew...
Dec 3 23:53:07 OpenWrt daemon.notice netifd: wan (31680): Sending renew...
Dec 3 23:53:07 OpenWrt daemon.notice netifd: wan (31680): Received DHCP NAK
Dec 3 23:53:07 OpenWrt daemon.notice netifd: Interface 'wan' has lost the connection

... maybe this is causing the DHCP to respond with a NAK for whatever reason. What still is not true is that the WAN 'has lost the connection'. As mentioned, my cable modem's status page reports an active connection.

And as it is working in 10.03.1 something must have been changed that causes this issue.

comment:18 Changed 4 years ago by imago <piotr@…>

No, standard is strict and clear in this case.
If the client receives a DHCPNAK message, the client restarts the configuration process.

comment:19 Changed 4 years ago by anonymous

Sorry, I seemed to be wrong... It seems to be 'better' from a connection reset POV on the old version (for whatever reason) but it still occurred over night. So I assume there must be something wrong with the lease time as offered by my USPs DHCP. Will try to get this investigated at their end. Sorry for the noise... ;o)

comment:20 Changed 4 years ago by anonymous

Sorry, it appears I was wrong... It seems to be 'better' from a connection reset POV on the old version (for whatever reason) but it still occurred over night. So I assume there must be something wrong with the lease time as offered by my USPs DHCP. Will try to get this investigated at their end. Sorry for the noise... ;o)

comment:21 Changed 4 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:22 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:23 Changed 16 months ago by alirz

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Im Running "OpenWrt Attitude Adjustment 12.09.1 / LuCI Trunk (svn-r10537)"
on WRT1900AC router and im experiencing the same issue. its not clear if this bug was fixed or not.

Mar 7 19:20:50 OpenWrt daemon.notice netifd: wan (1379): Sending renew...
Mar 7 19:20:50 OpenWrt daemon.notice netifd: wan (1379): Received DHCP NAK
Mar 7 19:20:50 OpenWrt daemon.notice netifd: Interface 'wan' has lost the connection
Mar 7 19:20:50 OpenWrt daemon.warn dnsmasq[2730]: no servers found in /tmp/resolv.conf.auto, will retry
Mar 7 19:20:50 OpenWrt user.notice root: stopping ntpclient

That keeps happening every 30 minutes exactly. if i power cycle my router, i seems to be stay fine for like an hour or two but the issue starts again.

comment:24 Changed 16 months ago by anonymous

Attitude Adjustment 12.09.1 is ancient firmware. please upgrade and test newer ones

http://wiki.openwrt.org/toh/linksys/wrt1900ac#where_to_get_firmware

comment:25 Changed 16 months ago by alirz

I'm well aware of how ancient it is. I Already tried all the firmwares on that wiki months ago...
As the wiki also states that AA seems to work most stable for most, myself included.
I'm up to date on the development status and issues with the latest CC builds, but they have serious issues with stability and wifi issues.

comment:26 Changed 16 months ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

The AA build for wrt1900ac was not made by us. It is heavily modified from the original codebase, so we cannot support it.
Feel free to reopen this ticket if the bug still applies to CC, otherwise please leave it closed.

comment:27 Changed 16 months ago by anonymous

I have a similar issue, if not the same, on my TL-WDR4900 running the (almost) latest trunk build r44621.
It is connected to the cable modem provided by my ISP (KD, bridge mode enabled).

Wed Mar 11 15:04:09 2015 daemon.notice netifd: wan (18759): Sending renew...
Wed Mar 11 15:04:09 2015 daemon.notice netifd: wan (18759): Received DHCP NAK
Wed Mar 11 15:04:09 2015 daemon.notice netifd: Interface 'wan' has lost the connection

Happens every 45 minutes..

comment:28 Changed 16 months ago by alirz

  • Resolution worksforme deleted
  • Status changed from closed to reopened

See above user's post.

comment:29 Changed 6 months ago by anonymous

Every half of 30 min lease time happens that:

Fri Jan  8 18:42:35 2016 daemon.notice netifd: wwan (1430): Sending renew...
Fri Jan  8 18:50:05 2016 daemon.notice netifd: wwan (1430): Sending renew...
Fri Jan  8 18:53:50 2016 daemon.notice netifd: wwan (1430): Sending renew...
Fri Jan  8 18:55:42 2016 daemon.notice netifd: wwan (1430): Sending renew...
Fri Jan  8 18:56:38 2016 daemon.notice netifd: wwan (1430): Sending renew...
Fri Jan  8 18:57:06 2016 daemon.notice netifd: wwan (1430): Sending renew...
Fri Jan  8 18:57:20 2016 daemon.notice netifd: wwan (1430): Sending renew...
Fri Jan  8 18:57:27 2016 daemon.notice netifd: wwan (1430): Sending renew...
Fri Jan  8 18:57:30 2016 daemon.notice netifd: wwan (1430): Sending renew...
Fri Jan  8 18:57:31 2016 daemon.notice netifd: wwan (1430): Sending renew...
Fri Jan  8 18:57:31 2016 daemon.notice netifd: wwan (1430): Lease lost, entering init state
Fri Jan  8 18:57:31 2016 daemon.notice netifd: Interface 'wwan' has lost the connection
Fri Jan  8 18:57:31 2016 daemon.err miniupnpd[1553]: ioctl(s, SIOCGIFADDR, ...): Address not available
Fri Jan  8 18:57:31 2016 daemon.err miniupnpd[1553]: Failed to get IP for interface wlan0
Fri Jan  8 18:57:31 2016 daemon.warn miniupnpd[1553]: SendNATPMPPublicAddressChangeNotification: cannot get public IP address, stopping
Fri Jan  8 18:57:31 2016 daemon.warn dnsmasq[1176]: no servers found in /tmp/resolv.conf.auto, will retry
Fri Jan  8 18:57:31 2016 daemon.notice netifd: wwan (1430): Sending select for 100.73.20.40...
Fri Jan  8 18:57:31 2016 daemon.notice netifd: wwan (1430): Lease of 100.73.20.40 obtained, lease time 1800
Fri Jan  8 18:57:31 2016 daemon.notice netifd: Interface 'wwan' is now up

As a result IP changes every 30 minutes.
tcpdump says what nothing comes from server on renew requests.

comment:30 follow-up: Changed 6 months ago by anonymous

This was only happening for me with the AA builds. Those are pretty much obsolete. I switched to CC a year ago and do not have any more problems.

comment:31 Changed 6 months ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:32 in reply to: ↑ 30 Changed 6 months ago by densmoke@…

Replying to anonymous:

This was only happening for me with the AA builds. Those are pretty much obsolete. I switched to CC a year ago and do not have any more problems.

I'm on Bleeding Edge, but problem is still alive. Will try later with stable CC

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.