Modify

Opened 10 years ago

Closed 7 years ago

Last modified 7 years ago

#1212 closed defect (fixed)

b44: eth1: BUG! Timeout waiting for bit 80000000 of register 428 to clear.

Reported by: oconnor Owned by: acoul
Priority: normal Milestone: Backfire 10.03.1
Component: base system Version: Kamikaze trunk
Keywords: Cc:

Description

Hi,
I compiled the Kamikaze Firmware r6109 with target brcm-2.6. After uploading the firmware to my Asus wl-500g the AP doesn't load's all scrpits on start up and dmesg give's a bunch of rerrors: b44: eth1: BUG! Timeout waiting for bit 80000000 of register 428 to clear., like I posted in the forum, because of that my router can't find my mini-pci card (bcm or Atheros).
I found that the Problem is already fixed for Asus wl-500gP, but that solution doesn't work for the wl-500g.

Attachments (2)

170-linux_b44_driver.patch (321 bytes) - added by b.sander 10 years ago.
201-b44_phy_fix.patch (338 bytes) - added by b.sander 10 years ago.
fix for eth timeout BUG on Broadcom devices

Download all attachments as: .zip

Change History (59)

comment:1 Changed 10 years ago by nbd

  • Milestone changed from Kamikaze to Kamikaze Milestone 1

comment:2 Changed 10 years ago by rufus

With r6508 I have the same error in dmesg on the same hardware.

comment:3 Changed 10 years ago by hmr

I had a similar problem recently on a Samsung notebook. After a while I recognized that udevd had permanently allocated the ethernet interface (eth0 in my case) to a different driver (which was the ethernet over ieee1394 driver). After I deleted the permanent entries in "/etc/udev/rules.d/z25_persistent-net.rules" the main problem was gone. A remaining misbehaviour was that the allocated interface name for b44 now was eth3 after reboot. So I bound the b44 MAC explicitly to eth0, and all worked fine. Another symptom of this mess had been, that the ipw2200 driver did hang for about 60 seconds during boot, which had also been cured by the given procedure.

However, in your case, the reason possibly is also a resource conflict concerning the interface name?

Changed 10 years ago by b.sander

comment:4 Changed 10 years ago by b.sander

Hi!

170-linux_b44_driver.patch is for the brcm47xx-2.6 target. May someone give a try ...

--- linux-2.6.19.ref/drivers/net/b44.c	2007-04-10 03:59:50.000000000 +0200
+++ linux-2.6.19.ref/drivers/net/b44.c	2007-04-10 20:16:48.000000000 +0200
@@ -1807,7 +1807,7 @@
 		bw32(bp, B44_RXCONFIG, val);
 	} else {
 		unsigned char zero[6] = {0, 0, 0, 0, 0, 0};
-		int i = 0;
+		int i = 1;
 
 		__b44_set_mac_addr(bp);


comment:5 Changed 10 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:6 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [7085]

comment:7 Changed 10 years ago by acoul <alex@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened

this bug is still present on svn #8728 on kamikaze 2.6 kernel on a wrc-1000 and a RT-220 board.

BusyBox v1.4.2 (2007-09-10 15:12:19 EEST) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 KAMIKAZE (bleeding edge, r8728) -------------------
  * 10 oz Vodka       Shake well with ice and strain
  * 10 oz Triple sec  mixture into 10 shot glasses.
  * 10 oz lime juice  Salute!
 ---------------------------------------------------

root@OpenWrt:/# dmesg
 for bit 80000000 of register 428 to clear.
b44: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear.
b44: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear.
b44: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear.

comment:8 Changed 10 years ago by acoul <alex@…>

this is the dmesg from the RT220 box:

BusyBox v1.4.2 (2007-09-10 15:12:19 EEST) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 KAMIKAZE (bleeding edge, r8728) -------------------
  * 10 oz Vodka       Shake well with ice and strain
  * 10 oz Triple sec  mixture into 10 shot glasses.
  * 10 oz lime juice  Salute!
 ---------------------------------------------------
root@OpenWrt:/# cat /proc/interrupts
           CPU0
  4:        118            MIPS  eth0
  7:      63091            MIPS  timer

ERR:          0
root@OpenWrt:/# reboot -f
Segmentation fault
root@OpenWrt:/# dmesg
Linux version 2.6.22.4 (alex@lexy) (gcc version 4.2.1) #2 Mon Sep 10 16:46:30 EEST 2007
CPU revision is: 00024000
ssb: Core 0 found: SDRAM (cc 0x803, rev 0x00, vendor 0x4243)
ssb: Core 1 found: ILine 20 (cc 0x801, rev 0x00, vendor 0x4243)
ssb: Core 2 found: Fast Ethernet (cc 0x806, rev 0x00, vendor 0x4243)
ssb: Core 3 found: V90 (cc 0x807, rev 0x00, vendor 0x4243)
ssb: Core 4 found: USB 1.1 Hostdev (cc 0x808, rev 0x00, vendor 0x4243)
ssb: Core 5 found: PCI (cc 0x804, rev 0x00, vendor 0x4243)
ssb: Core 6 found: MIPS (cc 0x805, rev 0x00, vendor 0x4243)
ssb: Core 7 found: EXTIF (cc 0x811, rev 0x00, vendor 0x4243)
ssb: Core 8 found: Fast Ethernet (cc 0x806, rev 0x00, vendor 0x4243)
ssb: Initializing MIPS core...
ssb: set_irq: core 0x0806, irq 2 => 2
ssb: set_irq: core 0x0804, irq 4 => 3
ssb: set_irq: core 0x0806, irq 0 => 4
ssb: Sonics Silicon Backplane found at address 0x18000000
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
On node 0 totalpages: 4096
  Normal zone: 32 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 4064 pages, LIFO batch:0
Built 1 zonelists.  Total pages: 4064
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0,115200
Enabling BCM4710A0 cache workarounds.
Primary instruction cache 8kB, physically tagged, 2-way, linesize 16 bytes.
Primary data cache 4kB, 2-way, linesize 16 bytes.
Synthesized TLB refill handler (20 instructions).
Synthesized TLB load handler fastpath (32 instructions).
Synthesized TLB store handler fastpath (31 instructions).
Synthesized TLB modify handler fastpath (30 instructions).
PID hash table entries: 64 (order: 6, 256 bytes)
Using 62.400 MHz high precision timer.
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 13648k/16384k available (2019k kernel code, 2736k reserved, 292k data, 116k init, 0k highmem)
Calibrating delay loop... 82.43 BogoMIPS (lpj=164864)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
ssb: PCIcore in host mode found
registering PCI controller with io_map_base unset
PCI: fixing up bridge
PCI: Setting latency timer of device 0000:00:00.0 to 64
PCI: Fixing up device 0000:00:00.0
Time: MIPS clocksource has been installed.
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
squashfs: version 3.0 (2006/03/15) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) Β© 2001-2006 Red Hat, Inc.
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver $Revision: 1.90 $ 2 ports, IRQ sharing enabled
b44.c:v1.01 (Jun 16, 2006)
eth0: Broadcom 10/100BaseT Ethernet 00:01:e3:04:62:72
eth1: Broadcom 10/100BaseT Ethernet 00:01:e3:04:62:73
flash init: 0x1fc00000 0x00400000
Physically mapped flash: Found 1 x16 devices at 0x0 in 16-bit bank
 Amd/Fujitsu Extended Query Table at 0x0040
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
Flash device: 0x400000 at 0x1fc00000
bootloader size: 262144
Creating 4 MTD partitions on "Physically mapped flash":
0x00000000-0x00040000 : "cfe"
0x00040000-0x003f0000 : "linux"
0x00100000-0x003f0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
split_squasfs: no squashfs found in "Physically mapped flash"
0x003f0000-0x00400000 : "nvram"
nf_conntrack version 0.5.0 (128 buckets, 1024 max)
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP vegas registered
NET: Registered protocol family 1
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (jffs2 filesystem).
Freeing unused kernel memory: 116k freed
Warning: unable to open an initial console.
Algorithmics/MIPS FPU Emulator v1.5
diag: Router model not detected.
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
Probing device eth0: No Robo switch in managed mode found
Probing device eth1: [/extra/openwrt/trunk/build_dir/linux-brcm47xx/kmod-switch/switch-robo.c:91] SIOCGETCPHYRD failed!
[/extra/openwrt/trunk/build_dir/linux-brcm47xx/kmod-switch/switch-robo.c:91] SIOCGETCPHYRD failed!
No Robo switch in managed mode found
Probing device eth2: No such device
Probing device eth3: No such device
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
Probing device eth0: No Robo switch in managed mode found
Probing device eth1: [/extra/openwrt/trunk/build_dir/linux-brcm47xx/kmod-switch/switch-robo.c:91] SIOCGETCPHYRD failed!
[/extra/openwrt/trunk/build_dir/linux-brcm47xx/kmod-switch/switch-robo.c:91] SIOCGETCPHYRD failed!
No Robo switch in managed mode found
Probing device eth2: No such device
Probing device eth3: No such device

comment:9 Changed 10 years ago by anonymous

this issue is present in both 2.6.22.4 & 2.6.23 kernel tested as of snapshot [9287]

b44: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear.

comment:10 Changed 10 years ago by blogic

  • Resolution set to duplicate
  • Status changed from reopened to closed

comment:11 Changed 10 years ago by blogic

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:12 Changed 10 years ago by blogic

moved to #2520

comment:13 Changed 10 years ago by blogic

  • Milestone changed from Kamikaze 7.06 to 7.10?

comment:14 Changed 10 years ago by florian

  • Owner florian deleted
  • Status changed from reopened to new

Changed 10 years ago by b.sander

fix for eth timeout BUG on Broadcom devices

comment:15 Changed 10 years ago by acoul <alex@…>

this bug is still with us as of trunk [9928] on a brcm47xx device on a 2.6.23.1 kernel

b44: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear.

comment:16 Changed 10 years ago by acoul <alex@…>

b.sanders patch did not fix it on a BCM4710 device

comment:17 Changed 9 years ago by anonymous

...
diag: Router model not detected.
...

maybe here is the prob? the diag module does not have settings for gpio of your router!?

comment:18 Changed 9 years ago by acoul <alex@…>

I thought the diag modules is for the LED functionality only?

comment:19 Changed 9 years ago by ChristophMüllner

The problem is comming from the file:
target/linux/brcm-2.4/base-files/etc/init.d/netconfig (for 2.4 and 2.6 kernels).
This script seems to be buggy.
For my Western Digital NetCenter it creates a /etc/config/network file which contains a lan and a wan entry, but the netcenter has only one network interface... So changing /etc/config/network in your running system (removing the wan stuff) or changing the netconfig-script (let it only create a lan entry) fixes this bug (at least for the NetCenter).

Now a word to diag (as it has been mentioned before):
This is a module to control your gpio-lines of your processor. If your device is not dedected try to change package/broadcom-diag/src/gpio.c if you need the gpio-lines. For the NetCenter this is needed to turn on the powersupply for the internal harddisk, but in most cases the gpio-lines are just controlling the LEDs...

comment:20 Changed 9 years ago by MichaelWeiser

Is there anything happening on this? I'm being hit by it on my Asus WL-500gP with latest kamikaze 2.6.23.16 and can't put it to use. I'm waiting desperately for a fix. Is there anything I could do to help you debug it?

comment:21 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [10720]

comment:22 Changed 9 years ago by acoul <alex@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened
cpu model               : Broadcom BCM4710 V0.0
Linux version 2.6.23.16 (alex@extreme) (gcc version 4.2.3) #2 Sun Apr 6 20:25:13 EEST 2008
b44: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear.

patch [10720] deals with IOP32x architecture, I don't see how it will fix a broadcom bug ...

comment:23 Changed 9 years ago by acoul <alex@…>

here is the dmesg, this is on a toshiba wrc-1000. eth1 is down. enabling eth1 floods the dmesg with the BUG message.

Linux version 2.6.23.16 (alex@extreme) (gcc version 4.2.3) #2 Sun Apr 6 20:25:13 EEST 2008
CPU revision is: 00024000
ssb: Core 0 found: SDRAM (cc 0x803, rev 0x00, vendor 0x4243)
ssb: Core 1 found: ILine 20 (cc 0x801, rev 0x00, vendor 0x4243)
ssb: Core 2 found: Fast Ethernet (cc 0x806, rev 0x00, vendor 0x4243)
ssb: Core 3 found: V90 (cc 0x807, rev 0x00, vendor 0x4243)
ssb: Core 4 found: USB 1.1 Hostdev (cc 0x808, rev 0x00, vendor 0x4243)
ssb: Core 5 found: PCI (cc 0x804, rev 0x00, vendor 0x4243)
ssb: Core 6 found: MIPS (cc 0x805, rev 0x00, vendor 0x4243)
ssb: Core 7 found: EXTIF (cc 0x811, rev 0x00, vendor 0x4243)
ssb: Core 8 found: Fast Ethernet (cc 0x806, rev 0x00, vendor 0x4243)
ssb: Initializing MIPS core...
ssb: set_irq: core 0x0806, irq 2 => 2
ssb: set_irq: core 0x0804, irq 4 => 3
ssb: set_irq: core 0x0806, irq 0 => 4
ssb: Sonics Silicon Backplane found at address 0x18000000
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
On node 0 totalpages: 4096
  Normal zone: 32 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 4064 pages, LIFO batch:0
  Movable zone: 0 pages used for memmap
Built 1 zonelists in Zone order.  Total pages: 4064
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0,115200
Enabling BCM4710A0 cache workarounds.
Primary instruction cache 8kB, physically tagged, 2-way, linesize 16 bytes.
Primary data cache 4kB, 2-way, linesize 16 bytes.
Synthesized TLB refill handler (21 instructions).
Synthesized TLB load handler fastpath (33 instructions).
Synthesized TLB store handler fastpath (33 instructions).
Synthesized TLB modify handler fastpath (32 instructions).
PID hash table entries: 64 (order: 6, 256 bytes)
Using 62.400 MHz high precision timer.
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 13792k/16384k available (1913k kernel code, 2592k reserved, 270k data, 108k init, 0k highmem)
Calibrating delay loop... 82.43 BogoMIPS (lpj=164864)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
Time: MIPS clocksource has been installed.
ssb: PCIcore in host mode found
Registering a PCI bus after boot
PCI: Fixing up bridge 0000:00:00.0
PCI: Setting latency timer of device 0000:00:00.0 to 64
PCI: Fixing up device 0000:00:00.0
PCI: Fixing latency timer of device 0000:00:00.0 to 168
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
detected lzma initramfs
initramfs: LZMA lc=1,lp=2,pb=2,origSize=512
squashfs: version 3.0 (2006/03/15) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  Β© 2001-2006 Red Hat, Inc.
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver $Revision: 1.90 $ 2 ports, IRQ sharing enabled
b44.c:v1.01 (Jun 16, 2006)
eth0: Broadcom 10/100BaseT Ethernet 00:90:96:3f:8c:ca
eth1: Broadcom 10/100BaseT Ethernet 00:90:96:3f:8c:cb
flash init: 0x1fc00000 0x00400000
Physically mapped flash: Found 1 x16 devices at 0x0 in 16-bit bank
 Amd/Fujitsu Extended Query Table at 0x0040
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
Flash device: 0x400000 at 0x1fc00000
bootloader size: 262144
Creating 4 MTD partitions on "Physically mapped flash":
0x00000000-0x00040000 : "cfe"
0x00040000-0x003f0000 : "linux"
0x000f0000-0x003f0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
split_squashfs: no squashfs found in "Physically mapped flash"
0x003f0000-0x00400000 : "nvram"
TCP vegas registered
NET: Registered protocol family 1
NET: Registered protocol family 17
VFS: Mounted root (jffs2 filesystem) readonly.
Freeing unused kernel memory: 108k freed
Please be patient, while OpenWrt loads ...
Algorithmics/MIPS FPU Emulator v1.5
diag: Router model not detected.
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
roboswitch: Probing device eth0: No Robo switch in managed mode found
roboswitch: Probing device eth1: <3>roboswitch: [/extra3/openwrt/broadcom/trunk/build_dir/linux-brcm47xx/kmod-switch/switch-robo.c:117] SIOCGETCPHYRD failed!
roboswitch: [/extra3/openwrt/broadcom/trunk/build_dir/linux-brcm47xx/kmod-switch/switch-robo.c:117] SIOCGETCPHYRD failed!
No Robo switch in managed mode found
roboswitch: Probing device eth2: No such device
roboswitch: Probing device eth3: No such device
BFL_ENETADM not set in boardflags. Use force=1 to ignore.
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
roboswitch: Probing device eth0: No Robo switch in managed mode found
roboswitch: Probing device eth1: <3>roboswitch: [/extra3/openwrt/broadcom/trunk/build_dir/linux-brcm47xx/kmod-switch/switch-robo.c:117] SIOCGETCPHYRD failed!
roboswitch: [/extra3/openwrt/broadcom/trunk/build_dir/linux-brcm47xx/kmod-switch/switch-robo.c:117] SIOCGETCPHYRD failed!
No Robo switch in managed mode found
roboswitch: Probing device eth2: No such device
roboswitch: Probing device eth3: No such device
BFL_ENETADM not set in boardflags. Use force=1 to ignore.

comment:24 Changed 9 years ago by MichaelWeiser

This is still happening with 2.6.25.9. Is there any progress in tracking down the cause?

comment:25 Changed 9 years ago by MichaelWeiser

More importantly: What can I do to help? Give me pointers and I'll go testing, patching, compiling and trying.

comment:26 Changed 9 years ago by hayate

Yes. I have a rt-390w board and have this problem. The CPU model is BCM4704.

comment:27 follow-up: Changed 9 years ago by acoul <alex@…>

i wonder if this patch may help. will give it a try

comment:28 in reply to: ↑ 27 Changed 9 years ago by acoul <alex@…>

it didn't. the patched images are here.

comment:29 Changed 9 years ago by florian

Can you post the link to the patch if you have it ? 10.2.19.1 is not routed to me ;)

comment:30 Changed 9 years ago by acoul <alex@…>

here is the patch:

--- linux-2.6.23.17/drivers/net/b44.c.old       2008-08-14 17:34:48.000000000 +0300
+++ linux-2.6.23.17/drivers/net/b44.c   2008-08-14 17:35:45.000000000 +0300
@@ -299,6 +299,12 @@
        u32 val;
        int err;

+        /* hackish fix for wrtsl54gs, 5 fails, 30 works for eth1 */
+        if (( bp->phy_addr == 5) || ( bp->phy_addr == 4)) {
+            printk(KERN_INFO PFX "%s: Forcing PHY address to 30.\n", bp->dev->name);
+            bp->phy_addr = 30;
+        }
+
        if (bp->phy_addr == B44_PHY_ADDR_NO_PHY)
                return 0;
        err = b44_writephy(bp, MII_BMCR, BMCR_RESET);

the patched images are here

comment:31 Changed 9 years ago by MichaelWeiser

ethtool reports eth1 with phy addr 31 on my Asus WL500gP. So I tried the patch, forcing phy_addr == 31 to 30. This caused the driver to continute to initialise. But the error messages remain. Also, when I set an IP on eth1 it isn't pingable on the network connected to that interface. Instead it's suddenly pingable on the network connected to eth0. So forcing the phy addr causes some serious mixup, as suspected by the original author.

Has anyone had any success with the fix introduced through https://dev.openwrt.org/ticket/2662? It appears as target/linux/brcm47xx/patches-2.6.25/210-b44_phy_fix.patch in recent kamikaze svn. My Asus has the same switch mentioned in the ticket for the WRTSL54GS.

comment:32 Changed 9 years ago by MichaelWeiser

Today after some research my braindeadness became clear to me: I thought the switch partitions manifest themselves as normal ethernet interfaces, eth0 being the four-port-switch and eth1 the wan interface. After carefully reading http://wiki.openwrt.org/OpenWrtDocs/NetworkInterfaces and setting up the proper vlans, everything is working as expected now. It would have worked OOB if I were actually running OpenWRT. But I also neglected to mention that I'm only using the kernel and running Gentoo off an USB stick on it. Sorry for the confusion.

comment:33 Changed 9 years ago by luis@…

Latest trunk built and installed (brcm43xx with generic wireless) on a wl500g still has this bug... I haven't tested if wan link works.

The mentioned patch (from alex) also doesn't work. The problem still exists.
Is there any known workaround for this bug?
How can I help testing this? Is the 2.6 image safe to install on a WL500GP (my other wifi router)?

comment:34 Changed 8 years ago by luis.silva@…

Is there any hope of solving this problem before final release? This pretty much makes any WL500g (and possibly other units, I don't know) useless...

comment:35 Changed 8 years ago by goatzilla@…

FYI, I pulled r15324 a few days ago and tried running 2.6 on a Dell Truemobile 2300 v1, and I get a bunch of these errors as well.

comment:36 Changed 8 years ago by anonymous

Still current KAMIKAZE (8.09.1, r16278) Broadcom BCM4710 V0.0, hardware_version=WL500-02-04-02-40 (WL-500g) boardtype=bcm94710dev

comment:37 Changed 8 years ago by mauritzius@…

Unfortunately, this bug is still present in current trunk (r17207) on Asus WL-500g.

comment:38 Changed 8 years ago by luis.silva@…

8.09.2 rc2 still has this bug...

Should this unit (wl500g) be considered dead on openwrt (brcm-2.4 also doesn't work...)? Is there anyone looking at this problem? Can the owners of this platform help in any way on the debug process?

Thanks.

comment:39 Changed 7 years ago by samir.ibradzic

Still have this bug in 8.09.1, 8.09.2 and latest svn, but only only on 2.6 kernel bcrm47xx, 2.4 kernel versions seems to be fine.

comment:40 Changed 7 years ago by samir.ibradzic

ok, a line from first patch at the top of this post, 201-b44_phy_fix.patch works well when applied to Kamikaze (r19167), kernel 2.6.30.10:

--- linux-2.6.30.10/drivers/net/b44.c.old
+++ linux-2.6.23.17/drivers/net/b44.c

@@ -2092,9 +2092,9 @@
	/* Some ROMs have buggy PHY addresses with the high
	 * bits set (sign extension?). Truncate them to a
	 * valid PHY address. */
-	bp->phy_addr &= 0x1F;
+	if (sdev->id.coreid == SSB_DEV_ETHERNET) bp->phy_addr = B44_PHY_ADDR_NO_PHY;

	memcpy(bp->dev->dev_addr, addr, 6);

btw, my the affected router is Buffalo BHR-4RV which is the Japanese equivalent of WZR-RS-G54, only without WiFi inside, used to be marketed as VPN router, 8MB flash, 64MB RAM.

comment:41 Changed 7 years ago by jochen@…

I have a related problem on a MN-700. This device has two ethernet cores. One is connected to an internal unmanaged switch and a second one is directly connected to an external RJ45 port. If this port is not connected, I get lots of error message spam in the dmesg buffer and any prepending logs are lost.

To get rid of this spam, i submitted this patch:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=f6ca057f1bfe251d944505fc5ba4df3762802539

Thanks, Jochen

comment:42 Changed 7 years ago by thepeople

  • Milestone changed from Kamikaze to Backfire 10.03
  • Version set to Kamikaze trunk

comment:43 Changed 7 years ago by hayate

Will this defect be fixed in release backfire?

comment:44 Changed 7 years ago by mauritzius@…

hayate, it doesn't seem to be fixed in Backfire. On my WL500g it's still present.

comment:45 Changed 7 years ago by acoul

  • Owner set to acoul
  • Status changed from reopened to assigned

comment:46 Changed 7 years ago by sdecugis@…

If it can help, I have exactly the same bug with an OpenWRT from today's trunk, on a D-Link DIR-330 routeur (kernel 2.6.32.14, target brcm47xx, all default options).

comment:47 Changed 7 years ago by acoul

please provide the output of the following:

nvram show | grep boardtype
nvram show | grep boardnum

comment:48 Changed 7 years ago by sdecugis@…

Hello,
Here it is:
boardtype=0x042f
boardnum=12

In addition just in case:
boardflags=0x110
boardrev=0x10

I have also tried to change the file:
target/linux/brcm47xx/patches-2.6.32/210-b44_phy_fix.patch
so that the bp->phy_addr = B44_PHY_ADDR_NO_PHY; is applied unconditionally in b44_bcm47xx_workarounds(), but it did not change the behavior of the routeur (i.e. there is no packet sent over the "Internet" port -- I tried to change the vlan configuration but it only resulted in no more access to the routeur...)

Thank you for looking into this!

comment:49 follow-up: Changed 7 years ago by sdecugis@…

By the way I don't know if it is relevant, in dmesg I see:

roboswitch: Probing device eth1: found a 5325! It's a 5350.

comment:50 in reply to: ↑ 49 Changed 7 years ago by acoul

Replying to sdecugis@…:

By the way I don't know if it is relevant, in dmesg I see:

roboswitch: Probing device eth1: found a 5325! It's a 5350.

roboswitch is obsolete, no need to use it anymore. Can you try with kernel 2.6.35-rc2 and provide a dmesg output?

comment:51 Changed 7 years ago by sdecugis@…

Hello,

Here is the output. I had to disable b43 and b43legacy (not sure which one) which prevented the build.

Linux version 2.6.35-rc2+ (thedoc@chavroux) (gcc version 4.3.3 (GCC) ) #2 Fri Jun 11 14:58:03 JST 2010
CPU revision is: 00029006 (Broadcom BCM3302)
ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x03, vendor 0x4243)
ssb: Core 1 found: Fast Ethernet (cc 0x806, rev 0x06, vendor 0x4243)
ssb: Core 2 found: Fast Ethernet (cc 0x806, rev 0x06, vendor 0x4243)
ssb: Core 3 found: USB 1.1 Hostdev (cc 0x808, rev 0x03, vendor 0x4243)
ssb: Core 4 found: PCI (cc 0x804, rev 0x08, vendor 0x4243)
ssb: Core 5 found: MIPS 3302 (cc 0x816, rev 0x03, vendor 0x4243)
ssb: Core 6 found: V90 (cc 0x807, rev 0x02, vendor 0x4243)
ssb: Core 7 found: IPSEC (cc 0x80B, rev 0x00, vendor 0x4243)
ssb: Core 8 found: MEMC SDRAM (cc 0x80F, rev 0x02, vendor 0x4243)
ssb: Sonics Silicon Backplane found at address 0x18000000
Serial init done.
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00002000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00002000
On node 0 totalpages: 8192
free_area_init_node: node 0, pgdat 8027a660, node_mem_map 81000000
  Normal zone: 64 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 8128 pages, LIFO batch:0
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
Kernel command line:  root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
PID hash table entries: 128 (order: -3, 512 bytes)
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Primary instruction cache 16kB, VIPT, 2-way, linesize 16 bytes.
Primary data cache 16kB, 2-way, VIPT, cache aliases, linesize 16 bytes
Memory: 29668k/32768k available (2203k kernel code, 3100k reserved, 331k data, 148k init, 0k highmem)
NR_IRQS:128
console [ttyS0] enabled
Calibrating delay loop... 263.16 BogoMIPS (lpj=526336)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 512
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
PCI: Fixing up bridge 0000:00:00.0
PCI: Setting latency timer of device 0000:00:00.0 to 64
PCI: Fixing up device 0000:00:00.0
PCI: Fixing latency timer of device 0000:00:00.0 to 168
pci 0000:00:00.0: reg 10: [mem 0x00000000-0x00001fff]
pci 0000:00:00.0: reg 14: [mem 0x00000000-0x07ffffff pref]
pci 0000:00:01.0: reg 10: [mem 0x00000000-0x00001fff]
pci 0000:00:01.0: BAR 0: assigned [mem 0x40000000-0x40001fff]
pci 0000:00:01.0: BAR 0: set to [mem 0x40000000-0x40001fff] (PCI address [0x40000000-0x40001fff]
PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
PCI: Fixing up device 0000:00:01.0
PCI: Setting latency timer of device 0000:00:01.0 to 64
ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x0D, vendor 0x4243)
ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x09, vendor 0x4243)
ssb: Core 2 found: PCI (cc 0x804, rev 0x0C, vendor 0x4243)
ssb: Core 3 found: PCMCIA (cc 0x80D, rev 0x07, vendor 0x4243)
ssb: WARNING: Invalid SPROM CRC (corrupt SPROM)
ssb: Unsupported SPROM  revision 0 detected. Will extract v1
ssb: Sonics Silicon Backplane found on PCI device 0000:00:01.0
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
UDP hash table entries: 256 (order: 0, 4096 bytes)
UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
NET: Registered protocol family 1
PCI: CLS 0 bytes, default 32
init_vdso successfull
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
msgmni has been set to 57
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 2 ports, IRQ sharing enabled
serial8250: ttyS0 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250: ttyS1 at MMIO 0xb8000400 (irq = 3) is a 16550A
serial8250.0: ttyS0 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250.0: ttyS1 at MMIO 0xb8000400 (irq = 3) is a 16550A
flash init: 0x1c000000 0x02000000
Physically mapped flash: Found 1 x16 devices at 0x0 in 16-bit bank
Physically mapped flash: Found an alias at 0x800000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1000000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1800000 for the chip at 0x0
Amd/Fujitsu Extended Query Table at 0x0040
Physically mapped flash: Swapping erase regions for top-boot CFI table.
number of CFI chips: 1
Flash device: 0x800000 at 0x1fc00000
bootloader size: 262144
Creating 4 MTD partitions on "Physically mapped flash":
0x000000000000-0x000000040000 : "cfe"
0x000000040000-0x0000007f0000 : "linux"
0x000000111800-0x0000007f0000 : "rootfs"
mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=270000, len=580000 
0x000000270000-0x0000007f0000 : "rootfs_data"
0x0000007f0000-0x000000800000 : "nvram"
b44: b44.c:v2.0
b44 ssb0:0: eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:90:4c:4e:00:0c
b44 ssb0:1: eth1: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:90:4c:4f:00:0c
BCM47xx Watchdog Timer enabled (30 seconds, nowayout)
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 148k freed
b44 ssb0:0: eth0: Link is up at 100 Mbps, full duplex
b44 ssb0:0: eth0: Flow control is off for TX and off for RX
mini_fo: using base directory: /
mini_fo: using storage directory: /tmp/root
b44 ssb0:0: eth0: powering down PHY
b44 ssb0:0: eth0: Link is up at 100 Mbps, full duplex
b44 ssb0:0: eth0: Flow control is off for TX and off for RX
device eth0 entered promiscuous mode
br-lan: port 1(eth0) entering forwarding state
br-lan: port 1(eth0) entering forwarding state
b44 ssb0:1: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear
b44 ssb0:1: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear
b44 ssb0:1: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear
b44 ssb0:1: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear
b44 ssb0:1: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear
b44 ssb0:1: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear
b44 ssb0:1: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear
b44 ssb0:1: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear
b44 ssb0:1: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear
b44 ssb0:1: eth1: BUG!  Timeout waiting for bit 80000000 of register 428 to clear
b44 ssb0:1: eth1: Link is up at 100 Mbps, full duplex
b44 ssb0:1: eth1: Flow control is off for TX and off for RX
b44 ssb0:1: eth1: powering down PHY
b44 ssb0:1: eth1: Link is up at 100 Mbps, full duplex
b44 ssb0:1: eth1: Flow control is off for TX and off for RX
br-lan: port 1(eth0) entering forwarding state
br-lan: port 1(eth0) entering forwarding state
br-lan: port 1(eth0) entering forwarding state
jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
jffs2_build_filesystem(): unlocking the mtd device... done.
jffs2_build_filesystem(): erasing all blocks after the end marker... 

I hope this helps. Please let me know if I can do anything else...

comment:52 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in r22110

comment:53 Changed 7 years ago by realopty

  • Resolution fixed deleted
  • Status changed from closed to reopened

b44: eth0: Link is up at 10 Mbps, full duplex.
b44: eth0: Flow control is off f
or TX and off for RX.
br-lan: port 1(eth0) entering forwarding state


WARNING: at net/sched/sch_generic.c:261
0x801b4284()
NETDEV WATCHDOG: eth1 (b44): transmit queue 0 timed out
Modules linked in: ums_usbat ums_sddr55 ums_sddr09 ums_karma ums_jumpshot ums_isd200 ums_freecom ums_datafab ums_cypress ums_alauda usb_storage ehci_hcd sd_mod ide_gd_mod ext2 ext3 jbd aec62xx usbcore scsi_mod nls_base ide_core diag
Call Trace:[<8000a1a8>] 0x8000a1a8
[<8000a1a8>] 0x8000a1a8
[<80023f0c>] 0x80023f0c
[<801b4284>] 0x801b4284
[<80023f8c>] 0x80023f8c
[<8019cadc>] 0x8019cadc
[<801b4284>] 0x801b4284
[<8017da1c>] 0x8017da1c
[<8017d18c>] 0x8017d18c
[<8021a10c>] 0x8021a10c
[<8017da1c>] 0x8017da1c
[<801b4098>] 0x801b4098
[<80030a58>] 0x80030a58
[<8002b300>] 0x8002b300
[<8002b418>] 0x8002b418
[<80001444>] 0x80001444
[<8002b418>] 0x8002b418
[<8000e084>] 0x8000e084
[<80001444>] 0x80001444
[<80001660>] 0x80001660
[<8000f690>] 0x8000f690
[<8000f690>] 0x8000f690
[<8027ca88>] 0x8027ca88
[<8027c3ac>] 0x8027c3ac

---[ end trace 09311c9e4c591a5c ]---
b44: eth1: transmit timed out, resetting
b44: eth1: powering down PHY

comment:54 follow-up: Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

Don't reopen bugs because of issues that are different from the original report.

comment:55 in reply to: ↑ 54 Changed 7 years ago by anonymous

its relevant "eth1 (b44): transmit queue 0 timed out"

Replying to nbd:

Don't reopen bugs because of issues that are different from the original report.

comment:56 Changed 7 years ago by acoul

can you issue an: lsmod ?

try to remove all wifi modules and see if the problem remains.

comment:57 Changed 7 years ago by acoul

it is a good practice to remove all modules and start loading some to see where the problem occurs.

You may also wan to try this

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.