Modify

Opened 4 years ago

Closed 18 months ago

#12125 closed defect (fixed)

Network-Ports in trunk r33311 doesnt work anymore

Reported by: anonymous Owned by: juhosg
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

in r33123 all is OK.

Attachments (0)

Change History (22)

comment:1 in reply to: ↑ description Changed 4 years ago by anonymous

Replying to anonymous:

in r33123 all is OK.

Device is Edimax 3g-6200n

comment:2 Changed 4 years ago by nbd

  • Resolution set to too_vague
  • Status changed from new to closed

please provide more details, your description is way too vague

comment:3 Changed 4 years ago by anonymous

  • Resolution too_vague deleted
  • Status changed from closed to reopened

Sorry for misinformation.
Ive compiled successfully a fully working image from trunk r33123 for the device Edimax 3G6200n (Target System Ralink RT288x/RT3xxx, Subtarget RT305x based boards, Target Profile Default Profile, Image=3G6200n).

After upgrading (fresh image) to r33311 the LanPorts are not accessible anymore, so the Device gets bricked (rebricking with orig. Image from Edimax.

When i install r33123 and do a sysupgrade to r33311 (keep configuration) all seems to work except the LanPorts. Any suggestions or Solutions?

comment:4 follow-up: Changed 4 years ago by nbd

You could try running make target/linux/clean after updating your tree to the latest version, then upgrade without keeping your configuration.

comment:5 in reply to: ↑ 4 Changed 4 years ago by anonymous

Replying to nbd:

You could try running make target/linux/clean after updating your tree to the latest version, then upgrade without keeping your configuration.

I had done this several times with no effect.
I cleaned the complete "trunk" folder, proplems still here.

comment:6 Changed 4 years ago by nbd

  • Owner changed from developers to juhosg
  • Status changed from reopened to assigned

ok

comment:7 Changed 4 years ago by c.chalvanzis@…

I have the same experience with an Asus rt -n10+. The latest trunk bricked the router (ethernet ports stopped working) and I used tftp to flash an older openwrt image to make it work again. After the upgrade (keep settings) wlan was working and I could reach the router through it. When I tried to restore factory settings using Luci, the router froze! I did a power recycle and WPS light was blinking fast (as when it loads the os) but it never stopped as usualy does when the load sequence is completed.

comment:8 Changed 4 years ago by thess

I can verify that a number of RT305x platforms, including the Aztech HW550-3gn have non-functional ethernet ports. It appears as if the WAN/LAN ports are bridged (via switch?) -- very odd indeed. A machine attached to the LAN ports gets a DHCP address from upstream on the WAN segment. However, the LAN/WLAN bridge has the pre-configured static address.

The patches for ramips_esw.c originally posted on openwrt-devel last Jan were OK - at least on the platforms I've used it on.

comment:9 Changed 4 years ago by anonymous

LAN doesn't work on dir-615 h1 either.
And there is another problem. I-ve enabled wireless, but I can't see any signal or ssid. I'm using a Prolific cable to communicate with the router.

comment:10 Changed 4 years ago by c.chalvantzis@…

Did some research:
in [33298] everything works normaly
in [33299] leds stopped working
in [33300] ports stopped workings altogether

comment:11 Changed 4 years ago by anonymous

I can confirm, 33298 works (EDIMAX 3G-6200n).

comment:12 Changed 4 years ago by Guenther <guenther.racz@…>

comment:13 Changed 4 years ago by thess

[SOLVED] (Sort of - config workaround)

The main problem here is the setup of the switch on first-boot via /etc/uci-defaults/network. However, it does nothing if you already have a /etc/config/network setup from your build.

An easy workaround is to include all the switch setup configuration data in your customized /etc/config/network file. Another solution is patch the script in target/linux/ramips/base-files/etc/uci-defaults/network to NOT test for the existence of the /etc/config/network file (test is near the bottom). This seems a harmless workaround.

In addition, the new esw driver expects the bootloader to have setup the switch config default for the router. Unfortunately, most Uboot based RT305x routers have the switch configured in "dump" mode where all ports are enabled and vlans disabled. I suspect there needs to be additional board specific setup (in mach_xxxx.c files) done for the default switch configuration on each these devices.

comment:14 Changed 4 years ago by lsoltero@…

hello all,

i am trying to get the netwok ports working on an alfa w502u board and having very similar issue as the ones described above. After installation and initial configuration the lan and wan ethernet interfaces get created but the ports act like a switch and not independently. Additionally its impossible to route traffic from the router to any of the ethernet ports. (incidentally, the wifi works fine). I have documented the issues here.
https://dev.openwrt.org/ticket/12207

I have tried some of the suggestions listed above with no little luck.

Interestingly enough I have an older version of AA

lsoltero@ubuntu810vm:~/openwrt/trunk$ svn info
Path: .
URL: svn://svn.openwrt.org/openwrt/trunk
Repository Root: svn://svn.openwrt.org/openwrt
Repository UUID: 3c298f89-4303-0410-b956-a3cf2f4a3e73
Revision: 30512
Node Kind: directory
Schedule: normal
Last Changed Author: juhosg
Last Changed Rev: 30508
Last Changed Date: 2012-02-13 12:11:58 -0500 (Mon, 13 Feb 2012)

with the VLAN ports working perfectly.

Any insight into this issue would greatly be appreciated.

comment:15 Changed 4 years ago by nixxnutz

the workaround from Guenther works for me.
device is zyxel nbg-419n

comment:16 Changed 4 years ago by lsoltero@…

hello all,

anyone have an update on this? just did an svn update and running...

lsoltero@ubuntu810vm:/disk2/lsoltero/openwrt.exp$ svn info
Path: .
URL: svn://svn.openwrt.org/openwrt/trunk
Repository Root: svn://svn.openwrt.org/openwrt
Repository UUID: 3c298f89-4303-0410-b956-a3cf2f4a3e73
Revision: 34319
Node Kind: directory
Schedule: normal
Last Changed Author: florian
Last Changed Rev: 34318
Last Changed Date: 2012-11-23 17:43:11 -0500 (Fri, 23 Nov 2012)

on an Alfa w502u but no luck with the ethernet ports.

comment:17 Changed 4 years ago by anonymous

hello all,

Fix by Gunther
https://dev.openwrt.org/ticket/12125#comment:12
works for the alfa w502u

using aa 12.09 r34379

--luis

comment:18 Changed 3 years ago by guenther.racz@…

FYI: My Fix works up to r36160.
r36161 and above doesnt work anymore.

comment:19 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:20 Changed 18 months ago by anonymous

Any news on this? It's currently somehow bad, as recent builds doesn't work anymore on these devices as fix by Guenther isn't working anymore.

comment:21 Changed 18 months ago by anonymous

Is fixed a long time ago. You dont need a patch.
Ethernet works!

comment:22 Changed 18 months ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.