Modify

Opened 4 years ago

Last modified 17 months ago

#12133 new defect

rt2800pci multissid problem

Reported by: steve.harrison@… Owned by: developers
Priority: normal Milestone:
Component: kernel Version: Trunk
Keywords: Cc:

Description

Hi,

I have a arv752dpw with a RT2860T. I installed the latest openwrt trunk, using the rt2800pci driver. My aim is create an mutli ssid setup, with the following config:

config wifi-device  radio0
	option type     mac80211
	option channel  11
	option macaddr	0c:00:28:43:00:60
	option hwmode	11ng
	option htmode	HT20
	list ht_capab	GF
	list ht_capab	SHORT-GI-20
	list ht_capab	SHORT-GI-40
	list ht_capab	RX-STBC1
	# REMOVE THIS LINE TO ENABLE WIFI:
	# option disabled 1


config wifi-iface                                
        option 'device' 'radio0'                 
     	option 'ssid' 'encrypted network'
        option 'mode' 'ap'              
       	option 'network' 'lan'           
        option 'encryption' 'psk2'       
        option 'key' 'topseeeecret' 
        option macaddr  0c:00:28:43:00:61

config wifi-iface
        option 'device' 'radio0'
	option 'ssid' 'open network'
        option 'mode' 'ap'
        option 'network' 'lan'
        option macaddr  0c:00:28:43:00:60


According to linux wireless that should work, except that for the mac assignment. But it doesn't work:

root@router:/# wifi down
root@router:/# wifi up
Configuration file: /var/run/hostapd-phy0.conf
[ 3945.104000] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3945.112000] device wlan0 entered promiscuous mode
[ 3945.152000] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Using interface wlan0 with hwaddr 0c:00:28:43:00:61 and ssid 'encrypted network'
[ 3945.564000] br-lan: port 2(wlan0) entered forwarding state
[ 3945.568000] br-lan: port 2(wlan0) entered forwarding state
[ 3945.572000] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 3945.588000] device wlan0-1 entered promiscuous mode
Could not set int[ 3945.600000] device wlan0-1 left promiscuous mode
[ 3945.604000] br-lan: port 3(wlan0-1) entered disabled state
erface wlan0-1 flags: Device or resource busy
Failed to add BSS (BSSID=0c:00:28:43:00:60)
Interface initialization failed
wlan0: Unable to setup interface.
Failed to remove [ 3945.640000] device wlan0 left promiscuous mode
[ 3945.644000] br-lan: port 2(wlan0) entered disabled state
BSS interface wlan0-1
Failed to start hostapd for phy0

Is this my error or an defect?

Attachments (0)

Change History (9)

comment:1 Changed 4 years ago by anonymous

I can confirm this problem on a RT3050F based DIR-300 b1.

There seems to be a patch that adds support in the driver, and although it allows setting up multiple SSIDs, actually connecting to the network doesn't work: https://patchwork.kernel.org/patch/1277291/

comment:2 Changed 4 years ago by koen.bijttebier@…

I seem to have the same problem.

root@OpenWrt:~# wifi down
root@OpenWrt:~# wifi up
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr b8:a3:86:12:67:66 and ssid 'OpenWrt'
Could not set interface wlan0-1 flags: Device or resource busy
Failed to add BSS (BSSID=ba:a3:86:12:67:67)
Interface initialization failed
wlan0: Unable to setup interface.
Failed to remove BSS interface wlan0-1
Failed to start hostapd for phy0

comment:3 Changed 4 years ago by usr-sse2

Oh, in Wive-RTNL it really creates network, but nobody can connect to it, as anonymous said. And OpenWRT shows the error.

comment:4 Changed 4 years ago by nbd

please test the latest version to see if the issue still happens there.

comment:5 Changed 4 years ago by koen.bijttebier@…

I Updated to revision 33532. (full checkout of the sources)
Done a full rebuild. But the problem seems to be the same (same error).
Is there anything that I can do to help ? Any debug/log that you need ?

comment:6 Changed 4 years ago by martin

Hi, also suffering ! :P

I'm using revision 33535 built from cvs. Target hardware is Dir-600 RevB,

target: ramips,
platform: RaLink RT288x/RT305x WiSoC 
wireless nic: Ralink RT3050F

error shows:

Command failed: Not found
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr 00:26:5a:a5:25:6c and ssid "TetragrammatonChurch"
Could not set interface wlan0-1 flags (UP): Device or resource busy
Failed to add BSS (BSSID=02:26:5a:a5:25:6d)
Interface initialization failed
wlan0: Unable to setup interface.
Failed to remove BSS interface wlan0-1
Failed to start hostapd for phy0

Configuration borrowed from the wiki.
Thanks

comment:8 Changed 3 years ago by Aleksandar Kostadinov <akostadinov@…>

Are there patches also required for sta/adhoc/ap mixed mode multi-ssid setup?

http://patchwork.openwrt.org/patch/3778/
http://patchwork.openwrt.org/patch/3786/

btw how do I know what revision a patch is applied to?

comment:9 Changed 17 months ago by pen.friend@…

is virtual ap now working? with rt 2800 drivers...

i have an asus WL330N3G - the stock firmware can do it, but someone said openwrt does not allow this (yet) due to this driver..

what about barrier breaker? is it fixed / new driver ?

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.