Modify

Opened 4 years ago

Last modified 2 months ago

#12135 reopened defect

PAPRD still damages AR93?*!

Reported by: Halo2 Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

As #12073 was closed I now tried to install >=r33278 on AR9381 (Buffalo WZR-HP-G450H) (instead of on AR9331 (Hornet-UB), because all of them I had are dead thanks to r33031).

The consequence is still the same, rx for anything not near range gets deaf (after some hours, not instantly after upgrade). Downgrade does not bring it back, so its dead permanently.

Transfers on near range still work as before.

Received SN from that device on a reference node (ar9280/ar9223) shows 20-21 without and 70-80 with paprd on 'idle'. On transfer its unbelievable 97-98 in both cases.

So please look that up really conscientious this time!

I would suggest to disable it by default again, and as this is so dangerous only enable it after real intensive testing.
Cause I'm sure I'm not the only one unhappy about destroyed routers.

Thank you

Attachments (0)

Change History (15)

comment:1 follow-up: Changed 4 years ago by nbd

Have you tried if unplugging the device, leaving it powered off for a while, then plugging it back in helps to bring back some of the rx sensitivity?

comment:2 in reply to: ↑ 1 Changed 4 years ago by Halo2

Replying to nbd:

Have you tried if unplugging the device, leaving it powered off for a while, then plugging it back in helps to bring back some of the rx sensitivity?

Unfortunately not.

After the downgrade I've selected other antennas (was using only tx and rx on 1), and that instantly gives neighbours. But back to 1 and they are gone.
After reconnecting power I've just tested it with original Firmware. Good Range, but speed varied a lot on range, so I thought thats because of lost sensitivity on antenna 1.. .

Have already "decommissioned" the router, but if you really think I have to try it again (disconnected power did not help on hornet..) I can get it back for that before getting rid of it finally.

comment:3 Changed 4 years ago by nbd

I asked people from Qualcomm Atheros to look into this. I'll let you know when I get more information.

comment:4 follow-up: Changed 4 years ago by nbd

I just looked at a WZR-HP-G450H, and it does not have PA predistortion enabled in EEPROM. Can you check yours?

cat /sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom

comment:5 in reply to: ↑ 4 Changed 4 years ago by Halo2

Replying to nbd:

I just looked at a WZR-HP-G450H, and it does not have PA predistortion enabled in EEPROM. Can you check yours?

cat /sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom

So i took it back to my environment temporary and flashed OpenWRT again to check rx on ant 1 and its still deaf (after a day or so without power).

And then I read your message, just after flashing dd-wrt again. Nice that it shows it too:

      EEPROM Version :          2
          RegDomain1 :          0
          RegDomain2 :       7936
             TX Mask :          7
             RX Mask :          7
          Allow 5GHz :          0
          Allow 2GHz :          1
   Disable 2GHz HT20 :          0
   Disable 2GHz HT40 :          0
   Disable 5Ghz HT20 :          0
   Disable 5Ghz HT40 :          0
          Big Endian :          0
           RF Silent :          0
           BT option :          0
          Device Cap :          0
         Device Type :          4
  Power Table Offset :          0
        Tuning Caps1 :         66
        Tuning Caps2 :          0
 Enable Tx Temp Comp :          1
 Enable Tx Volt Comp :          0
   Enable fast clock :          1
     Enable doubling :          1
  Internal regulator :          1
        Enable Paprd :          1
     Driver Strength :          0
          Quick Drop :          0
   Chain mask Reduce :          0
   Write enable Gpio :          3
   WLAN Disable Gpio :          0
       WLAN LED Gpio :          8
 Rx Band Select Gpio :        255
             Tx Gain :          3
             Rx Gain :          0
              SW Reg :          0
          MacAddress : xx:xx:xx:xx:xx:xx

Interesting that yours has it disabled.. .

Thanks very much for your efforts!

comment:6 follow-up: Changed 4 years ago by nbd

I got some feedback from QCA saying that under normal conditions there is no way that PAPRD alone can physically damage the rx path.

What could damage both the PA and the rx path is enabling it while leaving disconnected antennas configured.

comment:7 in reply to: ↑ 6 ; follow-up: Changed 4 years ago by Halo2

Replying to nbd:

I got some feedback from QCA saying that under normal conditions there is no way that PAPRD alone can physically damage the rx path.

What could damage both the PA and the rx path is enabling it while leaving disconnected antennas configured.

But external antenna was connected the whole time, and stable (measured every day). No config file changed. Update - deaf. On the configured and connected antenna working before. Again.

If its no problem I hope on the ones who try to reproduce it ;-).

ad-hoc, diversity 0, rxantenna and txantenna 1 (also on 1 chain ar9331..).
(Not the original antenna, some bigger omni and cable.. . Do I really have to try it with original one next (router) time?!)

comment:8 in reply to: ↑ 7 Changed 4 years ago by Halo2

I'll try tx 4 rx 7.
First with original antennas, if nothing happens with external omni.
Will be interesting if only chain "3" gets deaf or both remaining ones (or nothing).

comment:9 follow-up: Changed 4 years ago by nbd

I don't think you should deliberately try to use disconencted antennas, I was just looking for possible causes.

comment:10 in reply to: ↑ 9 Changed 4 years ago by Halo2

Replying to nbd:

I don't think you should deliberately try to use disconencted antennas, I was just looking for possible causes.

Think you got this other then I've meant it.
Doing it with 3 antennas connected. Sending only on the 3rd one (receiving on all) and looking if only this connected tx one gets damaged (like when using only antenna 1 for rx and tx). Or if the receiving (and connected) ones strike too.
Never configured and used a not connected one!

comment:11 follow-up: Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

PAPRD disabled in r33332, I'll let you know when I get more info from atheros

comment:12 in reply to: ↑ 11 ; follow-up: Changed 4 years ago by Halo2

Replying to nbd:

PAPRD disabled in r33332, I'll let you know when I get more info from atheros

Currently testing the remaining chains.
From the most unlikely causing config to the most likely.
I'll post the results as soon as I have some.. .

comment:13 in reply to: ↑ 12 Changed 4 years ago by Halo2

Replying to Halo2:

Replying to nbd:

PAPRD disabled in r33332, I'll let you know when I get more info from atheros

Currently testing the remaining chains.
From the most unlikely causing config to the most likely.
I'll post the results as soon as I have some.. .

Okay, finished.
There could have been more research done, but its over for now, because all 3 chains are dead yet.

I would really love to give the router to QCA or Buffalo, then they propably could find out what this hardware has. But I think they will just trash defect ones so.. .

What I've done and found out is:

Chain1 already got totally deaf before (no packets received). (Reason for opening the ticket.)
Chain2 (rx3) and chain3(+chain2) (rx7) gave many packets from many stations.

With all 3 original antennas:

One day with tx chain2 (tx2/rx3), one day with tx chain3 (tx4/rx7). *1
All stations are still visible, with chain2 (rx3) as with chain3(+chain2) (rx7).

Connect external antenna (big omni, "pigtail", lambda/4 surge protection, long cable, pigtail) to chain2 (chain1 and chain3 still connected with original antennas):

One day with tx chain3 (tx4/rx7). *2 (So not the external. Why: Wanted to know if rx on external is enough to get deaf.)
Chain2 (rx3) and chain3(+chain2) (rx7) still gave all stations. So chain2 is still okay and only rx on external did not do any harm on this receiving chain (but says nothing for chain3 to be correct).

One day with tx chain2 (tx2/rx7). *3 (So tx on external now.)
Chain2 (rx3) and chain3(+chain2) (rx7) give no packets from no stations. So chain2 is dead now and chain3 is dead too (gone now, or before.)

So chain2 has gone on the day (and even before the night) when beeing used for tx (and rx) on external antenna.

And chain3 has gone when beeing used for tx (and rx) on internal antenna when external antenna was connected to an other rx (only) chain. (*2)
Or it has gone when beeing used for rx (only) on internal antenna when external antenna was connected to an other tx (and rx) chain. *3
Or it could even be that it has been gone when tested with internal antennas only (as nothing or as tx and rx (and chain2 just had "luck" there) or even before). *1

Tried to exclude just coincidences.
Hope this helps.

Propably should be done again without paprd.
But as this device was stable till activation of it, its unlikely to be whole independent of that (and hornet-ub also has gone after paprd enablement (additionaly there was a now corrected error in the code), but I had a dead chain on another wzr-hp-g450h some time before (so before paprd got enabled)).
And propably on another antenna (which I have in similar setup) (hornet-ub was on the same one, but others (wzr-hp-ag300h (ar92?*), wrt54gs) have run stable for a long time on it and still are okay).

comment:14 Changed 22 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:15 Changed 2 months ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

problem not solved. the exact same malfunction happened with GL-AR150 device in CC/DD.

ano no, nothing so far won't bring it back just as OP wrote.

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.