Modify

Opened 4 years ago

Closed 3 years ago

Last modified 2 years ago

#12159 closed defect (no_response)

ath9k: 5.4Ghz radio lost after some time in r33288

Reported by: Aaron Opfer <me@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

My device is the WZR-HP-AG300H. My phone is Galaxy Nexus which has 2.4Ghz and 5.4Ghz radios. When setting the phone to listen only to 5.4Ghz, after a few days I begin to notice that WiFi no longer connects even though the router is broadcasting the SSID. Some association step appears to fail. Switching the phone to use the 2.4Ghz band and the connection occurs immediately. Power-cycling the router fixes the issue temporarily, as does logging into the router and restarting the wifi interfaces. I've been running trunk for a month and flashed new revisions several times and have had this issue on all of them.

I cannot seem to provoke the connection loss, I just pick up my phone sometime and the wifi isn't connected and failed over to 4G.

Attachments (0)

Change History (19)

comment:1 Changed 4 years ago by Aaron Opfer <me@…>

As an addendum: the weirdest part about this issue is that the SSID is still broadcasted. I think that hostapd may be the guilty party rather than ath9k. The next time the issue occurs, I will attempt to obtain a dmesg log and logread dump so that we might have more information to go off of.

comment:2 Changed 4 years ago by nigel@…

I have similar problems but it seems to happen on both radios on my TP-Link WDR4300. Restarting the radio through the web interface fixed the problem.

comment:3 Changed 4 years ago by cat@…

I'm having the same problem with my Galaxy Nexus against a Netgear WNDR3700 (ath9k AR9280) running 3.3.8.

I have two phys, 2.4G and 5G, on different SSIDs but otherwise with identical settings (encryption). My hostapd.conf for the 5G phy1 is:

ctrl_interface=/var/run/hostapd-phy1
driver=nl80211
wmm_ac_bk_cwmin=4
wmm_ac_bk_cwmax=10
wmm_ac_bk_aifs=7
wmm_ac_bk_txop_limit=0
wmm_ac_bk_acm=0
wmm_ac_be_aifs=3
wmm_ac_be_cwmin=4
wmm_ac_be_cwmax=10
wmm_ac_be_txop_limit=0
wmm_ac_be_acm=0
wmm_ac_vi_aifs=2
wmm_ac_vi_cwmin=3
wmm_ac_vi_cwmax=4
wmm_ac_vi_txop_limit=94
wmm_ac_vi_acm=0
wmm_ac_vo_aifs=2
wmm_ac_vo_cwmin=2
wmm_ac_vo_cwmax=3
wmm_ac_vo_txop_limit=47
wmm_ac_vo_acm=0
tx_queue_data3_aifs=7
tx_queue_data3_cwmin=15
tx_queue_data3_cwmax=1023
tx_queue_data3_burst=0
tx_queue_data2_aifs=3
tx_queue_data2_cwmin=15
tx_queue_data2_cwmax=63
tx_queue_data2_burst=0
tx_queue_data1_aifs=1
tx_queue_data1_cwmin=7
tx_queue_data1_cwmax=15
tx_queue_data1_burst=3.0
tx_queue_data0_aifs=1
tx_queue_data0_cwmin=3
tx_queue_data0_cwmax=7
tx_queue_data0_burst=1.5
hw_mode=a
channel=36

country_code=CA

logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
ieee80211n=1
ht_capab=[HT20][SHORT-GI-40][TX-STBC][RX-STBC1][DSSS_CCK-40]
ieee80211d=1
preamble=0

interface=wlan1
ctrl_interface=/var/run/hostapd-phy1
wpa_passphrase=<snip>
auth_algs=1
wpa=2
wpa_pairwise=CCMP
ssid=HammerTime-A
bridge=br-lan
wmm_enabled=1
bssid=20:4e:7f:7c:c6:98
ignore_broadcast_ssid=0

I keep my Galaxy Nexus wifi set to "5G Only" and I set up my laptop wifi in monitor mode (it's a iwl4965 so I trust it) on the right channel. I can see beacons from the AP consistently.

When I toggle the GN wifi on/off, I don't see anything with the phone's MAC address, it must only do passive scanning. Even when I touch the network and hit "Connect" I don't get anything immediately but _eventually_ I see this:

a0:0b:ba:c8:cf:1c  Broadcast  128  Probe Request, SN=1, FN=0, Flags=........, SSID=Broadcast
a0:0b:ba:c8:cf:1c  Broadcast  128  Probe Request, SN=2, FN=0, Flags=........, SSID=Broadcast
a0:0b:ba:c8:cf:1c  Broadcast  128  Probe Request, SN=6, FN=0, Flags=........, SSID=Broadcast
a0:0b:ba:c8:cf:1c  Broadcast  140  Probe Request, SN=1, FN=0, Flags=........, SSID="HammerTime-A"
a0:0b:ba:c8:cf:1c  Broadcast  140  Probe Request, SN=2, FN=0, Flags=........, SSID="HammerTime-A"
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=3, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=3, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=4, FN=0, Flags=........
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=4, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=4, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=4, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=4, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=4, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=4, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=5, FN=0, Flags=........
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=5, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=5, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=5, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=5, FN=0, Flags=....R...
a0:0b:ba:c8:cf:1c  20:4e:7f:7c:c6:98  59  Authentication, SN=5, FN=0, Flags=....R...

Nothing interesting in the tail of dmesg. Interrupts seems to be flowing for both phys at ~100/s.

Anything else I can poke at?

comment:4 Changed 4 years ago by Del <delonly@…>

Consider if your issues are duplicates of #11894

comment:5 Changed 4 years ago by cat@…

It does seem like the issues are similar (AP won't respond to mgmt frames anymore), but for me the problem only occurs on 5G and not 2.4G.

It has also stopped working for me entirely - my phone can consistently connect to the 2.4G network and never the 5G.

My laptop, however, can connect to both. I'm going to try to do some more captures with 2.4G turned off everywhere to try to narrow down the problem.

comment:6 Changed 4 years ago by Aaron Opfer <me@…>

I actually have not been able to reproduce this issue since I reported it, and I now have quite a few idle WiFi devices on either radio floating around now.

Also, I'm a bit of a liar: I didn't actually see the bug in r33288, I flashed to r33288 after experiencing the bug and then reported it anyway, fully expecting to run into the problem again. Maybe others who have this issue can specify if they're also on this revision.

comment:7 Changed 4 years ago by cat@…

FWIW I'm on r33369. Also tried disabling any encryption, 11n and WMM in hostapd, still no assoc.

comment:8 Changed 4 years ago by cat@…

Set up a mon1 interface attached to phy1 (5G) on the AP and ran hostapd in another terminal. I can see other devices nearby (people's iPhones etc) sending probe req, and hostapd responds. I can also see my laptop getting assoc'd to the AP and traffic flows just fine. .. but when my Galaxy Nexus tries to associate, I can see the auth packets on my laptop's mon0, but nothing shows up on the AP's mon1.

comment:9 Changed 4 years ago by cat@…

rmmod'ed ath9k*, ath, and *80211. Now when starting hostapd I see the deauth to broadcast, but no beacon frames at all.

Seems the phone might also be partially to blame:
http://code.google.com/p/android/issues/detail?id=34942

comment:10 Changed 4 years ago by nbd

Please try the latest version, the hostapd config change in r33399 might help...

comment:11 Changed 4 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:12 Changed 4 years ago by cat@…

I'm running r33576 and still having issues. Now Android won't see the router at all. But I also still think it might be mostly the phone's fault.

Is there any way to adjust ath9k sensitivity?

comment:13 Changed 4 years ago by Aaron Opfer <me@…>

Okay, I'm running the beta and my hardware is now in this bugged
state. I unfortunately cannot give any logdata because SSH bots filled
my log buffer with failed logins. But, I have access to:

The router itself
The galaxy nexus that doesn't connect on either 2.4Ghz or 5.4Ghz
A linux laptop that can sniff wifi, which also doesn't connect on 2.4Ghz

I can even grant a developer who wants to sniff around SSH access to
the laptop and router if they want to figure it out. Note that
restarting the router or the wireless hardware will almost certainly
make the bug go away, and we'd have to wait several days for it to
break again.

comment:14 Changed 4 years ago by Aaron Opfer <me@…>

Okay, I'm running the beta and my hardware is now in this bugged
state. I unfortunately cannot give any logdata because SSH bots filled
my log buffer with failed logins. But, I have access to:

The router itself
The galaxy nexus that doesn't connect on either 2.4Ghz or 5.4Ghz
A linux laptop that can sniff wifi, which also doesn't connect on 2.4Ghz

I can even grant a developer who wants to sniff around SSH access to
the laptop and router if they want to figure it out. Note that
restarting the router or the wireless hardware will almost certainly
make the bug go away, and we'd have to wait several days for it to
break again.

comment:15 Changed 3 years ago by me@…

  • Resolution no_response deleted
  • Status changed from closed to reopened

I finally captured debug output of a factory fresh Galaxy Nexus attempting a handshake to my router.

WPA: wpa_sm_step() called recursively
wlan0: STA 18:e2:c2:88:f9:1f IEEE 802.1X: unauthorizing port
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-DEAUTHENTICATE.indication(18:e2:c2:88:f9:1f, 2)
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-DELETEKEYS.request(18:e2:c2:88:f9:1f)
wlan0: STA 18:e2:c2:88:f9:1f WPA: event 3 notification
wlan0: STA 18:e2:c2:88:f9:1f IEEE 802.1X: unauthorizing port
Could not set station 18:e2:c2:88:f9:1f flags for kernel driver (errno=124).
wlan0: STA 18:e2:c2:88:f9:1f IEEE 802.11: deauthenticated
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-DEAUTHENTICATE.indication(18:e2:c2:88:f9:1f, 7)
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-DELETEKEYS.request(18:e2:c2:88:f9:1f)
wlan0: STA 18:e2:c2:88:f9:1f IEEE 802.11: authentication OK (open system)
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-AUTHENTICATE.indication(18:e2:c2:88:f9:1f, OPEN_SYSTEM)
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-DELETEKEYS.request(18:e2:c2:88:f9:1f)
wlan0: STA 18:e2:c2:88:f9:1f IEEE 802.11: authenticated
wlan0: STA 18:e2:c2:88:f9:1f IEEE 802.11: association OK (aid 2)
wlan0: STA 18:e2:c2:88:f9:1f IEEE 802.11: associated (aid 2)
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-ASSOCIATE.indication(18:e2:c2:88:f9:1f)
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-DELETEKEYS.request(18:e2:c2:88:f9:1f)
wlan0: STA 18:e2:c2:88:f9:1f WPA: event 1 notification
wlan0: STA 18:e2:c2:88:f9:1f WPA: start authentication
wlan0: STA 18:e2:c2:88:f9:1f IEEE 802.1X: unauthorizing port
wlan0: STA 18:e2:c2:88:f9:1f WPA: sending 1/4 msg of 4-Way Handshake
wlan0: STA 18:e2:c2:88:f9:1f WPA: received EAPOL-Key frame (2/4 Pairwise)
wlan0: STA 18:e2:c2:88:f9:1f WPA: invalid MIC in msg 2/4 of 4-Way Handshake
wlan0: STA 18:e2:c2:88:f9:1f WPA: EAPOL-Key timeout
wlan0: STA 18:e2:c2:88:f9:1f WPA: sending 1/4 msg of 4-Way Handshake
wlan0: STA 18:e2:c2:88:f9:1f WPA: received EAPOL-Key frame (2/4 Pairwise)
wlan0: STA 18:e2:c2:88:f9:1f WPA: invalid MIC in msg 2/4 of 4-Way Handshake
wlan0: STA 18:e2:c2:88:f9:1f WPA: EAPOL-Key timeout
wlan0: STA 18:e2:c2:88:f9:1f WPA: sending 1/4 msg of 4-Way Handshake
wlan0: STA 18:e2:c2:88:f9:1f WPA: received EAPOL-Key frame (2/4 Pairwise)
wlan0: STA 18:e2:c2:88:f9:1f WPA: invalid MIC in msg 2/4 of 4-Way Handshake
wlan0: STA 18:e2:c2:88:f9:1f WPA: EAPOL-Key timeout
wlan0: STA 18:e2:c2:88:f9:1f WPA: sending 1/4 msg of 4-Way Handshake
wlan0: STA 18:e2:c2:88:f9:1f WPA: received EAPOL-Key frame (2/4 Pairwise)
wlan0: STA 18:e2:c2:88:f9:1f WPA: invalid MIC in msg 2/4 of 4-Way Handshake
wlan0: STA 18:e2:c2:88:f9:1f WPA: EAPOL-Key timeout
wlan0: STA 18:e2:c2:88:f9:1f WPA: PTKSTART: Retry limit 4 reached
wlan0: STA 18:e2:c2:88:f9:1f WPA: event 3 notification
WPA: wpa_sm_step() called recursively
wlan0: STA 18:e2:c2:88:f9:1f IEEE 802.1X: unauthorizing port
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-DEAUTHENTICATE.indication(18:e2:c2:88:f9:1f, 2)
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-DELETEKEYS.request(18:e2:c2:88:f9:1f)
wlan0: STA 18:e2:c2:88:f9:1f WPA: event 3 notification
wlan0: STA 18:e2:c2:88:f9:1f IEEE 802.1X: unauthorizing port
Could not set station 18:e2:c2:88:f9:1f flags for kernel driver (errno=124).
wlan0: STA 18:e2:c2:88:f9:1f IEEE 802.11: deauthenticated
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-DEAUTHENTICATE.indication(18:e2:c2:88:f9:1f, 7)
wlan0: STA 18:e2:c2:88:f9:1f MLME: MLME-DELETEKEYS.request(18:e2:c2:88:f9:1f)
wlan0: WPA rekeying GTK
wlan0: STA 64:a7:69:9b:cb:5a WPA: sending 1/2 msg of Group Key Handshake
wlan0: STA 64:a7:69:9b:cb:5a WPA: received EAPOL-Key frame (2/2 Group)
wlan0: STA 64:a7:69:9b:cb:5a WPA: group key handshake completed (RSN)

comment:16 Changed 3 years ago by Del <delonly@…>

I believe this bug was fixed about two months ago, and the fix is in trunk. Have a look at the history here:
https://dev.openwrt.org/ticket/11894

Please provide the revision you are testing with, and if it is old, then test with trunk images.

comment:17 Changed 3 years ago by nbd

  • Resolution set to no_response
  • Status changed from reopened to closed

comment:18 Changed 3 years ago by anonymous

This seems fixed for me in r35135.

comment:19 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.