Modify

Opened 4 years ago

Last modified 7 months ago

#12181 reopened defect

VLAN tagging of TP-Link WDR4300 v1.1

Reported by: timo.gerlach Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: base system Version: Attitude Adjustment 12.09 Beta
Keywords: WDR4300 AR8327N vlan tagging 802.1q Cc: zioproto@…

Description

There is a Atheros AR8327N switch chip in it. External VLAN tagging does not work (tried every possibel configuration, also with swconfig).
Tested with r33312 and also http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-factory.bin

Attachments (0)

Change History (119)

comment:1 Changed 4 years ago by email@…

I have the same Problem.
Would like to VLAN tagging the WAN Port.
It works fine with WR1043ND, but not with WDR4300.
Is fixing possible?

comment:2 follow-up: Changed 4 years ago by 4300

Should this not be resolved as it works fine for me on Attitude Adjustment 12.09-rc1 just by assigning the Vlan ID in Network>Switch and the changing the interfaces>"">physical settings.

comment:3 follow-up: Changed 4 years ago by anonymous

MODEL: TL-WDR4300
OPENWRT: 12.09-rc1 (r35093)

WAN: STATIC (192.168.32.254/255.255.255.0) & VLAN ID 100 (x.x.x.x/255.255.255.248 - white subnet).

The VLAN ID 100 must traverse to another device through the port number 5.

...
config 'switch_vlan'
	option 'device' 'eth0'
	option 'vlan' '100'
	option 'vid' '100'
	option 'ports' '0t 1t 5'

config switch_vlan
	option device 'eth0'
	option vlan '2'
	option ports '0t 1'

config switch_vlan
	option device 'eth0'
	option vlan '1'
	option ports '0t 2 3 4'

WAN (192.168.32.254/255.255.255.0) - OK!
VLAN ID 100 (x.x.x.x/255.255.255.248) - NO OK!

...
config 'switch_vlan'
	option 'device' 'eth0'
	option 'vlan' '100'
	option 'vid' '100'
	option 'ports' '0t 1t 5'

config switch_vlan
	option device 'eth0'
	option vlan '2'
	option ports '0t 1t'

config switch_vlan
	option device 'eth0'
	option vlan '1'
	option ports '0t 2 3 4'

WAN (192.168.32.254/255.255.255.0) - NO OK!
VLAN ID 100 (x.x.x.x/255.255.255.248) - OK!

:(

comment:4 follow-up: Changed 4 years ago by qasdfdsaq@…

Do

swconfig dev eth0 show

There's a bug in network init somewhere that means the port PVIDs and tagged VIDs are being assigned in the wrong order so they don't work properly on some switches.

comment:5 in reply to: ↑ 4 Changed 4 years ago by anonymous

# swconfig dev eth0 show

Global attributes:
	enable_vlan: 1
Port 0:
	mib: Port 0 MIB counters
RxBroad     : 59
RxPause     : 0
RxMulti     : 3
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 62
Rx128Byte   : 51
Rx256Byte   : 9
Rx512Byte   : 62
Rx1024Byte  : 2
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 37404
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 1
TxBroad     : 575
TxPause     : 0
TxMulti     : 259
TxUnderRun  : 0
Tx64Byte    : 202
Tx128Byte   : 644
Tx256Byte   : 151
Tx512Byte   : 72
Tx1024Byte  : 28
Tx1518Byte  : 1
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 137779
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 0
	link: port:0 link:up speed:1000baseT full-duplex txflow rxflow 
Port 1:
	mib: Port 1 MIB counters
RxBroad     : 2242
RxPause     : 0
RxMulti     : 636
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 1036
Rx128Byte   : 1353
Rx256Byte   : 376
Rx512Byte   : 77
Rx1024Byte  : 47
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 318604
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 2250
TxBroad     : 146
TxPause     : 0
TxMulti     : 75
TxUnderRun  : 0
Tx64Byte    : 1
Tx128Byte   : 95
Tx256Byte   : 40
Tx512Byte   : 84
Tx1024Byte  : 15
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 58155
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 0
	link: port:1 link:up speed:1000baseT full-duplex auto
Port 2:
	mib: Port 2 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 1
	link: port:2 link:down
Port 3:
	mib: Port 3 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 1
	link: port:3 link:down
Port 4:
	mib: Port 4 MIB counters
RxBroad     : 12
RxPause     : 0
RxMulti     : 32
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 20
Rx128Byte   : 234
Rx256Byte   : 17
Rx512Byte   : 23
Rx1024Byte  : 0
Rx1518Byte  : 1
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 31836
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 2
TxPause     : 0
TxMulti     : 2
TxUnderRun  : 0
Tx64Byte    : 51
Tx128Byte   : 51
Tx256Byte   : 9
Tx512Byte   : 6
Tx1024Byte  : 2
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 13972
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 1
	link: port:4 link:up speed:1000baseT full-duplex auto
Port 5:
	mib: Port 5 MIB counters
RxBroad     : 89
RxPause     : 0
RxMulti     : 77
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 44
Rx128Byte   : 60
Rx256Byte   : 42
Rx512Byte   : 27
Rx1024Byte  : 16
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 36127
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 50
TxPause     : 0
TxMulti     : 35
TxUnderRun  : 0
Tx64Byte    : 59
Tx128Byte   : 13
Tx256Byte   : 32
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 10065
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 100
	link: port:5 link:up speed:100baseT full-duplex auto
Port 6:
	mib: Port 6 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 0
	link: port:6 link:down
VLAN 1:
	vid: 1
	ports: 0t 2 3 4 
VLAN 2:
	vid: 2
	ports: 0t 1t 
VLAN 100:
	vid: 100
	ports: 0t 1t 5 

comment:6 Changed 3 years ago by anonymous

don't working for me neither :(

comment:7 Changed 3 years ago by dpecile@…

sorry for previous post, don't working for me neither :( on WDR4300 V1.3
unable to split traffic on switch using vlans.
any test to make to give some clear on the problem ?

thans

comment:8 in reply to: ↑ 3 Changed 3 years ago by anonymous

Replying to anonymous:

MODEL: TL-WDR4300
OPENWRT: 12.09-rc1 (r35093)

WAN: STATIC (192.168.32.254/255.255.255.0) & VLAN ID 100 (x.x.x.x/255.255.255.248 - white subnet).

The VLAN ID 100 must traverse to another device through the port number 5.


I found the solution for AR8327N. Please close this ticket.


UNTAGGED = VLAN ID 1! :-)

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0.2'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.32.254'
	option netmask '255.255.255.0'
	option gateway '192.168.32.1'

config switch
	option name 'eth0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'eth0'
	option vlan '1'
	option ports '0t 1'

config switch_vlan
	option device 'eth0'
	option vlan '2'
	option ports '0t 2 3 4'

config switch_vlan
	option device 'eth0'
	option vlan '100'
	option ports '0t 1t 5'

comment:9 Changed 3 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

comment:10 follow-up: Changed 3 years ago by chrisrenzhen@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I can confirm that VID0 is not equals to untagged.
for my own experience.my isp need untagged traffic for internet and vlan43 tagged traffic for IPTV.
the fact is that current ar8327 switch driver does not allow tagged and untagged frame on the same port.
for example config in /network
config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'

option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

config interface 'wan'

option ifname 'eth0.2'
option proto 'pppoe'
xxxxxxxxxxxx

config switch_vlan

option device 'eth0'
option vlan '1'
option ports '0t 2 3 5'

config switch

option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'eth0'
option vlan '2'
option ports '0t 1'

config switch_vlan

option device 'eth0'
option vlan '43'
option ports '1t 4'

# swconfig dev eth0 show

Global attributes:

enable_vlan: 1

Port 0:

pvid: 0
link: port:0 link:up speed:1000baseT full-duplex txflow rxflow

Port 1:

pvid: 2
link: port:2 link:down

Port 2:

pvid: 1
link: port:2 link:down

Port 3:

pvid: 1
link: port:3 link:down

Port 4:

pvid: 43
link: port:5 link:up speed:100baseT full-duplex auto

Port 5:

pvid: 1
link: port:3 link:down

Port 6:

mib: Port 6 MIB counters
pvid: 0
link: port:6 link:down

VLAN 1:

vid: 1
ports: 0t 1 2 5

VLAN 2:

vid: 2
ports: 0t 1t

VLAN 43:

vid: 43
ports: 1t 4

to make it in short,that is port 1 is not allowed to be used as untagged and tagged.if you insist config like that,the untagged port is forced to be tagged,which makes the eth0.2 is also tagged and no traffic for internet,only trafic for iptv (with real test)

also tested with vid1 for wan port by assigning port1 to vlan1 and makes eth0.1 as wan,assgning 2 3 5 for vlan2, makes eth0.2 as lan.
the same result,no internet only iptv from port 4

that is to say,vid1 is not equals to untagged,it works for jow and the people in ruasian forum is maybe because that their isp treat vid1 as untagged,but not our ar8327 switch.

i think it need special rewrite of switch driver
the problem involves all the device using ar8327(wdr4300 wdr4310 etc.),a lot of people in forum are facing this problem and we belive ar8327 is a advance switch and should support that feature.

as far as i know the switch of wzr-hp-g300nh(not v2) wdr1043nd which use rtl8366rb can achieve the feature of tagged and untagged on same port.

that's why i believe it as a driver problem

comment:11 Changed 3 years ago by anonymous

sorry for typing mistake from the first sentense

it should be "I can confirm that VID1 is not equals to untagged."

comment:12 follow-up: Changed 3 years ago by jow

  • Priority changed from normal to response-needed

Do you have any hard facts that the switch hardware supports this feature? Is it mentioned in a datasheet or confirmed working with OEM firmware? If not then this is not a regression but a feature request which might or might not be possible to implement.

comment:13 in reply to: ↑ 12 Changed 3 years ago by Chris <chrisrenzhen@…>

Replying to jow:

Do you have any hard facts that the switch hardware supports this feature? Is it mentioned in a datasheet or confirmed working with OEM firmware? If not then this is not a regression but a feature request which might or might not be possible to implement.

those are from datasheet of ar8327

The AR8327 switch supports many VLAN options including IEEE 802.1Q and port-based VLANs. The
AR8327 supports 4096 IEEE 802.1Q VLAN groups and 4K VLAN table entries, and the AR8327 device
checks VLAN port membership from the VLAN ID, extracted from the tag header of the frame. Table
2-18 shows the AR8327-supported 802.1Q modes. The port-based VLAN is enabled according to the
user-defined PORT VID value. The AR8327 supports optional discards of tagged, untagged frames,
and priority tagged frames. The AR8327 also supports untagging of the VLAN ID for packets going
out on untagged ports on a per-port basis.

comment:14 Changed 3 years ago by Chris <chrisrenzhen@…>

i am facing the same problem of the people who open this ticket.

the root of this issue is the hybrid vlan port support of switch.

comment:15 follow-up: Changed 3 years ago by jow

Did you ever try to set the PVID of port 1 to 2 while leaving it as 1t in its vlan group? That should treat untagged traffic on this port as if it is tagged with vid 2.

comment:16 in reply to: ↑ 15 Changed 3 years ago by Chris <chrisrenzhen@…>

Replying to jow:

Did you ever try to set the PVID of port 1 to 2 while leaving it as 1t in its vlan group? That should treat untagged traffic on this port as if it is tagged with vid 2.

yes,i tried.

besides,the vid is already 2 no matter if you use PVID option or not. you can see it from swconfig show.

but i also tried to force set pvid ,the same

comment:17 Changed 3 years ago by jow

The config/output you posted has neither VLAN 43 attached to the CPU nor does it show a cable connected to port 1 - did you really test the right RJ45 plugs?

comment:18 Changed 3 years ago by Chris <chrisrenzhen@…>

port 1 is connected with the only cable of isp

port 4 is conneted with cable to iptv box

my iptv service only need a bridge in router(that's why port0 is now assosiated) because iptv box will lauch pppoe client to connect to its server .the only things that need to do is outgoing traffic need to tagged with vid43 so that isp server knows it is traffic from iptv.

and i confirm iptv works fine but the internet

comment:19 Changed 3 years ago by anonymous

facing same problem here on WNDR4300, which also has AR8327 switch. By the way, i am using dd-wrt, but I believe the driver source code almost the same.

in this set ports function of ar8216.c, from line 1379, thers is a note could explain you can not make a port in one vlan untagged, while in other vlan tagged:
/* make sure that an untagged port does not

  • appear in other vlans */

1381 for (j = 0; j < AR8X16_MAX_VLANS; j++) {
1382 if (j == val->port_vlan)
1383 continue;
1384 priv->vlan_table[j] &= ~(1 << p->id);

comment:20 Changed 3 years ago by kalounet@…

Same problem here with routeur TL-WDR4300. Can't get VLAN 100 tagged on same port as wan.

Please, is it possible to get a fix for the driver ? This functionnality is supported by the switch, it just needs to be implemented by the driver :)

comment:21 follow-up: Changed 3 years ago by zzandry

Just sharing my experiences on a TL-WDR4300 (sorry for my english) :

  1. For the VLAN number limitation not the VID see my comment : http://blog.philippklaus.de/2012/12/openwrt-on-a-tp-link-tl-wdr4300-router/#comment-10334
  1. I work on the WAN port, I create my VLAN 1->1, 8->8, 9->9, 19->190, 110->110 (vlan number->vlan ID) and set all ports to untagged for vlan 1 and all rest vlan are tagged on the WAN port, I rebooted the device softly (ssh reboot or via luci). Result: port WAN unreacheable, fortunately I've left the rest port untagged for VLAN 1 so I moved cable thus I can access device. I set the WAN port to be tagged for all VLAN, that worked I can ping all address for each vlan. I revert the config, WAN port untagged for vlan 1 and tagged for all rest vlan. Reboot : not working, I decide then to power off the device, power on after a few seconds, strange it's working . I remade the test and the conclusion is to power off/on the device. I've see also this issue when I played with something else , may be the wifi I dont'remind.

Here are my final config :

config switch

option reset '1'
option enable_vlan '1'
option name 'switch0'

config switch_vlan

option vlan '1'
option device 'switch0'
option vid '1'
option ports '0t 1 2 3'

config switch_vlan

option vlan '8'
option device 'switch0'
option vid '8'
option ports '0t 1t 4t 5t'

config switch_vlan

option vlan '9'
option device 'switch0'
option vid '9'
option ports '0t 1t 5t'

config switch_vlan

option vlan '19'
option device 'switch0'
option ports '0t 1t 4 5t'
option vid '190'

config switch_vlan

option vlan '110'
option device 'switch0'
option ports '0t 1t 5t'
option vid '110'

However, swconfig dev switch0 show display :
VLAN 1:

vid: 1
ports: 0t 1t 2 3

VLAN 8:

vid: 8
ports: 0t 1t 5t

VLAN 9:

vid: 9
ports: 0t 1t 5t

VLAN 19:

vid: 190
ports: 0t 1t 4 5t

VLAN 110:

vid: 110
ports: 0t 1t 5t

But on my HP procurve , where device's WAN port is connected, it's sure vlan 1 untagged and 8-9,110,190 tagged.
Good luck

comment:22 in reply to: ↑ 21 Changed 3 years ago by anonymous

Replying to zzandry:

that is ,in short,your solution is to perform a hard reboot? and it works?

does anyone can test on this method? since i've sold my device because of endless waiting of fixing this issue

comment:23 Changed 3 years ago by zzandry

yes, hard reboot is the key for me.
Now I'm a dealing with dynamic vlan which work, but I can't see STA associated in Luci. I can't figure also how to retrieve wlan's list spawned with vlan by hostpad.

comment:24 in reply to: ↑ 10 ; follow-up: Changed 3 years ago by anonymous

Replying to chrisrenzhen@…:

I can confirm that VID1 is not equals to untagged.

The default settings.
eth0.1 = lan (VLAN ID 1), eth0.2 = wan (VLAN ID = 2)

You have to change the configuration and reboot the router.
eth0.1 = wan (VLAN ID 1 - untagged), eth0.2 = lan (VLAN ID = 2)

It's works for me.

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0.2'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option ifname 'eth0.1'
    option proto 'pppoe'
    xxxxxxxxxxxx

config switch_vlan
    option device 'eth0'
    option vlan '2'
    option ports '0t 2 3 5'

config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0t 1'

config switch_vlan
    option device 'eth0'
    option vlan '43'
    option ports '0t 1t 4t'

See screenshots and configuration files on the Russian forum.

comment:25 Changed 3 years ago by anonymous

Experiencing similar VLAN tagging issues with TP-Link WDR3600, but I have issue tagging ports 2, 3 and 4 (port 1 is WAN). Port 5 is fine.
In fact, ports stop forwarding packets for vlan 1 for ports 2, 3 and 4:

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option vid '1'
        option ports '0t 2 3 4 5'

config switch_vlan
        option device 'eth0'
        option vlan '2'
        option ports '0t 1'
        option vid '2'

config switch_vlan
        option device 'eth0'
        option vlan '3'
        option vid '3'
        option ports '0t'

config switch_vlan
        option device 'eth0'
        option vlan '6'
        option vid '6'
        option ports '0t 5t'


VLAN 1:
        vid: 1
        ports: 0t 2 3 4 5t
VLAN 2:
        vid: 2
        ports: 0t 1
VLAN 3:
        vid: 3
        ports: 0t
VLAN 6:
        vid: 6
        ports: 0t 5t

comment:26 Changed 3 years ago by anonymous

Same problem here with routeur TL-WDR4300 v1.3.
Please, is it possible to get a fix for the driver ? This functionnality is supported by the switch, it just needs to be implemented by the driver :)

comment:27 in reply to: ↑ 24 Changed 3 years ago by zioproto

You have to change the configuration and reboot the router.

do you mean a hard reboot unplugging and replugging the power adapter ? or it should be enough to reboot typing the reboot command ?

which kind of reboot works for you exactly ?

thanks

comment:28 Changed 3 years ago by zioproto

  • Cc zioproto@… added

comment:29 Changed 3 years ago by Martijn

A hard reboot works. It looks as if, without a hard reboot, the VLAN setting are not changed in the AR8327. You can use "swconfig dev eth0 show" to verify that the VLAN setting that you have set in the OpenWRT web interface is also set on the eth0 interface.

It would be good if this would be fixed so that the AR8327 does change its config, following the changes in the web interface...

comment:30 Changed 3 years ago by d@…

After any changes to the switch config you need to either initiate /etc/init.d/network restart or reboot, but that's not the subject of this ticket.

The problem is described above, a port can not be assigned to untagged VLAN and a tagged on at the same time. It works fine when you create a VLAN where the port is untagged, but once you add another VLAN where the same port is tagged - it becomes tagged in the previous one as well.

comment:31 Changed 3 years ago by Halino <enterprise.nx@…>

I am experiencing the same issue on wdr 3600, the switch doesn't accept on the same port tagged and untagged traffic.

comment:32 Changed 3 years ago by me@…

Same problem here on TL-WDR4900 MPC arch with same AR8327N switch chip.

comment:33 Changed 3 years ago by anonymous

So someone have a solution for this problem? Beacause i have same tp-link wdr4300 v1.6 and cant make Internet and IPTV i cant corectly tagg vlan's. So if someone have i solution please share.

comment:34 Changed 3 years ago by anonymous

The AR8327 switch also supports 4k VLANs, but the current driver only supports 128. Not really an issue, but nevertheless the driver should probably support the full chip capabilites.

The VLAN tagging issue also really needs to be looked at. As others have mentioned, as soon as a port is tagged in any VLAN, it becomes tagged in all other VLANs it is a member of, regardless of whether it is set to untagged. There can be no doubt that the chip itself supports this, so someone with the knowledge really should try fixing it.

comment:35 Changed 3 years ago by remigijus.kompas@…

I am experiencing the same issue on wdr3600, the switch doesn't accept on the same port tagged and untagged traffic, i used driver that support 4k VLANs, but don't work. So if someone have solution please help.

comment:36 Changed 3 years ago by Rafciq

The same problem with the router TL-WDR4300, I can't use tagged and untagged traffic on the same switch port.

comment:37 Changed 3 years ago by anonymous

Same problem with TL-WDR4300 here.
Please consider to fix it.

comment:38 Changed 3 years ago by timbaledorion

The problem appears with the new TL-WR1043ND v2.1 that uses AR3287....
Hope somebody will get some interest in it!!!

Last edited 3 years ago by timbaledorion (previous) (diff)

comment:39 Changed 3 years ago by Dalius@…

Isn't it obvious that the problem is in the switch driver, please stop spamming with new device models.
Better try to get hold of driver developer.

comment:40 Changed 3 years ago by anonymous

You are Dalius trying to find some
not that easy.....

comment:41 Changed 3 years ago by klondike

https://lafibre.info/images/doc/201106_spec_AR8327.pdf

In case it helps pages 40 and 41 of this document explain how to set the VLAN setting per port to choose between tagged and untagged egress policies, and also to choose the input policy.

Maybe the problem is that the switch is configured to accept input frames as either tagged or untagged+priority tagged instead of all options.

comment:42 Changed 3 years ago by anonymous

The good news is that the switch has this functionality (I tested)

The issue is that the driver contain u8 variable (vlan_tagged) which holds information on whether the port is tagged or not. To solve the problem, this variable should be replaced by an u8 array with will hold the information for each VLAN.

Yesterday I made a small test. I added condition to the ar8327_vtu_load_vlan function that enforces the tagged setting for port 1 in vlan1 and untagged setting for port 1 in vlan2 and it works.

In free time I will try to fix the issue but I'm not sure how this will affect on other switch supported by this driver (AR8216/AR8236/AR8316).

If I will succeed then will publish the code and ready images for trunk and 12.09

comment:43 Changed 3 years ago by timbaledorion

Would you like to share your work anyhow? I wish i could help!! I was starting to get into the driver code and the 8327 documentation in case it could be helpfull....

Tim

comment:44 Changed 3 years ago by k

Hi Tim, here is is what I've done yesterday: http://pastebin.com/8kWBKRLu

I tested few cases and so far is working. I'm planning to add one small change, make more tests and then I will prepare ready images.

Please remember that if you flash an image with broken driver you will brick your router and the only way to unbrick is flash fimware via serial cabe.

comment:45 Changed 3 years ago by candles

Apologies if I am talking about a different issue here, it appears that I might be, but thought I'd share this anyway - I was having issues with using untagged ports on the switch of my 4300 (v1.2) in that my kit was not getting anything back on any of these physical ports with VLAN enabled. Bizarrely, wifi connections were working absolutely fine and working as expected (e.g VLAN separation between two different SSIDs...)...

Anywho, it all suddenly started working when I made a small alteration to /etc/config/network;

  • Added the following option to "config switch"
    1. option enable_vlan4k '1'

I noticed someone said that the current driver for the AR8327 only supports 128 VLANs, but looks to me that it can support the 4k with the right options?

Hope this helps...

comment:46 Changed 3 years ago by anonymous

That is different 'candles', 'k' let us know when your fix is in trunk

comment:47 Changed 3 years ago by anonymous

Confirming that k's patch works here.
Hardware: RB951G-2HnD (Atheros8327).
Config:

  VLAN 1: 0t 5 (wan)
  VLAN 2: 0t 1 2 (lan, bridged)
  VLAN 6: 0t 3 4 5t (iptv)

It's used to split IPTV (tagged) and Internet (untagged). Previously only tagged or untagged worked.
Thank you very much, k! You saved me from having to buy a separate switch ;)

comment:48 Changed 3 years ago by anonymous

So this has been submitted into trunk now?

comment:49 Changed 3 years ago by Chionsas

It's not in the trunk yet.
I manually replaced the file at ./target/linux/generic/files/drivers/net/phy/ar8216.c after a make dirclean and compiled everything anew.

comment:50 Changed 3 years ago by k

I'm sorry for the late reply, I was a little bit busy.

My previous version probably will not work with older switches (AR8216/AR8236/AR8316). I tried to fix that issue in new one, but I dont have posibility to test this (I have only WDR3600 router). This is also the reason why I did not submit my changes into trunk.

If you have a device with a switch from AR8xxx family (especially AR8216/AR8236/AR8316) and you know how to unbrick your device if anything will go wrong, then I will be grateful for test my changes :)

source file: http://pastebin.com/1qcL7AFD
images for WDRxxxx (trurn r39183): https://www.dropbox.com/sh/1ccnx6djf0yda0b/uWfjsnIE0k

comment:51 Changed 3 years ago by anonymous

Thanks to k for the work he is doing.
Could someone help me to build openwrt for WR1043ND using his driver?
I would be please to come back to you with tests results......

Tim

comment:52 Changed 3 years ago by k

Hi Tim, on wiki you can find how to build openwrt : http://wiki.openwrt.org/about/toolchain

In brief:

1) Create working directory

mkdir trunk 
cd trunk

2) Download sources

git clone git://git.openwrt.org/openwrt.git
git clone git://git.openwrt.org/packages.git

4) Go to openwrt directory

cd openwrt

3) Updating feeds

./scripts/feeds update -a
./scripts/feeds install -a

5) Download my driver and replace old one

wget http://pastebin.com/raw.php?i=1qcL7AFD --output-document ar8216.c
mv ar8216.c ./target/linux/generic/files/drivers/net/phy/ar8216.c

6) Select profile for your router (in your case Taget system -> Atheros AR7xxx/AR9xxx, Target Profile -> TP-LINK TL-WR1043N/ND)

make menuconfig

7) Cleare build_dir and staging_dir

make dirclean

8) Complie image

make

9) Images you will find at

.bin/ar71xx/

I added images for your router to dropbox: https://www.dropbox.com/sh/1ccnx6djf0yda0b/uWfjsnIE0k
But please remember that I did not test my changes on your router and I'm not sure if after all you will need to unbrick your router via serial cable.

comment:53 Changed 3 years ago by timbaledorion

Once again many thanks K,

I understand i may brick my WR1043ND......(I have 4 of them)
The only way for us to know if it works is to test it. If it goes wrong i won't complain and will try to unbrick (maybe with your help).

If everything is working i will let you know so that you could propose your patch to trunk

Best Regards

Tim

comment:54 Changed 3 years ago by anonymous

I flashed my wdr4300 with the image given by K with no brick problem.
I did not test this specific problem with VLans config, but I understand it will solve it, so once again many thanks to K.
What I did not achieved to do, is to "opkg install kmod-usb-storage" because of dependencies..
So I imagine we have now to wait this fix to be in trunk ! :)

Sylvain.

comment:55 Changed 3 years ago by running910@…

wow!it's great to see this.

I want to know if my board (AP123: SOC: ar9341) 's internal switch support this feature?
I found the following from ar9341's datasheet:
"
The Ethernet switch supports many VLAN
options including IEEE 802.1Q and port-based
VLANs. The Ethernet switch supports 4096
IEEE 802.1Q VLAN groups and 4000 VLAN
table entries, and it checks VLAN port
membership from the VLAN ID extracted from
the tag header of the frame. The port-based
VLAN is enabled according to the user-defined
PORT VID value. The Ethernet switch supports
optional discards of tagged, untagged frames,
and priority tagged frames; the AR9341 also
supports untagging the VLAN ID for packets
going on untagged ports on a per-port basis.
"
does that mean ar9341's internel switch support this feture?

I would like to help 'k' test because I am used to flashing fimware via serial cabe.

btw:when will this feture be submitted into trunk?

running910

comment:56 Changed 3 years ago by anonymous

@k How about submitting this as "Request for Comments" and for inclusion to the openwrt-devel list? https://dev.openwrt.org/wiki/SubmittingPatches

comment:57 Changed 3 years ago by anonymous

Thanks to k
Evaluation done with WR1043ND v2and k's patch.
It works very well.

We intend to deploy 15 of them next week.

I aggree k should propose it to the included in openwrt-devel

comment:58 Changed 2 years ago by anonymous

I tried to build revision 36088 with the modified ar8216.c but it is incompatible (error: 'AR8316_REG_POSTRIP' undeclared etc..).

So may we hope to have the source of the modified ar8216.c compatible with R36088 (which is current http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/) ? Or am I only dreaming ? :)
Thanks k ;)

comment:59 Changed 2 years ago by shaun@…

Hi K.

I applied your patch to the latest Barrier Breaker code (svn-r9951) and built an image for my TP-Link TL-WDR4300 v1 but unfortunately the issue remains (at least for me).

Specifically, I cannot have one switch port in more than one VLAN if I want to combine both tagged and untagged modes. My goal (which I have running on my older WR1043NDs with Attitude Adjustment 12.09) is to have port 3 egress VLAN 1 traffic untagged and VLAN 2 traffic tagged.

The config (tail of /etc/config/network) looks ok:

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 3t'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0t 2 3 4 5'

But "swconfig dev switch0 show" shows that this is not what has been applied:

VLAN 1:
	vid: 1
	ports: 0t 2 3 4 5 
VLAN 2:
	vid: 2
	ports: 0t

If I try to force swconfig to add "3t" to VLAN 2 (swconfig dev switch0 vlan 2 set ports '0t 3t'), it sets port 3 in VLAN 1 to tagged as well, rather the untagged:

VLAN 1:
	vid: 1
	ports: 0t 2 3t 4 5 
VLAN 2:
	vid: 2
	ports: 0t 3t

I'm not going crazy am I? This should work shouldn't it?

Cheers.
Shaun.

comment:60 Changed 2 years ago by anonymous

Hi,

@shaun: are you sure you applied correctly the changes made by k?

On my end I have patched the current ar8216.c from trunk and vlans are working as expected on my wr1043 v2, as you can see here port 2 is untagged in the first vlan and tagged in the third:

VLAN 1:

vid: xx
ports: 0t 1 2

[...]
VLAN 3:

vid: xx
ports: 0t 2t

I have access to the services of the machine on this port without any problem.
So for me the patch is working, thank you very much k.
I hope it will be included in trunk properly soon.

If anyone is interested you can find my ar8216.c here, use it at your own risks, ... :
http://pastebin.com/WsgL87mK

comment:61 follow-up: Changed 2 years ago by anonymous

Hi,

@shaun: change the order of your vlan definitions and it should work.

There's still a small problem after k's changes: vlan definitions that include a mixed mode port untagged, must appear before those that include the same port tagged. Othervise the untagged definition will remove that port from previously defined vlans, if it was tagged there.

comment:62 in reply to: ↑ 61 Changed 2 years ago by k

Hi,

Thanks everyone for help in testing.

Replying to anonymous:

Hi,

@shaun: change the order of your vlan definitions and it should work.

There's still a small problem after k's changes: vlan definitions that include a mixed mode port untagged, must appear before those that include the same port tagged. Othervise the untagged definition will remove that port from previously defined vlans, if it was tagged there.

I fixed the bug in below version (base on rev 39430):
http://pastebin.com/6pR6c0Rn

I also send patch to Gabor Juhos. I hope he will add my changes to trunk.

comment:63 Changed 2 years ago by didlawowo

Hi,
i'm looking for configuring vlan ID to 835 on WAN port of my wdr 4300 v .6
i have tried many configuration but still not work.

could you confirm me your patch can correct this bug ?

i have touch it could be possible with interface, but i'm thinking not.

could you tell me if this commandline are correct

swconfig dev etho set vlanid 835
swconfig dev etho set apply.

thx for your repsonse.

comment:64 Changed 2 years ago by shaun@…

Hi again.

@K, Sorry about the delayed response. Stupid day job using up my time. :-) I can confirm that your latest file version works perfectly!

VLAN 1:
	vid: 1
	ports: 0t 2 3 4 5 
VLAN 2:
	vid: 2
	ports: 0t 3t

You are clearly a wizard. :-)

Thank you for your efforts.

Shaun.

comment:65 Changed 2 years ago by anonymous

Tested with this last patch; it definitively fix this bug.
I don't know how you sent this patch, but can't see it in http://patchwork.openwrt.org/project/openwrt/list/?archive=both&page=1&state=*
@K aka ar8216Wizard : did you submit it with respect of the rules of art as stated before ? cf. https://dev.openwrt.org/wiki/SubmittingPatches
If so, it may be useful to resubmit it.

Anonymous owner of wdr4300 happy now from 6 days :)

comment:66 Changed 2 years ago by d@…

Hey,

What's the latest, when do we expect patch to be in the trunk?

comment:67 follow-up: Changed 2 years ago by SH.

Hi,

I've made a full build (all packages available) with k's patch based on r39577, see https://forum.openwrt.org/viewtopic.php?id=49024 if interested.

Cheers!

comment:68 Changed 2 years ago by anonymous

Hi,

@K, I can confirm that your latest file version works too, but traffic count reported by ifconfig on tagged VLAN interface is not correct :

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 2'
        option vid '99'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option vid '100'
        option ports '0t 1t 2t'

The device plugged on port 2 does now access the untagged vlan and the tagged one, that's ok.
However, traffic reported by ifconfig on tagged one (VLAN 100) is wrong :

root@OpenWrt:~# ifconfig eth0.99; ifconfig eth0.100
eth0.99   Link encap:Ethernet  HWaddr 64:70:02:E2:A7:D2
          inet addr:192.168.100.1  Bcast:192.168.100.255  Mask:255.255.255.0
          inet6 addr: fe80::6670:2ff:fee2:a7d2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:133 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:40166 (39.2 KiB)  TX bytes:630 (630.0 B)

eth0.100  Link encap:Ethernet  HWaddr 64:70:02:E2:A7:D2
          inet6 addr: fe80::6670:2ff:fee2:a7d2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2312 (2.2 KiB)  TX bytes:110 (110.0 B)

Swconfig count seems to be ok :

Port 1:
        mib: Port 1 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 33
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 2432
Rx128Byte   : 10752
Rx256Byte   : 13964
Rx512Byte   : 3119
Rx1024Byte  : 360
Rx1518Byte  : 528135
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 738792756
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 104
TxBroad     : 8
TxPause     : 0
TxMulti     : 71
TxUnderRun  : 0
Tx64Byte    : 3708
Tx128Byte   : 2984
Tx256Byte   : 15882
Tx512Byte   : 2648
Tx1024Byte  : 268
Tx1518Byte  : 484
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 4659195
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

        pvid: 2
        link: port:1 link:up speed:1000baseT full-duplex auto
Port 2:
        mib: Port 2 MIB counters
RxBroad     : 132
RxPause     : 0
RxMulti     : 49
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 260
Rx256Byte   : 15498
Rx512Byte   : 2586
Rx1024Byte  : 6
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 3186796
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 1
TxPause     : 0
TxMulti     : 15
TxUnderRun  : 0
Tx64Byte    : 155
Tx128Byte   : 8250
Tx256Byte   : 13177
Tx512Byte   : 2887
Tx1024Byte  : 4
Tx1518Byte  : 517643
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 723138805
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

        pvid: 3
        link: port:2 link:up speed:1000baseT full-duplex auto

So traffic of these roughly 700MB coming from the vlan100 are not shown via ifconfig, nor shown by statistics.

Is this due to the modified ar8216.c file, or something else ?

Thanks.

comment:69 follow-up: Changed 2 years ago by fkpwolf@…

I found an issue when attach 2 vlan on a port:

config switch_vlan
        option device 'switch0'
        option vlan '85'
        option vid '85'
        option ports '4 1t'

config switch_vlan
        option device 'switch0'
        option vlan '51'
        option vid '51'
        option ports '4 1t'

I got:

VLAN 51:
        vid: 51
        ports: "1t 4"
VLAN 85:
        vid: 85
        ports: "1t"

Looks vlan 51 override vlan 85. I have to delete vlan 51 to make 85 work.

is this another defect?

comment:70 Changed 2 years ago by fkpwolf@…

If I change to :

config switch_vlan
        option device 'switch0'
        option vlan '51'
        option vid '51'
        option ports '4t 1t'

config switch_vlan
        option device 'switch0'
        option vlan '85'
        option vid '85'
        option ports '4 1t'

I got:

VLAN 51:
        vid: 51
        ports: 1t 4t
VLAN 85:
        vid: 85
        ports: 1t 4

So the code only handle tag/untag case?

comment:71 in reply to: ↑ 69 Changed 2 years ago by anonymous

Replying to fkpwolf@…:

I found an issue when attach 2 vlan on a port:

config switch_vlan
        option device 'switch0'
        option vlan '85'
        option vid '85'
        option ports '4 1t'

config switch_vlan
        option device 'switch0'
        option vlan '51'
        option vid '51'
        option ports '4 1t'

I got:

VLAN 51:
        vid: 51
        ports: "1t 4"
VLAN 85:
        vid: 85
        ports: "1t"

Looks vlan 51 override vlan 85. I have to delete vlan 51 to make 85 work.

is this another defect?

You cannot have same port untagged in more than one vlan. How would the switch know, which vlan incoming untagged traffic belongs to?
You can, however, have the same port as untagged in one vlan and tagged in several other vlans at the same time now. Which is what this fix made possible.

comment:72 Changed 2 years ago by fkpwolf@…

So I should add PVID to define a default port at this case?

config switch_vlan
        option device 'switch0'
        option vlan '85'
        option vid '85'
        option ports '4 1t'

config switch_vlan
        option device 'switch0'
        option vlan '51'
        option vid '51'
        option ports '4 1t'

config switch_port
       option port '4'
       option pvid '85'

But I got same result. Port 4 was removed from vlan 85.

I try to remove all this part in ar8327_sw_set_ports method:

			/* make sure that an untagged port does not
			* appear in other vlans */
			for (j = 0; j < AR8X16_MAX_VLANS; j++) {
				if (j == val->port_vlan)
					continue;
				
				// skip tagged
				if(vlan_tagged[j] & BIT(p->id))
					continue;
				
				// remove port
                                // TODO remove ONLY when port is not a PVID
				//priv->vlan_table[j] &= ~(BIT(p->id));
			}

Then everything works well.

There are 2 VLAN tags my carrier use for iptv: 85 and 51. VLAN51 is a multicast stream, and only for downlink.

comment:73 follow-up: Changed 2 years ago by d@…

What's the status of trunk merge? I have WDR4900 which uses the same switch. I'm keen to give it a try.

comment:74 in reply to: ↑ 73 ; follow-up: Changed 2 years ago by anonymous

Replying to d@…:

What's the status of trunk merge? I have WDR4900 which uses the same switch. I'm keen to give it a try.

I have made a complete build (excluding a few packages.) for the WDR4900.
Feel free to download it at: http://files.s-eckardt.com/openwrt/

I don't know how long I will be hosting this. So I suggest to download everything you might need and make your own mirror.

comment:75 in reply to: ↑ 74 Changed 2 years ago by d@…

Replying to anonymous:

Replying to d@…:

What's the status of trunk merge? I have WDR4900 which uses the same switch. I'm keen to give it a try.

I have made a complete build (excluding a few packages.) for the WDR4900.
Feel free to download it at: http://files.s-eckardt.com/openwrt/

I don't know how long I will be hosting this. So I suggest to download everything you might need and make your own mirror.

Thanks! Downloaded.

comment:76 Changed 2 years ago by petr.dziacky@…

Hi,i am trying to compile owrt image for wdr4300 but i still getting an compiler error. It says:

drivers/net/phy/ar8216.c: In function 'ar8327_hw_config_pdata':
drivers/net/phy/ar8216.c:1128:8: error: 'AR8337_PAD_MAC06_EXCHANGE_EN' undeclared (first use in this function)

I just replace a ar8216.c file. I searched the file and the truth is that theres no definition of that constant. Does anyone have same problem? Whats definition of that constant? Thanks for help.

comment:77 Changed 2 years ago by anonymous

The last version of the patched ar8216.c, linked in comment #62, is against rev 39430.
The last change in ar8216.c in trunk was rev 39338.
As long as the file in trunk does not change, manually replacing the file with the patched one should just work.

As soon as the file in trunk changes again, someone needs to merge the changes and provide a new patched file. A better way would be to make some noise around this, idk, maybe in the forums, so it gets some attention and is hopefully added in trunk proper :)

comment:78 follow-up: Changed 2 years ago by zioproto@…

I cleaned up the patch and requested inclusion in trunk in the openwrt devel mailing list.

Find my git tree here:
https://github.com/zioproto/openwrt-trunk-zioproto/commit/e7226ba45d7198dff71fde3caa1be9962f9f4ef1

comment:79 in reply to: ↑ 78 Changed 2 years ago by anonymous

Replying to zioproto@…:

I cleaned up the patch and requested inclusion in trunk in the openwrt devel mailing list.

Find my git tree here:
https://github.com/zioproto/openwrt-trunk-zioproto/commit/e7226ba45d7198dff71fde3caa1be9962f9f4ef1

comment:80 Changed 2 years ago by alexalouit

I have the same problem here.
Hope the request will be accepted.

comment:81 Changed 2 years ago by Saverio

merged into trunk in r40777

comment:82 Changed 2 years ago by amluto

...and reverted in r40842. There went my home network :(

comment:83 Changed 2 years ago by anonymous

Hello do you know the reason why it has been reverted in 40842.
May I use the driver of r40777 and build a version for my WR1043 ND v2?

Thanks for your answers all.

Tim

comment:84 follow-up: Changed 2 years ago by nbd

It was reverted because it was causing regressions on other devices in normal configurations.
The patch as it stands is just too big and intrusive relative to the changed parts that matter. It should be split up and simplified to avoid regressions.

comment:85 in reply to: ↑ 84 Changed 2 years ago by oecke

Replying to nbd:

(..) It should be split up and simplified to avoid regressions.

Is someone working on it?

comment:86 Changed 2 years ago by redlizard

Test report: the patch from r40777 works correctly on my WR1043ND v2.

comment:87 follow-up: Changed 2 years ago by anonymous

redlizard: can you describe your test case? This is still not working for me on WR1043ND v2. I am simply trying to add additional tagged VLANs to the switchports, with VLAN 1 being the native (untagged) vlan.

# swconfig dev switch0 show
...
VLAN 1:
	vid: 1
	ports: 0 1 2 3 4 
VLAN 2:
	vid: 2
	ports: 5 6 
# swconfig dev switch0 vlan 3 set ports "0t 1t 2t 3t 4t"
# swconfig dev switch0 show
...
VLAN 1:
	vid: 1
	ports: 0t 1t 2t 3t 4t  <- should not affect VLAN 1 settings
VLAN 2:
	vid: 2
	ports: 5 6 
VLAN 3:
	vid: 3
	ports: 0t 1t 2t 3t 4t 

comment:88 in reply to: ↑ 87 Changed 2 years ago by redlizard

Replying to anonymous:

redlizard: can you describe your test case? This is still not working for me on WR1043ND v2. I am simply trying to add additional tagged VLANs to the switchports, with VLAN 1 being the native (untagged) vlan.

That is exactly the setup I'm using (I also have a few switch_port pvid clauses, but those should be unrelated).

What build are you using?

comment:89 follow-up: Changed 2 years ago by anonymous

What build are you using?

I misread your original post, I thought you were saying it was working for you in a newer revision in which the patch had been reverted. I'm running r41181. In your configuration is port 0 tagged in VLAN 1 or untagged? Are you able to create VLAN interfaces for your tagged VLANs and ping the respective router addresses?

comment:90 in reply to: ↑ 89 Changed 2 years ago by redlizard

Replying to anonymous:

What build are you using?

In your configuration is port 0 tagged in VLAN 1 or untagged?

Untagged.

Are you able to create VLAN interfaces for your tagged VLANs and ping the respective router addresses?

Yup.

comment:91 follow-up: Changed 2 years ago by Heidistein

Is this bug/feature also the reason my router cannot setup a PPPoE connection on vlan6?
Using the same (ports changed) config on wrt1043nd, working and N900 the 'timeout waiting for PADO packets'.
I am not sure, becouse the build by 's-eckardt.com' is not working either, for me...

The config (truncated)

config interface 'wan'
        option ifname 'eth0.6'
        option proto 'pppoe'

config switch
        option name 'switch0'
        option enable_vlan4k '1'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option ports '0t 1t 5'
        option vid '4'

config switch_vlan
        option device 'switch0'
        option vlan '6'
        option vid '6'
        option ports '0t 1t'
Last edited 2 years ago by Heidistein (previous) (diff)

comment:92 Changed 2 years ago by Valentijn Sessink

Just a small notice: I tried to backport the code from trunk to 12.09 but so far, that didn't work: my switch becomes unavailable (swconfig doesn't see it anymore). I'll see if I can make a patch from it, so others could look what's wrong.

comment:93 in reply to: ↑ 91 Changed 2 years ago by anonymous

Replying to Heidistein:

Is this bug/feature also the reason my router cannot setup a PPPoE connection on vlan6?
Using the same (ports changed) config on wrt1043nd, working and N900 the 'timeout waiting for PADO packets'.
I am not sure, becouse the build by 's-eckardt.com' is not working either, for me...

Hello,
I am the one, who made the build on s-eckardt.com Can you describe, what's not working? You are using a WDR4900 and trying to connect to a WAN? That's exactly what I am doing too. Here is my config: (check port 4 for tagged and untagged VLAN on same port)

config interface 'wan'

option ifname 'eth0.2'
option _orig_ifname 'eth0.2'
option _orig_bridge 'false'
option proto 'pppoe'
option username 'user'
option password 'pass'

config switch

option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'switch0'
option vlan '2'
option ports '0t 1'
option vid '2'

config switch_vlan

option device 'switch0'
option vlan '3'
option vid '41'
option ports '0t 2t 4'

config interface 'vlan41'

option proto 'static'
option ifname 'eth0.41'
option netmask 'mask'
option broadcast 'stuff'
option ipaddr 'ip'
option gateway 'gate'
option dns 'dns'

config switch_vlan

option device 'switch0'
option vlan '7'
option vid '21'
option ports '0t 2t 4t 5'

and so on... I am running a lot more VLANs on this device.
Hope you get your setup running.

comment:94 Changed 2 years ago by anonymous

Thanks for your response, my setup is very similar, except:

option _orig_ifname 'eth0.2'
option _orig_bridge 'false'

I will add those when I have spare time.

comment:95 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:96 Changed 2 years ago by d@…

What's the latest on submitting a polished fix into the trunk so we can forget about this ticket once and for all?

comment:97 Changed 2 years ago by anonymous

There have been at least two (2) submissions in the last month, the latest being:
http://patchwork.openwrt.org/patch/5941/

PS: I've been running my system with the previous version of the patch for the past 3+ months.

comment:98 Changed 2 years ago by anonymous

Still doesn't work for TL-WDR3600 v1.1

My network config:

config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

option ula_prefix 'fdba:d537:0bdd::/48'

config interface 'lan'

option ifname 'eth0.2'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.1.1'
option broadcast '192.168.1.255'
option stp '1'

config interface 'wan'

option ifname 'eth0.1'
option _orig_ifname 'eth0.1'
option _orig_bridge 'false'
option proto 'static'
option ipaddr '10.120.29.250'
option netmask '255.255.255.248'
option gateway '10.120.29.249'
option dns '91.103.73.7 91.103.76.2'

config interface 'wan6'

option ifname '@wan'
option proto 'dhcpv6'

config switch

option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 1'

config switch_vlan

option device 'switch0'
option vlan '2'
option vid '2'
option ports '0t 2 3 4'

config switch_vlan

option device 'switch0'
option vlan '3'
option vid '222'
option ports '0t 1t 5'

comment:99 Changed 2 years ago by mattwire

Add cc

comment:100 Changed 23 months ago by jpirko

I confirm that this still does not work with TL-WR1043ND v2 with Atheros AR8327 rev. 4

comment:101 Changed 23 months ago by jpirko

I just tested patch:
http://patchwork.openwrt.org/patch/5941/

I confirm that with that, vlans work as expected on TL-WR1043ND v2:
VLAN 1:

vid: 1
ports: 0t 1 2 3 4

VLAN 2:

vid: 2
ports: 5 6

VLAN 100:

vid: 100
ports: 0t 1t 2t 3 4

Please include this patch into BB. Thanks!

comment:102 Changed 23 months ago by wangyu

Hi,
I backport patch5941(http://patchwork.openwrt.org/patch/5941/) to AA 12.09,patch is here:
https://github.com/wangyu-/openwrt-patch/blob/master/ar8327-vlanfix-backport.patch
I also build a image for wdr4310v1 with luci:
https://github.com/wangyu-/openwrt-patch/blob/master/openwrt-ar71xx-generic-tl-wdr4310-v1-squashfs-sysupgrade.bin
(If you dont know how to unbrick,be carefull!)
the patch works for me in AA 12.09 on my wdr4310v1
This is my case:
config switch

option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'eth0'
option vlan '1'
option ports '0t 2 3 4 5'
option vid '1'

config switch_vlan

option device 'eth0'
option vlan '2'
option ports '0t 1'
option vid '2'

config switch_vlan

option device 'eth0'
option vlan '10'
option ports '0t 1t'
option vid '10'

WAN work as eth0.2 untagged and eth0.10 tagged.
I'll test more case later.

Last edited 23 months ago by wangyu (previous) (diff)

comment:103 in reply to: ↑ 67 Changed 22 months ago by anonymous

Replying to SH.:

Hi,

I've made a full build (all packages available) with k's patch based on r39577, see https://forum.openwrt.org/viewtopic.php?id=49024 if interested.

Cheers!

I tested this build on my 3600 and it works great. Thanks Again, Sylvain and K!

Jeremy

comment:104 in reply to: ↑ description Changed 22 months ago by hmataji@…

Replying to timo.gerlach:

There is a Atheros AR8327N switch chip in it. External VLAN tagging does not work (tried every possibel configuration, also with swconfig).
Tested with r33312 and also http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-factory.bin

Running bleeding edge on an rb2011, led status works fine but no links status displayed, or traffic flowing through the gigabit (AR8327) or the SFP ports. Any hints on how I can troubleshoot this, swconfig shows the switch and related ports, trying to disable all vlans in the network configuration to no avail.

Thanks!

comment:105 Changed 22 months ago by jeremy

Was the patch included in Barrier Breaker Final Release?

comment:106 follow-up: Changed 22 months ago by anonymous

On my TL-WDR3600.
Firmware Version OpenWrt Chaos Calmer r42757
The VLAN works.

The solution was merged in: r42652, r42653 (2014-09-23)
https://dev.openwrt.org/changeset/42653

I could not find if this solution is also merged in Barrier Breaker Final. But i can confirm that the trunk version works fine.

Maybe this helps.

comment:107 in reply to: ↑ 106 Changed 21 months ago by anonymous

Replying to anonymous:

On my TL-WDR3600.
Firmware Version OpenWrt Chaos Calmer r42757
The VLAN works.

The solution was merged in: r42652, r42653 (2014-09-23)
https://dev.openwrt.org/changeset/42653

I could not find if this solution is also merged in Barrier Breaker Final. But i can confirm that the trunk version works fine.

Maybe this helps.

It appears it's not since Barrier Breaker is based on revision 42625.

The current stable version Barrier Breaker 14.07 was released on October 2nd, 2014. It is based on r42625.

comment:108 Changed 21 months ago by anonymous

No, the fix still not included in BB 14.07.

I took sources of BB 14.07-rc3 from svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42682, replaced file target/linux/generic/files/drivers/net/phy/ar8216.c with the fixed one from trunk svn://svn.openwrt.org/openwrt/trunk@42653 and built the binary with default settings for wdr3600. Use this custom built binary for more than month now on WDR3600 v1.5, tagged/untagged packets support on the same port works properly. Note that later the driver file ar8216.c has been fixed again on trunk, I did not test this fix.

Did not build any packages, successfully use prebuilt ones for BB. Building the binary consumed 8GB of disk space.

comment:109 Changed 20 months ago by jmylchreest

Could anyone please tell me if there are any plans to backport this to bb final?

Last edited 20 months ago by jmylchreest (previous) (diff)

comment:110 Changed 20 months ago by hudys

Anyone tested this patch on WR1043ND v2? I have problem with utagged and tagged vlan on the same port (wan). Can You look at my config?

VLAN 10 - internet connection untagged (wan tag, 1-2 nat)
VLAN 13 - mng (tag wan, to cpu)
VLAN 14 - TV (wan tag, 3-4 untag)

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd85:2c86:fcc1::/48'

config interface 'lan'
	option ifname 'eth1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.5.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option dns '192.168.5.1'
	option delegate '0'

config interface 'wan'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option proto 'dhcp'
	option ifname 'eth0.10'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'
	option enable_vlan4k '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '5 6'
	option vid '10'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '14'
	option ports '1 2 5t'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '13'
	option ports '5t 6t'

config interface 'mng'
	option proto 'dhcp'
	option ifname 'eth0.13'
	option delegate '0'
	option defaultroute '0'

Global attributes:
	enable_vlan: 1
	enable_mirror_rx: 0
	enable_mirror_tx: 0
	mirror_monitor_port: 0
	mirror_source_port: 0
Port 0:
	mib: Port 0 MIB counters
RxBroad     : 509
RxPause     : 0
RxMulti     : 271
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 485
Rx128Byte   : 167
Rx256Byte   : 67
Rx512Byte   : 34
Rx1024Byte  : 26
Rx1518Byte  : 1
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 89704
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 779
TxBroad     : 1
TxPause     : 0
TxMulti     : 66
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 11
Tx256Byte   : 5
Tx512Byte   : 51
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 17301
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 1
	link: port:0 link:up speed:1000baseT full-duplex txflow rxflow 
Port 1:
	mib: Port 1 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 4
	link: port:1 link:down
Port 2:
	mib: Port 2 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 4
	link: port:2 link:down
Port 3:
	mib: Port 3 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 1
	link: port:3 link:down
Port 4:
	mib: Port 4 MIB counters
RxBroad     : 0
RxPause     : 0
RxMulti     : 0
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 0
Rx256Byte   : 0
Rx512Byte   : 0
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 0
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 0
TxBroad     : 0
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 0
Tx256Byte   : 0
Tx512Byte   : 0
Tx1024Byte  : 0
Tx1518Byte  : 0
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 0
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 1
	link: port:4 link:down
Port 5:
	mib: Port 5 MIB counters
RxBroad     : 594
RxPause     : 0
RxMulti     : 644
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 0
Rx128Byte   : 275
Rx256Byte   : 269
Rx512Byte   : 2635
Rx1024Byte  : 189
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 1071928
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 874
TxBroad     : 2541
TxPause     : 0
TxMulti     : 20
TxUnderRun  : 0
Tx64Byte    : 390
Tx128Byte   : 14
Tx256Byte   : 6
Tx512Byte   : 2150
Tx1024Byte  : 0
Tx1518Byte  : 1
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 772091
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 3
	link: port:5 link:up speed:100baseT full-duplex auto
Port 6:
	mib: Port 6 MIB counters
RxBroad     : 2542
RxPause     : 0
RxMulti     : 20
RxFcsErr    : 0
RxAlignErr  : 0
RxRunt      : 0
RxFragment  : 0
Rx64Byte    : 391
Rx128Byte   : 14
Rx256Byte   : 6
Rx512Byte   : 2151
Rx1024Byte  : 0
Rx1518Byte  : 0
RxMaxByte   : 0
RxTooLong   : 0
RxGoodByte  : 780082
RxBadByte   : 0
RxOverFlow  : 0
Filtered    : 2
TxBroad     : 298
TxPause     : 0
TxMulti     : 0
TxUnderRun  : 0
Tx64Byte    : 0
Tx128Byte   : 2
Tx256Byte   : 0
Tx512Byte   : 2242
Tx1024Byte  : 183
Tx1518Byte  : 1
TxMaxByte   : 0
TxOverSize  : 0
TxByte      : 885597
TxCollision : 0
TxAbortCol  : 0
TxMultiCol  : 0
TxSingleCol : 0
TxExcDefer  : 0
TxDefer     : 0
TxLateCol   : 0

	pvid: 3
	link: port:6 link:up speed:1000baseT full-duplex txflow rxflow 
VLAN 1:
	vid: 1
	ports: 0 3 4 
VLAN 3:
	vid: 10
	ports: 5 6 
VLAN 4:
	vid: 14
	ports: 1 2 5t 
VLAN 5:
	vid: 13
	ports: 5t 6t 

comment:111 Changed 19 months ago by Holger Thiel

On WDR4900 with r42625 it seems possible to have multiple VLANs on one port without an untagged VLAN.
The wired network gets stuck with an untagged VLAN and concurrent tagged VLANs on one port.

But most of it works fine.

comment:112 Changed 19 months ago by lexa2

Sorry for buzz but it seems that there's no easy option to add yourself to bug's CC list except for commenting on the bug. I've got several WDR4300 v1.1 working in production and I have a requirement to be able to use both tagged and untagged traffic on the same port. It works fine with latest trunk but I'd like to use latest stable release instead. I leave a comment here so I'd be (hopefully) notified if/when the patch would be backported into BB.

comment:113 Changed 19 months ago by bugs@…

@lexa2, +1 (replying here to be included on CC list).

comment:114 Changed 18 months ago by anonymous

ZyXEL NBG6716 has this bug too ?
Switch - QCA8337

http://wiki.openwrt.org/toh/zyxel/zyxel_nbg6716

comment:115 Changed 12 months ago by anonymous

Was this bug closed in Chaos Calmer, or does it still require patching?

comment:116 Changed 11 months ago by anonymous

Fixed in CC

comment:117 in reply to: ↑ 2 Changed 8 months ago by subhashkanpur222@…

Replying to 4300:

Should this not be resolved as it works fine for me on Attitude Adjustment 12.09-rc1 just by assigning the Vlan ID in Network>Switch and the changing the interfaces>"">physical settings.

Hi,
Could you please let me know what exact changes you did to make Dynamic VLAN work on Attitude Adjustment.
Which configuration files need to be modified.

comment:118 follow-up: Changed 7 months ago by darkmark

Hi

I'm seeing what appears to be almost the same problem on the Atheros AR934X switch chip with Chaos Calmer, r47466. Which I think is all part of the same driver set?

Ports which have a mixed tagged / untagged vlans all show as tagged on swconfig show.

So the config has port 5 with tagged and untagged traffic;

config switch_vlan

option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 1 2 5'

config switch_vlan

option device 'switch0'
option vlan '2'
option vid '2'
option ports '0t 5t'

but 'swconfig dev switch0 show' lists port 5 as '5t' on both.

VLAN 1:

vid: 1
ports: 0t 1 2 5t

VLAN 2:

vid: 2
ports: 0t 5t

Same bug?

Mark

Last edited 7 months ago by darkmark (previous) (diff)

comment:119 in reply to: ↑ 118 Changed 7 months ago by anonymous

Replying to darkmark:

Hi

I'm seeing what appears to be almost the same problem on the Atheros AR934X switch chip with Chaos Calmer, r47466. Which I think is all part of the same driver set?

Ports which have a mixed tagged / untagged vlans all show as tagged on swconfig show.

So the config has port 5 with tagged and untagged traffic;

config switch_vlan

option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 1 2 5'

config switch_vlan

option device 'switch0'
option vlan '2'
option vid '2'
option ports '0t 5t'

but 'swconfig dev switch0 show' lists port 5 as '5t' on both.

VLAN 1:

vid: 1
ports: 0t 1 2 5t

VLAN 2:

vid: 2
ports: 0t 5t

Same bug?

Mark

I have the same problem. It seems that the AR934X switch has much in common with the AR7240 which does not seem to support mixed tagged and untagged on the same port. However I have not found any information on AR934X. I built a firmware with this for loop removed but couldn't tell any difference.

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.