Modify

Opened 9 years ago

Closed 8 years ago

Last modified 21 months ago

#1269 closed defect (invalid)

vlan name type problems

Reported by: phr3ak Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: Cc:

Description (last modified by nbd)

route add 192.168.0.254 eth0.1
route: SIOC[ADD|DEL]RT: No such device

i think the /etc/sysctl.conf is unusable too with this vlan format.

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by MMCM <mmcm@…>

shouldn't that read:

route add -host 192.168.0.254 dev eth0.1

Quote from "man route"

route  [-v]  [-A  family]  add  [-net|-host]  target  [netmask  Nm]  [gw Gw] [metric N] [mss M] [window W] [irtt I]
              [reject] [mod] [dyn] [reinstate] [[dev] If]

comment:2 Changed 9 years ago by nbd

  • Description modified (diff)
  • Resolution set to worksforme
  • Status changed from new to closed

comment:3 Changed 8 years ago by phr3ak

  • Resolution worksforme deleted
  • Status changed from closed to reopened

root@WL500gP:~# ifconfig eth0.1
eth0.1 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx

UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:11727 errors:0 dropped:0 overruns:0 frame:0
TX packets:8264 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:13564913 (12.9 MiB) TX bytes:1864567 (1.7 MiB)

root@WL500gP:~# route add -host 192.168.0.254 dev eth0.1
route: SIOCADDRT: No such device

comment:4 follow-up: Changed 8 years ago by nbd

I can't reproduce that. Did you try trunk?

comment:5 in reply to: ↑ 4 Changed 8 years ago by phr3ak

root@WL500gP:~# route add -host 192.168.1.1 dev eth0.1
route: SIOCADDRT: No such device
root@WL500gP:~# ifconfig eth0.1 0.0.0.0
root@WL500gP:~# route add -host 192.168.1.1 dev eth0.1
root@WL500gP:~#

comment:6 Changed 8 years ago by florian

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:7 Changed 21 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.