Modify

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#14092 closed defect (fixed)

Unusable wifi connection with the tx queueing rework patches

Reported by: ferob Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Attitude Adjustment 12.09
Keywords: ath9k tx queueing rework patch wifi Cc:

Description

Since these tx queueing rework patches appeared (#37483 and #37533), the wifi connection is unusable on my android phone (HTC One X / Tegra 3), because a few seconds after the device connected to the network, it cannot reach the local network or the web and it simply times out or takes a very long time to load.

Attitude Adjustment and Trunk both has this issue even after the updated patches (#37616, #37713 and #37729).

Attachments (0)

Change History (38)

comment:1 Changed 4 years ago by nbd

are there any messages in the log when that happens?

comment:2 Changed 4 years ago by ferob

There is nothing in the log and if I'm trying to reconnect, then it's working for a few seconds (e.g. a web page can load if I'm quick), but mostly the above mentioned thing happens.

comment:3 Changed 4 years ago by nbd

Do you have a second ath9k based device that you could use in monitor mode to capture the exchange between the AP and the Client?

comment:4 Changed 4 years ago by denk

I can confirm that problem as I see the exact same symptoms using my Nokia N9.
But I don't own a second ath9k based device so I can't use monitor mode to get the needed info, sorry. If I can do anything else, please ask.

comment:5 Changed 4 years ago by ferob

Sorry, but I don't have a second ath9k based device.

comment:6 Changed 4 years ago by nbd

Here are 3 patches that revert parts of the tx queueing rework:
http://nbd.name/900-revert-mcast-sw-queueing.patch
http://nbd.name/901-revert-improve-tx-sched-fairness.patch
http://nbd.name/902-revert-use-sw-queues-for-unaggr.patch
Please try copying them to package/kernel/mac80211/patches one by one starting with the first, running a new test after each one. Let me know if one of those three makes it work for you again.
Thanks!

comment:7 Changed 4 years ago by hnyman <hannu.nyman@…>

@nbd:
ferob and a few others are using my wndr3700 builds and have asked me to create test builds for them. As complete testing of these patches requires three different versions, it sounds burdensome to flash the router three times.

Is there a possibility to test the patches by replacing just the compiled driver file in the live router?
Would it be /lib/modules/3.10.9/ath9k.ko ?
Or something else?

comment:8 Changed 4 years ago by nbd

Yes, for those patches it should be enough to replace ath9k.ko

comment:9 Changed 4 years ago by denk

Thanks to hnyman who kindly provided the test builds I can say the following:

  • 900 doesn't work
  • 900 + 901 doesn't work
  • 900 + 901 + 902 works

comment:10 Changed 4 years ago by nbd

what about the other test i suggested in that other ticket: does disabling n without any revert patches make it work as well?

comment:11 Changed 4 years ago by nbd

please try current trunk

comment:12 Changed 4 years ago by ferob

The problem is still there.

comment:13 Changed 4 years ago by nbd

Please test r38017

comment:14 Changed 4 years ago by ferob

Still not working.

comment:15 Changed 4 years ago by nbd

again, what about that other test that i suggested (disabling n)?

comment:16 Changed 4 years ago by ferob

There is no problem when diabling n.

comment:17 Changed 4 years ago by nbd

please try trunk r38249 or later

comment:18 Changed 4 years ago by ferob

Still the same.

comment:19 Changed 4 years ago by nbd

please show me your wireless config

comment:20 Changed 4 years ago by ferob

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'pci0000:00/0000:00:11.0'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option channel '11'
        option txpower '26'
        option htmode 'HT40-'
        option country 'US'
        option distance '10'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid '*****'
        option hidden '1'
        option encryption 'psk2'
        option key '**********'
        option wps_pushbutton '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11na'
        option path 'pci0000:00/0000:00:12.0'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option channel '48'
        option txpower '17'
        option htmode 'HT40-'
        option country 'US'
        option distance '10'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid '*****'
        option hidden '1'
        option encryption 'psk2'
        option key '**********'
        option wps_pushbutton '0'

comment:21 Changed 4 years ago by nbd

ferob, please test if current 12.09 svn/git (which has some parts of the tx queueing rework removed) has the same issue.

comment:22 Changed 4 years ago by ferob

It is working with the latest AA.

comment:23 Changed 4 years ago by nbd

please try latest trunk again, more fixes were added.

comment:24 Changed 4 years ago by ferob

Still not working.

comment:25 Changed 4 years ago by VlaoMao

The same with Nokia N950 and Netgear WNR612-V2, other devices (android phone, tablet and PC) is fully working.

comment:26 Changed 4 years ago by nbd

please try latest trunk.

comment:27 Changed 4 years ago by VlaoMao

OpenWrt Barrier Breaker r39048 / LuCI Trunk (svn-r9932)
$ ping 192.168.1.97
PING 192.168.1.97 (192.168.1.97) 56(84) bytes of data.
64 bytes from 192.168.1.97: icmp_seq=1 ttl=64 time=1385 ms
64 bytes from 192.168.1.97: icmp_seq=2 ttl=64 time=785 ms
64 bytes from 192.168.1.97: icmp_seq=4 ttl=64 time=1026 ms
64 bytes from 192.168.1.97: icmp_seq=5 ttl=64 time=1058 ms
64 bytes from 192.168.1.97: icmp_seq=6 ttl=64 time=1077 ms
64 bytes from 192.168.1.97: icmp_seq=7 ttl=64 time=895 ms
64 bytes from 192.168.1.97: icmp_seq=8 ttl=64 time=301 ms
64 bytes from 192.168.1.97: icmp_seq=9 ttl=64 time=124 ms
64 bytes from 192.168.1.97: icmp_seq=10 ttl=64 time=148 ms
^C
--- 192.168.1.97 ping statistics ---
10 packets transmitted, 9 received, 10% packet loss, time 9018ms
rtt min/avg/max/mdev = 124.248/755.880/1385.585/429.392 ms, pipe 2

comment:28 Changed 4 years ago by nbd

Please explain the ping results you just posted, without context they are meaningless to me.

comment:29 Changed 4 years ago by VlaoMao

  1. Connect n950 wifi to router.
  2. Open terminal on n950.
  3. ifconfig wlan0 output on n950:
RM680-21-3_PR_RM680:~# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 90:CF:15:1B:C9:CF  
          inet addr:192.168.1.97  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::92cf:15ff:fe1b:c9cf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31472 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28292 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:32139465 (30.6 MiB)  TX bytes:4938985 (4.7 MiB)
  1. iwconfig wlan0 output on n950:
RM680-21-3_PR_RM680:~# iwconfig wlan0
wlan0     IEEE 802.11abgn  ESSID:"vlaoNet"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:21:B7:BB:31:D8   
          Bit Rate=18 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=65/70  Signal level=-45 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
  1. Pinging n950 from router shell
root@OpenWrt:~# ping 192.168.1.97
PING 192.168.1.97 (192.168.1.97): 56 data bytes
64 bytes from 192.168.1.97: seq=0 ttl=64 time=1234.886 ms
64 bytes from 192.168.1.97: seq=1 ttl=64 time=346.259 ms
64 bytes from 192.168.1.97: seq=2 ttl=64 time=150.870 ms
64 bytes from 192.168.1.97: seq=3 ttl=64 time=188.584 ms
64 bytes from 192.168.1.97: seq=4 ttl=64 time=212.353 ms
64 bytes from 192.168.1.97: seq=5 ttl=64 time=31.283 ms
64 bytes from 192.168.1.97: seq=6 ttl=64 time=55.041 ms
64 bytes from 192.168.1.97: seq=7 ttl=64 time=78.803 ms
64 bytes from 192.168.1.97: seq=8 ttl=64 time=102.559 ms
64 bytes from 192.168.1.97: seq=9 ttl=64 time=126.377 ms
64 bytes from 192.168.1.97: seq=10 ttl=64 time=150.087 ms
64 bytes from 192.168.1.97: seq=11 ttl=64 time=173.818 ms
64 bytes from 192.168.1.97: seq=12 ttl=64 time=197.610 ms
64 bytes from 192.168.1.97: seq=13 ttl=64 time=221.292 ms
64 bytes from 192.168.1.97: seq=14 ttl=64 time=40.242 ms
64 bytes from 192.168.1.97: seq=15 ttl=64 time=63.983 ms
64 bytes from 192.168.1.97: seq=16 ttl=64 time=88.982 ms
^C
--- 192.168.1.97 ping statistics ---
18 packets transmitted, 17 packets received, 5% packet loss
round-trip min/avg/max = 31.283/203.707/1234.886 ms

wifi config:

root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '20'
        option channel '11'
        option country 'RU'
        option hwmode '11ng'
        option htmode 'HT40-'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'vlaoNet'
        option network 'lan'
        option encryption 'psk-mixed'
        option key 'key'

comment:30 Changed 4 years ago by nbd

The ping times look normal for a client in powersave mode. Does normal network traffic (e.g. web browsing) work properly as well?

comment:31 Changed 4 years ago by anonymous

No, all the same :(

comment:32 Changed 4 years ago by ferob

Still not working.

comment:33 Changed 4 years ago by alexey.ostrovsky@…

I got the same issue.
Upgraded to last trunk and now both pnones HTC One X not able to use Wifi.
Packets drops.
Losses about 30-50%

Any solution guys?

Thank you

comment:34 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Guys, thanks for your patience - I finally received a phone affected by this issue and was able to debug and fix it.
The fix is committed in r39688

comment:35 Changed 4 years ago by dtaht

I have one device now working well at 2.4ghz... and another device now not working at all at 5ghz, after this fix went in.

Working: Nexus 7 (old style) at 2.4ghz
Not working nexus 4 at 5.x

comment:36 Changed 4 years ago by nbd

My Nexus 4 is working just fine on 5 GHz, I just tested it again

comment:37 Changed 4 years ago by VlaoMao

Seems to be working. Thanks!

comment:38 Changed 3 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.