Modify

Opened 4 years ago

Last modified 4 years ago

#14349 new enhancement

Unable to set VLANs in the arv4518pw.

Reported by: ppvazquezfer@… Owned by: developers
Priority: low Milestone: Chaos Calmer 15.05
Component: other Version: Trunk
Keywords: lantiq rtl8306 Cc:

Description

Tried with different configurations found in the forums (i began with the config of the Linksys WRT160NL) with no luck. Also tried with Attitude Adjustment with the same result. The arv4518pw has a RTL8306SD switch.
One vlan configuration worked, but when i rebooted the router, sadly, failed to set up the switch.
My intention is to connect a modem to one port and leave the other three free.
In this moment i am using a Zyxel AR7 based router configured as a modem and the arv4518 as a router with eth0 connected to the Zyxel.

Attachments (1)

network.txt (565 bytes) - added by ppvazquezfer@… 4 years ago.

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by ppvazquezfer@…

comment:1 Changed 4 years ago by ppvazquezfer@…

Tried configuring the VLANs with AA like WRT160NL but no luck again. I followed this post: https://forum.openwrt.org/viewtopic.php?pid=115181#p115181
Called my attention these two lines:

[    0.500000] Registering RTL8306SD switch with Chip ID: 0x5988, version: 0x0000
[    0.504000] eth0: attached PHY [Realtek RTL8306S] (phy_addr=ltq_etop-fffffff:00, irq=-1)

If i configure from luci and press "Save and apply" it works (port 0 as wan and ports 1-4 as lan), but when rebooting the configuration doesn't work.
In AA the ARV4518PW has defined switch reset with gpio 13.
Some info:

 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (Attitude Adjustment, r38621)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option _orig_ifname 'eth0 radio0.network1'
        option _orig_bridge 'true'
        option ifname 'eth0.1'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option vid '1'
        option ports '1 2 3 5t'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth0.2'

config switch_vlan
        option device 'eth0'
        option vlan '2'
        option vid '2'
        option ports '0 5t'
root@OpenWrt:/# swconfig dev eth0 help
switch0: eth0(RTL8306SD), ports: 6 (cpu @ 5), vlans: 16
     --switch
        Attribute 1 (int): reset (Reset the switch)
        Attribute 2 (int): enable_vlan (Enable VLAN mode)
        Attribute 3 (int): trunk (Enable port trunking)
        Attribute 4 (int): trunk_sel (Select ports for trunking (0: 0,1 - 1: 3,4))
        Attribute 5 (none): apply (Activate changes in the hardware)
        Attribute 6 (none): reset (Reset the switch)
     --vlan
        Attribute 1 (int): vid (VLAN ID (1-4095))
        Attribute 2 (ports): ports (VLAN port mapping)
     --port
        Attribute 1 (int): pvid (Port VLAN ID)
        Attribute 2 (int): link (get the current link state)
        Attribute 3 (int): speed (current link speed)
        Attribute 4 (int): nway (enable autonegotiation)
root@OpenWrt:/# swconfig dev eth0 show
Global attributes:
        reset: ???
        enable_vlan: ???
        trunk: 0
        trunk_sel: 0
Port 0:
        pvid: 2
        link: 0
        speed: 0
        nway: 1
Port 1:
        pvid: 1
        link: 0
        speed: 0
        nway: 1
Port 2:
        pvid: 1
        link: 0
        speed: 0
        nway: 1
Port 3:
        pvid: 1
        link: 0
        speed: 0
        nway: 1
Port 4:
        pvid: 4
        link: 0
        speed: 0
        nway: 1
Port 5:
        pvid: 5
        link: 0
        speed: 1
        nway: 0
VLAN 0:
        vid: 0
        ports: 0 5 
VLAN 1:
        vid: 1
        ports: 1 2 3 5 
VLAN 2:
        vid: 2
        ports: 0 5 
VLAN 3:
        vid: 3
        ports: 3 5 
VLAN 4:
        vid: 4
        ports: 4 5 
VLAN 5:
        vid: 5
        ports: 0 1 2 3 4 
root@OpenWrt:/# swconfig dev switch0 show
Global attributes:
        reset: ???
        enable_vlan: ???
        trunk: 0
        trunk_sel: 0
Port 0:
        pvid: 2
        link: 0
        speed: 0
        nway: 1
Port 1:
        pvid: 1
        link: 0
        speed: 0
        nway: 1
Port 2:
        pvid: 1
        link: 0
        speed: 0
        nway: 1
Port 3:
        pvid: 1
        link: 0
        speed: 0
        nway: 1
Port 4:
        pvid: 4
        link: 0
        speed: 0
        nway: 1
Port 5:
        pvid: 5
        link: 0
        speed: 1
        nway: 0
VLAN 0:
        vid: 0
        ports: 0 5 
VLAN 1:
        vid: 1
        ports: 1 2 3 5 
VLAN 2:
        vid: 2
        ports: 0 5 
VLAN 3:
        vid: 3
        ports: 3 5 
VLAN 4:
        vid: 4
        ports: 4 5 
VLAN 5:
        vid: 5
        ports: 0 1 2 3 4

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.