Modify

Opened 10 years ago

Closed 10 years ago

Last modified 2 years ago

#1440 closed defect (worksforme)

amwall-0.1.0 wrong makefile

Reported by: Goshawk <vincenzo.ampolo@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description (last modified by mbm)

On 06/03/07 (today) i did a checkout of the kamikaze/trunk and tried to compile, then an error was shown:

user@nanoserver:~$ cat error
mipsel-linux-uclibc-gcc -Wall
-I/home/nuser/OpenWrt/kamikaze/trunk/build_mipsel/amwall-0.1.0
-DLANG=\"en\"
-I/home/nuser/OpenWrt/kamikaze/trunk/staging_dir_mipsel/usr/include
-I/home/nuser/OpenWrt/kamikaze/trunk/staging_dir_mipsel/usr/include/compat
-D_GNU_SOURCE=1     -c -o grammar_en.o grammar_en.y.c
In file included from grammar_en.y:33:
grammar.h:1: error: syntax error before '-' token
grammar.h:1: error: syntax error at '#' token
In file included from grammar_en.y:33:
grammar.h:4:2: #endif without #if
make[4]: *** [grammar_en.o] Error 1
make[4]: Leaving directory
`/home/nuser/OpenWrt/kamikaze/trunk/build_mipsel/amwall-0.1.0'
make[3]: ***
[/home/nuser/OpenWrt/kamikaze/trunk/build_mipsel/amwall-0.1.0/.built]
Error 2

I solved the problem and made a patch:

--- Makefile.old        2007-03-06 11:43:32.000000000 +0100
+++ Makefile    2007-03-06 11:14:53.000000000 +0100
@@ -122,7 +122,7 @@
        $(RM) -f $(TARGET) $(OBJECTS) *.y.? grammar.h
 
 .y.o:
-       @echo -e \
+       @echo \
        "#ifndef _H_GRAMMAR\n#define _H_GRAMMAR\n#include \"$<.h\"\n#endif" \
                > grammar.h
        @echo -e "  YACC\t$<" 

As you can see, removing the "-e" is enought.

Attachments (1)

amwall.patch (366 bytes) - added by Goshawk <vincenzo.ampolo@…> 10 years ago.
patch

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Goshawk <vincenzo.ampolo@…>

patch

comment:1 Changed 10 years ago by mbm

  • Description modified (diff)

Cleaned up description; see WikiFormatting

comment:2 Changed 10 years ago by Bartman007

This is not a problem with amwall and it does not need to be patched. It is a bug/mistake/error/feature in dash, the Debian Shell. I assume you are on Ubuntu Edgy or later; or Debian. On both of these systems /bin/sh links to /bin/dash.

The echo implementation in bash, coreutils and busybox ash all handle the -e properly; dash does not. File a bug with Debian/Ubuntu to get this resolved; in the meantime you can relink /bin/sh to one of the other shells manually or via `dpkg-reconfigure -plow dash'

comment:3 Changed 10 years ago by Bartman007

As I had somewhat expected, Debian insists that dash operates properly and the others are wrong. Whether they are or not doesn't really matter in my mind as they should at least add code to exclude "-e" from their output. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=401481

comment:4 Changed 10 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.