Modify

Opened 10 years ago

Closed 10 years ago

Last modified 2 years ago

#1475 closed defect (worksforme)

vsftpd compile error

Reported by: rufus Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: vsftpd Cc:

Description

r6587, target brcm47xx-2.6
vsftpd cannot be compiled:

make[4]: Entering directory `/home/htpc/kamikaze/trunk/build_mipsel/vsftpd-2.0.4'
mipsel-linux-uclibc-gcc -c sysutil.c -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -idirafter dummyinc
sysutil.c: In function 'vsf_sysutil_wait_exited_normally':
sysutil.c:604: error: assignment of read-only member 'in'
sysutil.c: In function 'vsf_sysutil_wait_get_exitcode':
sysutil.c:614: error: assignment of read-only member '
in'
make[4]: * [sysutil.o] Error 1
make[4]: Leaving directory `/home/htpc/kamikaze/trunk/build_mipsel/vsftpd-2.0.4'
make[3]:
* home/htpc/kamikaze/trunk/build_mipsel/vsftpd-2.0.4/.built Error 2
make[3]: Leaving directory `/home/htpc/kamikaze/packages/net/vsftpd'
make[2]: * [vsftpd-compile] Error 2
make[2]: Leaving directory `/home/htpc/kamikaze/trunk/package'
make[1]:
* [package/compile] Error 2
make[1]: Leaving directory `/home/htpc/kamikaze/trunk'
make: * [world] Error 2

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the bug, same target.

comment:2 Changed 10 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Sorry, I tried once again with the same result.
Default configuration, in menuconfig only select Target system brcm47xx-2.6 and vsftpd in network as module. Target profile is default Atheros wifi, no other changes made.
Ubuntu 6.06 linux, r6596

I will try in other distribution, because image with this target system is not working in my wl-500g...

comment:3 Changed 10 years ago by florian

  • Resolution set to worksforme
  • Status changed from reopened to closed

I am pretty sure you did not updated the vsftpd package itself or the symlink.

comment:4 Changed 10 years ago by rufus

I built all from scratch, all previous source code was deleted. I will try with another compiler... but on r6508 with "old" target brcm-2.6 vsftpd package builds without any problem. Thank you for support.

comment:5 Changed 10 years ago by nico

fixed in [6610]

comment:6 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.