Modify

Opened 10 years ago

Closed 9 years ago

Last modified 3 years ago

#1614 closed defect (invalid)

Can't detect ADM6996L Switch on AR7

Reported by: Matteo Owned by: ejka
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

The cpmac driver can't detect the ADM6996L switch and fails with "No PHY present".
I have a temporary patch that forces the driver to use the ADM6996L.
Please allow instead the driver to detect the switch.

Attachments (1)

adm6996l.diff (497 bytes) - added by rootkit85@… 10 years ago.

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by rootkit85@…

comment:1 Changed 10 years ago by ejka

  • Milestone set to Kamikaze
  • Owner changed from developers to ejka
  • Priority changed from high to normal
  • Status changed from new to assigned

This patch is unacceptable as it breaks other devices

comment:2 follow-up: Changed 10 years ago by florian

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #99

comment:3 in reply to: ↑ 2 Changed 10 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Replying to florian:

Duplicate of #99

Ticket #99 is for the Marvell 88E6060 switch used in the DG834Gv2.

I get the following on my DG834Gv2 currently running build 7039. Should #99 maybe be closed instead?

root@OpenWrt:~# dmesg |grep PHY
Generic PHY: Registered new driver
Fixed PHY: Registered new driver
PHY: fixed@100:1 - Link is Up - 10/Half

comment:4 Changed 9 years ago by matteo

  • Status changed from reopened to new

The Infineon ADM6996LC switch can't be detected too.
Also, I can't get it working even with the attached patch or by setting dumb_switch = 1

Fixed PHY: Registered new driver
cpmac-mii: probed
cpmac: PHY is number 31
cpmac: device eth0 (regs: 08610000, irq: 27, phy: 0:1f, mac: 00:18:39:5c:1b:7f)

comment:5 Changed 9 years ago by matteo

  • Reporter changed from rootkit85@… to Matteo

comment:6 Changed 9 years ago by matteo

Can this error be related?

Generic PHY: Registered new driver
NET: Registered protocol family 8
NET: Registered protocol family 20
Time: MIPS clocksource has been installed.
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
kobject_add failed for :0000256 with -EEXIST, don't try to register things with the same name in the same directory.
Call Trace:
[<94108a60>] dump_stack+0x8/0x34
[<94213ba0>] kobject_shadow_add+0x198/0x230
[<94179af4>] sysfs_slab_add+0x13c/0x1b4
[<943c1a2c>] slab_sysfs_init+0x8c/0x15c
[<943b2780>] kernel_init+0xc4/0x324
[<94103ed4>] kernel_thread_helper+0x10/0x18

SLUB: Unable to add boot slab kmalloc-192 to sysfs

comment:7 Changed 9 years ago by matteo

  • Resolution set to invalid
  • Status changed from new to closed

comment:8 Changed 9 years ago by anonymous

I've the same eact problem with the latest trunk revision.

Any suggestion?

comment:9 Changed 3 years ago by m3m3nt0

still have this problem with AG241 v2 (ADM6996LC switch).

Any solution?

any cpmac.c patch to test?

comment:10 Changed 3 years ago by florian

  • Version set to Trunk

Could you post a dmesg log of the current trunk for your device?

comment:11 Changed 3 years ago by M3m3nt0

Sure.

Here is my dmesg output of trunk version r39422

http://pastebin.com/HHjJSP8V

comment:12 Changed 3 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.