Modify

Opened 9 years ago

Closed 8 years ago

#1647 closed defect (fixed)

kmod-nls-base not generated for brcm-2.4

Reported by: thepeople Owned by: florian
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

kmod-nls-base which is needed for kmod-fs-cifs is not generated for broadcom 2.4

Attachments (0)

Change History (10)

comment:1 Changed 9 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:2 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [7128]

comment:3 Changed 9 years ago by petr.stetina@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

root@OpenWrt:/opt# ipkg install kmod-nls-base
Nothing to be done
An error ocurred, return value: 4.
Collected errors:
Cannot find package kmod-nls-base.
Check the spelling or perhaps run 'ipkg update'

comment:4 Changed 9 years ago by petr.stetina@…

...Kamikaze

comment:5 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed with [7432], though nls-base will not be generated for brcm-2.4 since it is in-kernel. Other nls packages will not depend on it, which is the expected behaviour.

comment:6 Changed 9 years ago by wingedstone@…

  • Resolution fixed deleted
  • Status changed from closed to reopened
root@OpenWrt:/etc# ipkg update
Downloading http://downloads.openwrt.org/kamikaze/7.06/brcm-2.4/packages/Packages
Updated list of available packages in /usr/lib/ipkg/lists/snapshots
Done.
root@OpenWrt:/etc# ipkg install kmod-fs-cifs
Installing kmod-fs-cifs (2.4.34-brcm-1) to root...
Downloading http://downloads.openwrt.org/kamikaze/7.06/brcm-2.4/packages/./kmod-fs-cifs_2.4.34-brcm-1_mipsel.ipk
Nothing to be done
An error ocurred, return value: 1.
Collected errors:
ERROR: Cannot satisfy the following dependencies for kmod-fs-cifs:
         kmod-nls-base

kmod-fs-cifs still depends on kmod-nls-base

comment:7 Changed 9 years ago by olli

  • Resolution set to fixed
  • Status changed from reopened to closed

Next Kamikaze release 7.07 will fix it. If you can't wait try from here.

Really closes this ticket now.

comment:8 Changed 9 years ago by waters23_1999@…

I noticed the msdos ( kmod-fs-msdos) and vfat (kmod-fs-vfat) packages experience the same problem at my openwrt brcm-2.4 version 7.06 when trying to install both packages for mounting a usb flash drive.

I hope this information is useful to you guys.

comment:9 Changed 8 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

ipkg install kmod-nls-iso8859-15
Installing kmod-nls-iso8859-15 (2.4.35.4-brcm-2.4-1) to root...
Downloading http://laptop/trunk/packages/./kmod-nls-iso8859-15_2.4.35.4-brcm-2.4-1_mipsel.ipk
Nothing to be done
An error ocurred, return value: 1.
Collected errors:
ERROR: Cannot satisfy the following dependencies for kmod-nls-iso8859-15:

kmod-nls-base

ipkg install kmod-nls-cp850
Installing kmod-nls-cp850 (2.4.35.4-brcm-2.4-1) to root...
Downloading http://laptop/trunk/packages/./kmod-nls-cp850_2.4.35.4-brcm-2.4-1_mipsel.ipk
Nothing to be done
An error ocurred, return value: 1.
Collected errors:
ERROR: Cannot satisfy the following dependencies for kmod-nls-cp850:

kmod-nls-base

I tried with nls-base in-kernel and as module (is not generated) with same result.

comment:10 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

Finally fixed with [10712].

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.