Modify

Opened 10 years ago

Closed 9 years ago

Last modified 2 years ago

#1655 closed defect (fixed)

pppoe can not start correctly in Kamikaze r7145

Reported by: damiel_1016@… Owned by: nbd
Priority: highest Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: pppoe Cc:

Description

pppoe can not start correctly in Kamikaze r7145

Attachments (4)

log_read (13.4 KB) - added by daniel_1016@… 10 years ago.
log of my 634u router
lsmod (2.2 KB) - added by daniel_1016@… 10 years ago.
lsmod
log (5.1 KB) - added by daniel_1016@… 10 years ago.
log of compile r7151
kernel-panic (1.6 KB) - added by arteqw@… 10 years ago.
kernel panic when wan using PPPoE

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by daniel_1016@…

log of my 634u router

Changed 10 years ago by daniel_1016@…

lsmod

comment:1 Changed 10 years ago by nbd

  • Owner changed from developers to nbd
  • Status changed from new to assigned

please try r7149

Changed 10 years ago by daniel_1016@…

log of compile r7151

Changed 10 years ago by arteqw@…

kernel panic when wan using PPPoE

comment:2 Changed 10 years ago by schuon (AT) mytum (DOT) de

I can confirm this also for r7263 on a netgear wgt634u. Does anyone know if this is a problem related to the netgear or does it apply to all h/w?

comment:3 in reply to: ↑ description Changed 10 years ago by anonymous

I have a WGT with r7279 and pppoe is working for me (and was several builds before). I still get some strange messages in serial console, but not with dmesg:

: Plugin rp-pppoe.so loaded.
: Linux kernel does not support PPPoE -- are you running 2.4.x?
br-lan: port 2(ath0) entering learning state
br-lan: topology change detected, propagating
br-lan: port 2(ath0) entering forwarding state
: Plugin rp-pppoe.so loaded.

Still, pppd is up and running.

comment:4 Changed 10 years ago by anonymous

even in the 7.06 I get:


Jan  1 00:00:38 bastet daemon.info pppd[1405]: Plugin rp-pppoe.so loaded.
Jan  1 00:00:38 bastet user.info : Plugin rp-pppoe.so loaded.
Jan  1 00:00:38 bastet daemon.err pppd[1405]: Linux kernel does not support PPPoE -- are you running 2.4.x?
Jan  1 00:00:38 bastet user.info : Linux kernel does not support PPPoE -- are you running 2.4.x?
Jan  1 00:00:38 bastet daemon.info pppd[1405]: Exit.}}}

comment:5 Changed 9 years ago by anonymous

This seems to happen only when br-lan and eth0.1 are not initialized before:

Jan  1 00:00:28 OpenWrt daemon.info pppd[890]: Plugin rp-pppoe.so loaded.
Jan  1 00:00:28 OpenWrt user.info : Plugin rp-pppoe.so loaded. 
Jan  1 00:00:28 OpenWrt daemon.err pppd[890]: Linux kernel does not support PPPoE -- are you running 2.4.x?
Jan  1 00:00:28 OpenWrt user.info : Linux kernel does not support PPPoE -- are you running 2.4.x? 
Jan  1 00:00:28 OpenWrt daemon.info pppd[890]: Exit.
Jan  1 00:00:32 OpenWrt user.info kernel: br-lan: port 1(eth0.0) entering learning state
Jan  1 00:00:32 OpenWrt user.info kernel: br-lan: topology change detected, propagating
Jan  1 00:00:32 OpenWrt user.info kernel: br-lan: port 1(eth0.0) entering forwarding state 
Jan  1 00:00:42 OpenWrt user.debug kernel: eth0.1: del 01:00:5e:00:00:01 mcast address from vlan interface
Jan  1 00:00:42 OpenWrt user.debug kernel: eth0.1: del 01:00:5e:00:00:01 mcast address from master interface
Jan  1 00:00:42 OpenWrt user.debug kernel: eth0.1: add 01:00:5e:00:00:01 mcast address to master interface
Jan  1 00:00:42 OpenWrt daemon.info pppd[1673]: Plugin rp-pppoe.so loaded.
Jan  1 00:00:42 OpenWrt user.info : Plugin rp-pppoe.so loaded. 
Jan  1 00:00:42 OpenWrt daemon.notice pppd[1674]: pppd 2.4.3 started by root, uid 0
Jan  1 00:00:43 OpenWrt daemon.info pppd[1674]: PPP session is 1843
Jan  1 00:00:43 OpenWrt daemon.info pppd[1674]: Using interface ppp0
Jan  1 00:00:43 OpenWrt daemon.notice pppd[1674]: Connect: ppp0 <--> eth0.1 

comment:6 in reply to: ↑ description Changed 9 years ago by anonymous

Could not get pppoe work with 7.06 followed with guide here: http://wiki.openwrt.org/OpenWrtDocs/Hardware/Netgear/WGT634U

Jan  1 00:00:28 Delta9 daemon.info pppd[1046]: Plugin rp-pppoe.so loaded.
Jan  1 00:00:28 Delta9 user.info : Plugin rp-pppoe.so loaded.
Jan  1 00:00:28 Delta9 daemon.err pppd[1046]: Linux kernel does not support PPPoE -- are you running 2.4.x?
Jan  1 00:00:28 Delta9 daemon.info pppd[1046]: Exit.
Jan  1 00:01:02 Delta9 daemon.info pppd[1561]: Plugin rp-pppoe.so loaded.
Jan  1 00:01:02 Delta9 daemon.notice pppd[1562]: pppd 2.4.3 started by root, uid 0
Jan  1 00:01:03 Delta9 daemon.info pppd[1562]: PPP session is 108
Jan  1 00:01:03 Delta9 daemon.info pppd[1562]: Using interface ppp0
Jan  1 00:01:03 Delta9 daemon.notice pppd[1562]: Connect: ppp0 <--> eth0.1
Jan  1 00:01:03 Delta9 daemon.warn pppd[1562]: Couldn't increase MTU to 1500
Jan  1 00:01:03 Delta9 daemon.warn pppd[1562]: Couldn't increase MRU to 1500
Jan  1 00:01:03 Delta9 daemon.notice pppd[1562]: peer from calling number 00:E0:FC:02:CC:A9 authorized
Jan  1 00:01:33 Delta9 daemon.warn pppd[1562]: IPCP: timeout sending Config-Requests
Jan  1 00:01:33 Delta9 daemon.warn pppd[1562]: Couldn't increase MTU to 1500
Jan  1 00:01:33 Delta9 daemon.warn pppd[1562]: Couldn't increase MRU to 1500
Jan  1 00:01:39 Delta9 daemon.notice pppd[1562]: Connection terminated.
Jan  1 00:01:39 Delta9 daemon.notice pppd[1562]: Modem hangup

But looks like the error message "Linux kernel does not support PPPoE -- are you running 2.4.x?" is a grab bag error message which the pppd program produces almost anytime something goes wrong. The response depends on the kernel version you are running (see here:http://axion.physics.ubc.ca/ppp-linux.html).

comment:7 Changed 9 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in [7726]

comment:8 Changed 9 years ago by Flo

workaround for me was adding the line "ifup -a" at /etc/init.d/network: boot() { ...
before the last line "/sbin/wifi up" }

-Flo

comment:9 Changed 9 years ago by anonymous

As workaround "ifup wan" is enough.

comment:10 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.