Opened 9 years ago

Closed 9 years ago

#1740 closed defect (worksforme)

postgresql is still broken on different targets

Reported by: anonymous Owned by: florian
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:


yes, libnotimpl is in the toolchain and on the host (ubuntu 7.04) i have installed ecpg ,pg_config, and zic. revision 6500 was the last revision that worked for me.

rm -f complex.o funcs.o
rm -f advanced.sql basics.sql complex.sql funcs.sql syscat.sql
make[5]: Leaving directory `/home/ubuntu/test/OpenWrt-SDK-Linux-i686-1/build_mipsel/postgresql-8.2.3/src/tutorial'
make -C test/thread distclean
make[5]: Entering directory `/home/ubuntu/test/OpenWrt-SDK-Linux-i686-1/build_mipsel/postgresql-8.2.3/src/test/thread'
rm -f thread_test thread_test.o
make[5]: Leaving directory `/home/ubuntu/test/OpenWrt-SDK-Linux-i686-1/build_mipsel/postgresql-8.2.3/src/test/thread'
rm -f Makefile.port
make[4]: Leaving directory `/home/ubuntu/test/OpenWrt-SDK-Linux-i686-1/build_mipsel/postgresql-8.2.3/src'
rm -f config.cache config.log config.status GNUmakefile
make[3]: Leaving directory `/home/ubuntu/test/OpenWrt-SDK-Linux-i686-1/build_mipsel/postgresql-8.2.3'
(cd /home/ubuntu/test/OpenWrt-SDK-Linux-i686-1/build_mipsel/postgresql-8.2.3; rm -f config.cache; AR=mipsel-linux-uclibc-ar AS="mipsel-linux-uclibc-gcc -c -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" LD=mipsel-linux-uclibc-ld NM=mipsel-linux-uclibc-nm CC="mipsel-linux-uclibc-gcc" GCC="mipsel-linux-uclibc-gcc" CXX=mipsel-linux-uclibc-g++ RANLIB=mipsel-linux-uclibc-ranlib STRIP=mipsel-linux-uclibc-strip OBJCOPY=mipsel-linux-uclibc-objcopy CFLAGS="-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" CPPFLAGS="$CPPFLAGS " LDFLAGS="" LIBS="-lnotimpl" ./configure --target=mipsel-linux --host=mipsel-linux --build=i486-linux-gnu --program-prefix="" --program-suffix="" --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --datadir=/usr/share --includedir=/usr/include --infodir=/usr/share/info --libdir=/usr/lib --libexecdir=/usr/lib --localstatedir=/var --mandir=/usr/share/man --sbindir=/usr/sbin --sysconfdir=/etc --disable-nls  --enable-shared --enable-static --disable-integer-datetimes --disable-rpath --without-java --without-krb4 --without-krb5 --without-openssl --without-pam --without-perl --without-python --without-readline --without-rendezvous --without-tcl --without-tk --with-zlib="yes" );
configure: loading site script /home/ubuntu/test/OpenWrt-SDK-Linux-i686-1/include/site/mipsel-linux-uclibc
checking build system type... i486-pc-linux-gnu
checking host system type... mipsel-unknown-linux-gnu
checking which template to use... linux
checking whether to build with 64-bit integer date/time support... no
checking whether NLS is wanted... no
checking for default port number... 5432
checking for mipsel-linux-gcc... mipsel-linux-uclibc-gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
make[2]: *** [/home/ubuntu/test/OpenWrt-SDK-Linux-i686-1/build_mipsel/postgresql-8.2.3/.configured] Error 77
make[2]: Leaving directory `/home/ubuntu/test/OpenWrt-SDK-Linux-i686-1/packages/libs/postgresql'
make[1]: *** [postgresql-compile] Error 2
make[1]: Leaving directory `/home/ubuntu/test/OpenWrt-SDK-Linux-i686-1/package'
make: *** [package/postgresql-compile] Error 2

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by anonymous


comment:2 Changed 9 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:3 Changed 9 years ago by florian

  • Resolution set to worksforme
  • Status changed from assigned to closed

I guess you are missing some host side tools, I cannot reproduce the bug here with feisty fawn.

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.