Opened 9 years ago

Closed 9 years ago

Last modified 2 years ago

#1742 closed defect (wontfix)

pptpctrl causes oops

Reported by: netprince (at) vt (dot) edu Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: pptpd, pptpctrl Cc:


Works fine in whiterussian, found this while testing kamikaze. I've tried pptp v1.3.0, and 1.2.3. I'm attempting to connect from a winXP machine. Let me know what else to try. I'm going to try a few more things later...

Unable to handle kernel paging request at virtual address 0000001                                            6, epc == 8011da4c, ra == 8011da14
Oops in fault.c::do_page_fault, line 206:
$0 : 00000000 1000fc00 0000000c 00000000 80e51230 00000000 00000000 1000fc01
$8 : 00000078 00000000 00000000 80749720 00000000 00000000 00000000 00000000
$16: 80e511c0 80e5120c 00000014 00000000 00000014 801a0000 00000000 00000001
$24: 00000000 2abce980                   80636000 80637a70 00000000 8011da14
Hi : 00000000
Lo : 00000022
epc   : 8011da4c    Tainted: P
Status: 1000fc03
Cause : 00000008
PrId  : 00029008
Process pptpctrl (pid: 3870, stackpage=80636000)
Stack:    80140254 00000003 80d2e420 02000001 8089c6a0 80e513c0 80e513c0
 00000014 807496fc 80e51340 c01ca20c c01ca1c0 80184080 80d2e420 802aea60
 802c3800 00000000 0101a8c0 80e513f0 00000014 c01ca378 802aead8 802aead8
 00000003 00000000 802aea60 00000000 76612074 21c003ff 0000c000 00000000
 23000405 80e24d80 8022f400 801a0000 801a6c00 801a0000 00000000 00000002
 00000000 ...
Call Trace:   [<80140254>] [<c01ca20c>] [<c01ca1c0>] [<c01ca378>] [<800e7a84>]
 [<800ccc9c>] [<800cccac>] [<8012fa4c>] [<800e7a84>] [<8012fa8c>] [<8012eec0>]
 [<800ccc9c>] [<800e7434>] [<8011da14>] [<8011eca0>] [<800e8b0c>] [<8011e3ac>]
 [<800c808c>] [<800ccf54>] [<800e8b0c>] [<800d59a4>] [<800d5e88>] [<800e8b0c>]
 [<800e8b0c>] [<800d5e40>] [<800e8b0c>] [<800e9494>] [<800e8b0c>] [<80069e7c>]
 [<80069e30>] [<800fa124>] [<8009fdf8>] [<8006a7d4>] [<8006a7cc>] [<800fac24>]
 [<800c7eb4>] [<800fbad0>] [<800fba6c>] [<80098ea8>] [<800f02a8>] ...

Code: 00661821  ac820000  ac830004 <96470002> 24020068  0045400b  02084021  30e6                                            00ff  8d040000
Kernel panic: Aiee, killing interrupt handler!
In interrupt handler - not syncing
 <0>Rebooting in 3 seconds..

Attachments (1)

mppe_mppc_missing.patch (971 bytes) - added by netprince (at) vt (dot) edu 9 years ago.
fixes mppe_mppc module missing in 2.4

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by netprince (at) vt (dot) edu

Let me add a few more details...

The system reboots while trying to connect the VPN from a windows XP box. Specifically, when the dialog says 'registering your computer...'. If I enter an incorrect password, then the router still reboots.

I am running r7305.

comment:2 Changed 9 years ago by netprince (at) vt (dot) edu

I also forgot to mention its the broadcom 2.4 build of kamikaze.

comment:3 Changed 9 years ago by netprince (at) vt (dot) edu

Looks like the ip_conntrack_pptp module could be the cause, if I dont load it then I can connect/disconnect normally...

comment:4 Changed 9 years ago by netprince (at) vt (dot) edu

I found a small problem with building the ppp_mppe_mppc module for the 2.4 kernel, attached a patch.

Changed 9 years ago by netprince (at) vt (dot) edu

fixes mppe_mppc module missing in 2.4

comment:5 Changed 9 years ago by florian

Patch added in [7362]

comment:6 follow-up: Changed 9 years ago by florian

  • Resolution set to wontfix
  • Status changed from new to closed

pptp is known to be crashing with 2.4 kernels. It is not worth the fix until we move to 2.6.

comment:7 Changed 8 years ago by anonymous

Do you have any update here, or expectation ?
It is working fine with DD-WRT, kernel in newer than K 7.09 :
Linux DD-WRT 2.4.36 #312 Sun Jul 27 16:42:02 CEST 2008 mips unknown.

comment:8 in reply to: ↑ 6 Changed 7 years ago by anonymous

Does this mean that you will never be able to use pptp on kamikaze 8.09 with kernel 2.4? So all depends on Broadcom releasing their wireless driver or on b43 until I can upgrade to kernel 2.6? Very frustrating situation.

comment:9 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.