Modify

Opened 9 years ago

Closed 7 years ago

Last modified 21 months ago

#1749 closed enhancement (fixed)

RTC driver for ASUS WL-HDD

Reported by: andimai Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: Cc:

Description

As requested I have attached the source code for an RTC driver for the ASUS WL-HDD which can replace the proprietary rtcdrv.o module. I has the same interface as rtcdrv.o and additionally supports the standard hwclock utility.

Attachments (2)

rtc.c (11.6 KB) - added by andimai 9 years ago.
rtc.2.c (11.5 KB) - added by andimai 9 years ago.
Bugfixed update

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by andimai

Changed 9 years ago by andimai

Bugfixed update

comment:1 Changed 9 years ago by andimai

Attached updated driver source, which fixes two bugs: 12h/24h transformation was incorrect and there was an off-by-one error when accessing the RTC via the ioctl() call.

comment:2 Changed 9 years ago by florian

  • Milestone changed from 0.9/rc6 to Kamikaze
  • Priority changed from normal to low

comment:3 Changed 9 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1873

comment:4 Changed 8 years ago by Eric <eric.poscher@…>

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Can someone build a binary package of that rtc driver - maybe something like kmod-rtc-wlhdd, so that people who are not into crosscompiling can easily install it?

comment:5 Changed 7 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed with [17073].

comment:6 Changed 21 months ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.