Opened 9 years ago

Closed 9 years ago

Last modified 2 years ago

#2059 closed defect (worksforme)

kernel panic when using 5GHz channels on atheros madwifi

Reported by: bart.swinnen@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: Cc:


When I change the channel of my AP to a 5GHz channel, i get a kernel panic. I think this is since the last version change of madwifi?

I'm using : KAMIKAZE (bleeding edge, r7897) on a Atheros platform.
Linux version

MadWifi and wlan info

wlan: (svn r2537)
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: (AR5212, AR5312, RF5111, RF5112)
ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (svn r2537)
ath_rate_minstrel: look around rate set to 10%
ath_rate_minstrel: EWMA rolloff level set to 75%
ath_rate_minstrel: max segment size in the mrr set to 6000 us
wlan: mac acl policy registered
ath_ahb: (svn r2537)
ath_pci: switching rfkill capability off
ath_pci: ath_pci: switching per-packet transmit power control off
wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 5.8 phy 4.4 radio 3.6
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
wifi0: Atheros 2313 WiSoC: mem=0xb8500000, irq=5

Here is some output how to reproduce the problem.

root@OpenWrt:/# iwconfig ath0
ath0      IEEE 802.11g  ESSID:"LumWifi"  Nickname:""
          Mode:Master  Frequency:2.462 GHz  Access Point: 00:4F:69:50:A7:CD
          Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=1/1
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:2600-941B-CDA6-1A00-2BF9-4365-E649-5055 [2]   Security mode:open
          Power Management:off
          Link Quality=0/70  Signal level=-94 dBm  Noise level=-94 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

When I change the channel to channel 40 I get a kernel panic.

root@OpenWrt:/# iwconfig ath0 channel 40
root@OpenWrt:/# skb_over_panic: text:c04bb5a4 len:405 put:5 head:81c31000 data:81c31010 tail:81c311a5 end:81c311a0 dev:<NULL>Break instruction in kernel code[#1]:
Cpu 0
$ 0   : 00000000 1000d000 00000071 80262460
$ 4   : 80262454 00000001 00000000 00000000
$ 8   : 1dcd6500 ac0a1100 80290000 802a0000
$12   : 80290000 8025fc58 80295d04 00000000
$16   : 81126dd4 00000000 813b3320 81c3104a
$20   : 803dabe0 813b3aa8 81126320 bfbfffdd
$24   : 00000000 802322a4
$28   : 8025e000 8025fd90 bfbfffdd 80185368
Hi    : 00000080
Lo    : 00000070
epc   : 80185368     Tainted: P
ra    : 80185368 Status: 1000d002    KERNEL EXL
Cause : 10800024
PrId  : 0001800a
Modules linked in: ath_ahb wlan_xauth wlan_wep wlan_tkip wlan_ccmp wlan_acl ath_rate_minstrel ath_hal(P) wlan_scan_sta wlan_tProcess swapper (pid: 0, threadinfo=8025e000, task=80260188)
Stack : 80042a80 c04bb5a4 00000195 00000005 81c31000 81c31010 81c311a5 81c311a0
        8024504c 00000001 c04bb5c0 00000002 00000002 00000000 00000000 00000000
        1000d001 00000003 00000001 803dabe0 813b3320 00000000 81c31c00 81126320
        802f8000 bfbfffdd bfbfffdd c0508084 ffffffff fff24460 8025fe08 00000000
        00000001 81127a14 81126320 802f8000 802f8000 8025fe48 81126000 c0513c20
Call Trace:[<80042a80>][<c04bb5a4>][<c04bb5c0>][<c0508084>][<c0513c20>][<80087e18>][<80089bac>][<80068160>][<8004488c>][<800]
Code: afa8001c  0c018a1f  afa20020 <0200000d> 8fbf0028  03e00008  27bd0030  27bdffe0  afb10014
Kernel panic - not syncing: Fatal exception in interrupt
Rebooting in 3 seconds..

I have no problem when I use channels in 2.4GHz range.

Attachments (0)

Change History (8)

comment:1 Changed 9 years ago by bart.swinnen@…

I'm quite sure it has to do with the madwifi version.
I do not have the problem with: ath_ahb: (svn r2420)


comment:2 Changed 9 years ago by florian

Confirmed, same here with silent reboots sometimes.

Try forcing the mode to be 11g or 11b in /etc/config/wireless :

option agmode "11g"

comment:3 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Errm, my problem was a hardware problem, this seems to be fixed now.

comment:4 Changed 9 years ago by bart.swinnen@…

What do you mean by fixed now????? new release, new version new hardware??

comment:5 Changed 9 years ago by robert.lukan@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

I have same problem with Kamikaze 7.07, and I need 5 GHz :)

comment:6 Changed 9 years ago by riener_w@…

Hi guys,
I have got same problems ...
I think it has to do with the madwifi version, too.

comment:7 Changed 9 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

should be fixed in r9422

comment:8 Changed 2 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.