Modify

Opened 9 years ago

Closed 9 years ago

#2064 closed defect (wontfix)

switch-robo fails to load on WL-500g with Kamikaze 7.07

Reported by: Fatus Owned by: developers
Priority: normal Milestone:
Component: kernel Version:
Keywords: Cc:

Description

Not sure if nbd wants feedback here, nobody answered on IRC:

With http://downloads.openwrt.org/people/nbd/kamikaze/7.07/brcm-2.4/openwrt-brcm-2.4-squashfs.trx,
on my Asus WL-500g switch-robo is not loaded:

Jan  1 00:00:09 wl500g user.warn kernel: diag: Detected 'ASUS WL-500g'
Jan  1 00:00:09 wl500g user.info kernel: b44: eth0: Link is up at 100 Mbps, full duplex.
Jan  1 00:00:09 wl500g user.info kernel: b44: eth0: Flow control is off for TX and off for RX.
Jan  1 00:00:09 wl500g user.warn kernel: Probing device eth0: No Robo switch in managed mode found
Jan  1 00:00:09 wl500g user.warn kernel: Probing device eth1: No Robo switch in managed mode found
Jan  1 00:00:09 wl500g user.warn kernel: Probing device eth2: No such device
Jan  1 00:00:09 wl500g user.warn kernel: Probing device eth3: No such device
Jan  1 00:00:09 wl500g user.warn kernel: BFL_ENETADM not set in boardflags. Use force=1 to ignore.
Jan  1 00:00:09 wl500g user.info kernel: >mini_fo: using base directory: /
Jan  1 00:00:09 wl500g user.info kernel: mini_fo: using storage directory: /jffs
Jan  1 00:00:09 wl500g user.warn kernel: jffs2.bbc: SIZE compression mode activated.
Jan  1 00:00:11 wl500g user.info kernel: device eth0 entered promiscuous mode
Jan  1 00:00:12 wl500g user.info kernel: b44: eth0: Link is up at 100 Mbps, full duplex.
Jan  1 00:00:12 wl500g user.info kernel: b44: eth0: Flow control is off for TX and off for RX.
Jan  1 00:00:12 wl500g user.info kernel: br-lan: port 1(eth0) entering learning state
Jan  1 00:00:12 wl500g user.info kernel: br-lan: port 1(eth0) entering forwarding state
Jan  1 00:00:12 wl500g user.info kernel: br-lan: topology change detected, propagating
Jan  1 00:00:13 wl500g user.warn kernel: Probing device eth0: No Robo switch in managed mode found
Jan  1 00:00:13 wl500g user.warn kernel: Probing device eth1: No Robo switch in managed mode found
Jan  1 00:00:13 wl500g user.warn kernel: Probing device eth2: No such device
Jan  1 00:00:13 wl500g user.warn kernel: Probing device eth3: No such device
Jan  1 00:00:13 wl500g user.warn kernel: BFL_ENETADM not set in boardflags. Use force=1 to ignore.

The result: WAN port shows no connection and

root@wl500g:~# ls -la /proc/switch/
dr-xr-xr-x    2 root     root            0 Jan  1 00:07 .
dr-xr-xr-x   34 root     root            0 Jan  1 00:00 ..
root@wl500g:~# insmod switch-robo
insmod: init_module: switch-robo: No such device
root@wl500g:~# logread
Jan  1 00:08:39 wl500g user.warn kernel: Probing device eth0: No Robo switch in managed mode found
Jan  1 00:08:39 wl500g user.warn kernel: Probing device eth1: No Robo switch in managed mode found
Jan  1 00:08:39 wl500g user.warn kernel: Probing device eth2: No such device
Jan  1 00:08:39 wl500g user.warn kernel: Probing device eth3: No such device

Attachments (0)

Change History (8)

comment:1 follow-up: Changed 9 years ago by nbd

The problem is that the switch on the WL-500g is not accessible through MII.
It might be possible to configure it through GPIO, but support for that needs to be added to switch-robo.c first.

comment:2 in reply to: ↑ 1 Changed 9 years ago by anonymous

Replying to nbd:

The problem is that the switch on the WL-500g is not accessible through MII.
It might be possible to configure it through GPIO, but support for that needs to be added to switch-robo.c first.

Ok, but I can't remember having that problem on Whiterussian. There was different code back then, correct?

If you say GPIO, is there any source, old code or something, that I could look in order to create a patch for switch-robo.c? Just any indication as to in which direction research could go?

comment:3 Changed 9 years ago by nbd

whiterussian also does not support that chip on the wl-500g.

comment:4 Changed 9 years ago by Fatus

You're saying whiterussian didn't configure the switch on WL-500g? I mean the "vlan0ports=0 1 2 3 4 5*" nvram setting, it was used after all, wasn't it?

comment:5 Changed 9 years ago by nbd

Right, whiterussian didn't configure the switch. If the vlan0ports variable mattered on that device, it was probably the boot loader applying the settings

comment:6 Changed 9 years ago by Fatus

Just to clarify, not THAT particular switch or not switches in general?

Also, do you have any idea where I could go look at? Otherwise, just close this bug then.

comment:7 Changed 9 years ago by nbd

that particular switch on wl-500g would be supported if switch-robo could access it through gpio, but it only supports switches connected through mii
there might be a few versions of the broadcom ethernet driver around that can help you with understanding how it works through gpio

comment:8 Changed 9 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

Setting this to wontfix. The switch layer will be rewritten sooner or later, the rewrite might include support for this.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.