Modify

Opened 9 years ago

Closed 9 years ago

#2080 closed defect (fixed)

iptables 1.3.8 doesn't install on broadcom 2.4

Reported by: netprince (at) vt (dot) edu Owned by: developers
Priority: high Milestone: Kamikaze 8.09 RC1
Component: packages Version:
Keywords: iptables Cc:

Description

Its looking for libipt_quota.so, which doesn't appear to exist:

make[3]: Entering directory `/trunk/package/iptables'
install -d -m0755 /trunk/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg/iptables-mod-extra/usr/lib/iptables
for m in ipt_condition ipt_LOG ipt_owner ipt_pkttype ipt_quota; do cp -fpR /trunk/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg-install/usr/lib/iptables/lib${m}.so /trunk/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg/iptables-mod-extra/usr/lib/iptables/ ; done
cp: cannot stat `/trunk/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg-install/usr/lib/iptables/libipt_quota.so': No such file or directory
make[3]: *** [/trunk/bin/packages/iptables-mod-extra_1.3.8-1_mipsel.ipk] Error 1
make[3]: Leaving directory `/trunk/package/iptables'
make[2]: *** [iptables-compile] Error 2
make[2]: Leaving directory `/trunk/package'
make[1]: *** [package/compile] Error 2
make[1]: Leaving directory `/trunk'
make: *** [world] Error 2

Attachments (1)

009-iptquota.patch (2.2 KB) - added by eisvogel äht embinet döt de 9 years ago.
package/iptables/patches/009-iptquota.patch (compile fix)

Download all attachments as: .zip

Change History (17)

comment:1 Changed 9 years ago by Weedy <weedy2887@…>

confirmed

mkdir -p /home/weedy/wrt54gs/kamikaze/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg/iptables-mod-extra/CONTROL
echo "Package: iptables-mod-extra" > /home/weedy/wrt54gs/kamikaze/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg/iptables-mod-extra/CONTROL/control
echo "Version: 1.3.8-1" >> /home/weedy/wrt54gs/kamikaze/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg/iptables-mod-extra/CONTROL/control
( DEPENDS=''; for depend in iptables +kmod-ipt-extra; do DEPENDS=${DEPENDS:+$DEPENDS, }${depend##+}; done; echo "Depends: $DEPENDS"; echo "Source: package/iptables"; echo "Section: net"; echo "Priority: optional"; echo "Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>"; echo "Architecture: mipsel"; echo -n "Description: "; getvar V_Package_iptables_mod_extra_description | sed -e 's,^[[:space:]]*, ,g'; ) >> /home/weedy/wrt54gs/kamikaze/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg/iptables-mod-extra/CONTROL/control
chmod 644 /home/weedy/wrt54gs/kamikaze/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg/iptables-mod-extra/CONTROL/control
(cd /home/weedy/wrt54gs/kamikaze/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg/iptables-mod-extra/CONTROL; var2file "V_Package_iptables_mod_extra_conffiles" conffiles; var2file "V_Package_iptables_mod_extra_preinst" preinst; var2file "V_Package_iptables_mod_extra_postinst" postinst; var2file "V_Package_iptables_mod_extra_prerm" prerm; var2file "V_Package_iptables_mod_extra_postrm" postrm; )
install -d -m0755 /home/weedy/wrt54gs/kamikaze/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg/iptables-mod-extra/usr/lib/iptables
for m in ipt_condition ipt_LOG ipt_owner ipt_pkttype ipt_quota; do cp -fpR /home/weedy/wrt54gs/kamikaze/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg-install/usr/lib/iptables/lib${m}.so /home/weedy/wrt54gs/kamikaze/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg/iptables-mod-extra/usr/lib/iptables/ ; done
cp: cannot stat `/home/weedy/wrt54gs/kamikaze/build_mipsel/linux-2.4-brcm/iptables-1.3.8/ipkg-install/usr/lib/iptables/libipt_quota.so': No such file or directory
make[3]: *** [/home/weedy/wrt54gs/kamikaze/bin/packages/iptables-mod-extra_1.3.8-1_mipsel.ipk] Error 1
make[3]: Leaving directory `/home/weedy/wrt54gs/kamikaze/package/iptables'
make[2]: *** [iptables-compile] Error 2
make[2]: Leaving directory `/home/weedy/wrt54gs/kamikaze/package'
make[1]: *** [package/compile] Error 2
make[1]: Leaving directory `/home/weedy/wrt54gs/kamikaze'
make: *** [world] Error 2

comment:2 Changed 9 years ago by anonymous

Confirmed. Same thing here.

comment:3 Changed 9 years ago by Weedy <weedy2887@…>

[7988] builds for me.

comment:4 follow-up: Changed 9 years ago by anonymous

Just tried 8005, same problem. Did you change anything?

comment:5 in reply to: ↑ 4 Changed 9 years ago by Weedy <weedy2887@…>

Replying to anonymous:

Just tried 8005, same problem. Did you change anything?

make distclean

comment:6 Changed 9 years ago by netprince (at) vt (dot) edu

Just tried the latest build (8138) and still the missing quota module is causing problems. To see the problem, you must include iptables-mod-extra into the firmware:

<*>   iptables-mod-extra....................... other extra iptables extensions

comment:7 follow-up: Changed 9 years ago by KadettGTE devilboy@…

after it gives the error, go to build_mipsel/linux-2.4-brcm/iptables-1.3.8/extensions
edit the Makefile and on the line that says PF_EXT_SLIB add quota at the end, then go to build_mipsel/linux-2.4-brcm/linux-2.4.34/includes/linux/netfilter and create a file named xt_quota.h with this contents

#ifndef _XT_QUOTA_H

2 #define _XT_QUOTA_H
3
4 enum xt_quota_flags {
5 XT_QUOTA_INVERT = 0x1,
6 };
7 #define XT_QUOTA_MASK 0x1
8
9 struct xt_quota_info {

10 u_int32_t flags;
11 u_int32_t pad;
12 aligned_u64 quota;
13 struct xt_quota_info *master;
14 };
15
16 #endif /* _XT_QUOTA_H */
17

(without the line numbers of course lol)

create this same file under build_mipsel/linux-2.4-brcm/linux-2.4.34/includes/linux/netfilter_ipv4

comment:8 in reply to: ↑ 7 Changed 9 years ago by KadettGTE devilboy@…

errr the file is like this

#ifndef _XT_QUOTA_H
#define _XT_QUOTA_H

enum xt_quota_flags {
XT_QUOTA_INVERT = 0x1,
};
#define XT_QUOTA_MASK 0x1
struct xt_quota_info {
u_int32_t flags;
u_int32_t pad;
aligned_u64 quota;
struct xt_quota_info *master;
};

#endif /* _XT_QUOTA_H */

Changed 9 years ago by eisvogel äht embinet döt de

package/iptables/patches/009-iptquota.patch (compile fix)

comment:9 Changed 9 years ago by MMCM <mmcm@…>

Fine, works for my wl-500gx build :-)

Please, include it into the official trunk!

comment:10 follow-up: Changed 9 years ago by florian

  • Milestone changed from Kamikaze to Afterburner 7.09

I cannot reproduce the bug with trunk or 7.07, do you confirm the bug is there ?

comment:11 Changed 9 years ago by KadettGTE devilboy@…

i can try it on latest trunk if you want, but have you already added the patch? if so the bug won't be reproduceable.

If you want me to try it just post here :)

thanks in advance

comment:12 Changed 9 years ago by Boop

One problem with the patch:

Applying ./patches/009-iptquota.patch using plaintext: 
patch: **** Only garbage was found in the patch input.
Patch failed!  Please fix ./patches/009-iptquota.patch!
make[3]: *** [/home/devel/kamikaze/build_test/trunk/build_mipsel/linux-2.4-brcm/iptables-1.3.8/.prepared_35d66274593cef8312c1d4a9a1bda72a] Error 1
make[3]: Leaving directory `/home/devel/kamikaze/build_test/trunk/package/iptables'
make[2]: *** [package/iptables/compile] Error 2
make[2]: Leaving directory `/home/devel/kamikaze/build_test/trunk'
make[1]: *** [/home/devel/kamikaze/build_test/trunk/staging_dir_mipsel/stampfiles/.package_compile] Error 2
make[1]: Leaving directory `/home/devel/kamikaze/build_test/trunk'
make: *** [world] Error 2

comment:13 Changed 9 years ago by Boop

Sorry, it works fine. thanks

comment:14 in reply to: ↑ 10 Changed 9 years ago by anonymous

Replying to florian:

I cannot reproduce the bug with trunk or 7.07, do you confirm the bug is there ?

dl tonight's trunk from svn , and the bug is still in there

comment:15 Changed 9 years ago by kadettgte devilboy@…

hummmm it wasn't yesterday

comment:16 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [8472].

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.