Opened 9 years ago

Closed 9 years ago

#2143 closed defect (worksforme)

ar7-port continuously reboots

Reported by: brian@… Owned by: nico
Priority: normal Milestone: Kamikaze 8.09 RC1
Component: kernel Version:
Keywords: Cc:


Recent snapshots of 8088 and newer continuously reboot after about 20 seconds after the boot process is finished. I am unsure of which svn snapshot this began as I went back to svn version 8000. This is occurring on an actiontec GT-701 DSL modem. I built an image with just the ppp modules, and the tiatm driver, and it still rebooted. The most basic image I could build still rebooted. To reproduce turn the modem on with a recent snapshot. Watch it reboot over and over.

Attachments (1)

ar7-wdt-kick-debug.patch (751 bytes) - added by Axel Gembe 9 years ago.
watchdog kicker debug

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by nabcore

This is just a guess, but does applying the patch in #2140 resolve this?

comment:2 in reply to: ↑ description Changed 9 years ago by brian@…

I did svn snapshots until I discovered which change was causing the reboot. svn r8117 with the watchdog timer is what is causing the restart. Apparently the watchdog daemon is getting false positives and after about 30 seconds reboots the modem.

comment:3 Changed 9 years ago by nico

  • Milestone set to Afterburner 7.09
  • Owner changed from developers to nico
  • Status changed from new to assigned

comment:4 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Should be fixed with [8280]

comment:5 Changed 9 years ago by brian@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

The modem reboots after 10 seconds now. This is about 1/3 the time it took before. I updated to svn 8280. Disabling the watchdog fixed it once again.

comment:6 Changed 9 years ago by Axel Gembe

Please try the ar7-wdt-kick-debug.patch patch. It should output some debug information about watchdog kicking. It won't make it work, but we'll see if something is even kicking the watchdog.

Changed 9 years ago by Axel Gembe

watchdog kicker debug

comment:7 in reply to: ↑ description Changed 9 years ago by brian@…

Please mark this as closed. This bug has been resolved.

comment:8 Changed 9 years ago by Axel Gembe

I'd like to know your solution, please.

comment:9 Changed 9 years ago by brian@…

svn was broke for a few days, and I was running svn 8200. When I updated to the latest snapshot the snapshot on my computer broke. I started fresh with a new .config and rebuilt. The router no longer reboots. I did try to use the patch to learn what was triggering the reboot, but the svn snapshots were broke. First try the latest svn snapshot for the latest changes to ar7 which I have the TNETD7300 and I noticed new patches against that revision regarding the watchdog timer. That build didn't load the network so I waited two days and the svn snapshot is mostly working now. (config doesn't set the network options for the build.) Before I was going to apply the patch for the verbose debug output I tried just a plain build with no changes. The router works now with out rebooting with the watchdog enabled.

comment:10 Changed 9 years ago by nico

  • Resolution set to worksforme
  • Status changed from reopened to closed

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.